Need More Info Character textures don't show up on character creation

Users who are viewing this thread

Version number
No, I didn't use any mods.


Summary: Just as the title says and this two threads stated, is the same thing:
Happens while loading a campaign as well. whenever characters textures show up games freezes.
On Multiplayer makes almost everyone invisible, note is not everyone.

Tried workarounds like deleting shaders folder, verifying game files and have the w7 platform update installed.
Didn't happen until 1.8, 1.7.2 worked "fine"

How to Reproduce: Character creation, party screen or custom battle
Have you used cheats and if so which: no and clean installation with no mods

Computer Specs:
OS: Windows 7
GPU: Radeon RX 560
GPU Driver Version:
CPU: i5 4570 3.2ghz
RAM: 8gb ddr3


Community Support
Community Support
Hey, sorry for the late reply. Are you still experiencing the issue? Recently we have released a list that includes most of the known workarounds for the known issues. Please have a look at the list and let me know if the issue is persistent after following the steps in there.


My understanding is this also affected 1.7.2 but less severely, and you could still create characters and would manifest as randomly freezing after some time ingame or after a large battle. It only seems to affect Windows 7 / 8 and GeForceNow users, and those of us on Windows have a workaround. Over on Microsoft's website you can grab Process Monitor and running that in the background gets asset loading unstuck.

Just remember to limit the log file to its minimum (options -> set history history depth -> 1 million entries) or it'll eat all your RAM. If the most recent version refuses to load on your machine, others have had luck grabbing older versions off the Wayback Machine or by installing Windows updates.
Top Bottom