• If you are reporting a bug, please head over to our Technical Support section for Bannerlord.
  • Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

Changing Versions and Installing Beta

Users who are viewing this thread

Joe Friday

Veteran
First allow me to ask for forgiveness. I'm not good at navigating through the support forum and also not good at using the search function.
My computer crashes almost immediately once I start a battle. It has been doing this ever since the 1.6.4 update. I've tried multiple fixes including a clean install. I was only able to send one crash support because usually when the game crashes it also shuts my monitor down. For this reason I'm not able to send in the appropriate info for a ticket.

Anyway, I'm thinking of either downgrading to 1.6.3 until 1.6.5 becomes available or better yet I think trying the 1.6.5 beta is the safer option.

How in the world do I get the beta to start installing through Steam? It tells me I need to enter a code but I have no known way to receive said code.
Thanks
 

Poddicus

Knight at Arms
M&BWBWF&SNWVC
Just click on the beta / previous version from the dropdown and exit. Should start updating automatically.

JWnMOyf.png
 

Ser Jon

Squire
M&BWBWF&SNWVC
This just makes me repeat my suggestion to the TW team: make the beta branch and telemetry tool version separate installs. Then half of this confusion wouldn't happen so much.
 

Joe Friday

Veteran
This just makes me repeat my suggestion to the TW team: make the beta branch and telemetry tool version separate installs. Then half of this confusion wouldn't happen so much.
Yeah I was totally confused. It didn't help my problem though. My game crashes in one to 5 minutes after starting a battle. Usually closer to a minute. I don't know what to do. I'm unable to put in a proper ticket too cause when it crashes my monitor shuts down as well. I can play MP without issue though. I'm about to pull up a very old save to see if it's an issue with my saved game files. If I can't figure it out I guess I'm at a loss.
 

Ser Jon

Squire
M&BWBWF&SNWVC
It sounds like Bannerlord is just finding a larger issue with your PC and is causing a shut down, not necessarily Bannerlord (such as power delivery issues or PSU issues). We can rule that out though, if you are willing to try to run through some preliminary troubleshooting options.

If so, uninstall Bannerlord. I know, that's annoying, but it's necessary. With it uninstalled, install a program called CCleaner and run the registry cleaner. Backup anything and then select the option to "fix all selected issues". Once it is done, reboot your PC. Now, before re-opening Steam, navigate to where Bannerlord had been installed and make sure no left over folders were left behind (Steam usually does this so be sure to check). Once you have deleted those, reboot Steam and re-install the game. Test it. Does it still happen?

If yes: backup your Documents folder for Bannerlord (make a copy to the desktop or something) and then delete the entire folder from Documents. Reboot Steam. Relaunch Bannerlord and check for the same problem. Does it still happen?

If yes: check your GPU drivers. If it is old, very old, update. If it's new, you can try to do a clean install of the drivers with DDU (if you want to do this, let me know and I can walk you through it). Once it has been updated, reboot PC and then relaunch Bannerlord and check for issues. Does it still happen?

Finally, does anything like this happen for other games?
 

Joe Friday

Veteran
I recently updated my NVDIA drivers earlier this week. The game will play with no issues in MP. It's just SP that gives these issues. It started after the last 1.6.4 update. I'll look to see if it does it when I start a new game. If it does then I would assume it's not a jacked up saved game file?
If it still messed up then I'll try to reinstall everything again. I did a reinstall yesterday and deleted the documents and program data folders it told me to delete from the crash troubleshooting guide. I have NOT tried the CCleaner though.
 
Top Bottom