CD Key not validating?

Users who are viewing this thread

MINTEEER

Recruit
Hello there
Two days ago I bought Mount and blade Package from steam. Napoleonic and With Fire and Sword online works, but when it comes to Mount and Blade Warband multiplayer, when I provide the CD key it says that it is invalid. I contacted Paradox Interactive and Iv got this for the response ''Paradox no longer owns this IP, please contact TaleWorlds for support with this product: taleworlds/com/en/Home/Support''. I did fill out the form but when I tried to send it it said ''Your message could not be registered in support system. Please try again later.'' Iv tried yesterday and today few times, with the same result. I dont know what to do. Does anyone have any solutions or contact to TaleWorlds support?

Best Regards
Jakub
 
Hi Jakub,

I'm currently trying to help out fellow warbanders like yourself, with the same issue as you in this thread. Please provide a screenshot at the point of being asked for a serial key so we can get this great game running!
 
Back
Top Bottom