BL Coding Can't modify native troops, but can rename them and add new ones?

Users who are viewing this thread

DatBoiCV93

Recruit
So i've a question. When i try to mod the existing native troops in a new mod, the changes does not take effect in-game. I Can easily add a new troops or rename the existing ones in when i copy the spnpcchracters and it changes in game- But if i try to change gear or so on native troops, it simply does not take effect in-game. Does anyone know why this is?

For example, here is my mod that adds more units, but any changes i tried to make on native troops just never...shoved up. So i deleted those changes. Is there anything im missing in therms of the submodule? (as you see i just kept the xml-files on the soldier i edited now. Previously i had a copy of the full one that bannerlords has and made many changes, none which happened in game.)

 

vota dc

Sergeant Knight at Arms
M&BWB
For adding troops there Is adonnay troops changer.
But if you really want to replace native troops you can change their skills and It works, changing the gear Is more difficult because they get free stuff, for example if you convert a cavalry to infantry they still have a chance to get horse even if you removed them from all their gear.
 
Upvote 0

Big_Guy_4_U

Recruit
I also have the same issue, except before I made the mod a module and when I was just replacing Vanilla spnpccharacters file, it worked like a ****ing charm! This modding system sucks!
 
Upvote 0
Top Bottom