In Progress Can't launch warband, please help (Steam version/ Windows 10)

Users who are viewing this thread

Eärendil Ardamírë

Subforum Moderator
Try it with deleting this folder
%APPDATA%\Mount&Blade Warband\
But then I am pretty much out of ideas.

C:\Users\you_user_name\AppData\Roaming\Mount&Blade Warband
C:\Users\you_user_name\Documents\Mount&Blade Warband
Deleting this folder will delete the saves and settings. You need to try to clear all information in the registry about mount blade warband and do a clean reinstall via Steam (trying with steam again).
Hello all!
BLUF: I believe this problem is caused by OneDrive and the solution lies in making sure the savegame and user profile data is saved on the local device.

Details: I've finally cracked this code (for me, anyway). I had this exact same issue, and found someone who recommended to re-install Windows 11. I did, and it worked, but only for a short time before it went back to the same exact issues - no window, no program, just hung in the launching sequence. Then I tried finagling with my savegame files and user profile data, deleting both, and lo and behold it worked again, just in time for it not to work again.

It occurred to me later in a flash that the only difference was me turning onedrive off and on. Essentially, the savegame and profiles were being saved in the cloud, but when I shut off onedrive and removed it from my startup sequence, then the data was trapped in the cloud while still having a semi-valid filepath. Thusly, MB would launch but then get stuck when there was no data to pull from.

I right-clicked the files/data and chose to save to local machine and it's worked flawlessly since then.

I really hope this easy solution helps the community! I've seen a huge rash of these problems which had the same exacty symptoms as mine, but with no real solution.
Top Bottom