Can't Connect To Servers

Users who are viewing this thread

My friend can't connect to servers on m&b he asked me to post this for him because he cannot connect to these forums or the main website for some reason, so here is what he said:

since the recent server hack, my servers wont laod for me. i have tried litterally everything. from restarting my pc. to changing my ip address. nothig works. i went to school to try it, and it worked, but at my home conection its not working. no servers will load. does anyone know what i can do?
 
Hi Gameplayor,

When was the last time your friend could connect to a server? Has he downloaded software or changed settings in his registry to modify his ping? Has he checked of the filter settings when searching for a server(sounds dumb but it happens :razz:)?
Can I asume he's playing on a laptop because he tried warband at school?

There are issues known for TW having faulty servers due to last events but everything should be stable now.

Hear from you soon!
 
Hi,

It looks like there is some kind of network filtering going on. This could be a DNS conflict, a router problem, a firewall issue or something that drops a time-out on the request to refresh the server list. It's not legally for me to look into the game itself so I cannot be of much aid and this should be post forwarded to the developers of warband as a bug.

One thing I can recommend for the time being is going to C:\Program Files (x86)\Steam\SteamApps\common\MountBlade Warband or if you're not using steam going to the warband folder. Once there check for a file called rgl_log.txt. Open it with notepad and look if the following values are the same:

use_instancing : 0
use_secure_connection : 0
max_number_of_connections : 16
look_for_server_on_this_machine : 0

Your friend is not the only one having this issue and I hope it willresolve itself.
Keep on notifying the situation!
 
hello, this is his friend, (the one with the problems). i have disables my firewall. didnt work, but as i was trying to figure it out, i went to my favorites, it loaded NI_Normal_EU3 server and when i tried to connect, it said " verifying serial key" and then it wouldnt verify it, i have a legit copy of the game. i am going to try and get a friends key, and see if it works, this way i will know if its my internet, or my game. there is another player i know of from the same country i am in, (canada) he is having the same issue.

ps: the reason i had my buddy post this was because taleworlds.com or anything with "taleworlds" in the URL will not load... i have no clue why, or why this is connected to my sever issue.

i will try the things you said to do in the
RGL note pad. if those dont work, i have no clue what to do, i really hope it will resolve it on its own.
 
Hi,

The RGL notepad is a log. Changing anything there won't help. It was a reference to see if your values are the same as mine.
Now that you mentionned the word "taleworlds" not working indicates that you have a filter going on either in firewall, ISP or DNS.

You already tried without firewall and its not working so we can scratch that.
To go around the DNS goto C:\Windows\System32\drivers\etc. You'll see a file called "hosts". Right click and open as administrator. At the botom of the file there is a "127.0.0.1      localhost". Bellow that you should add "162.159.252.73      www.taleworlds.com"

Save it and restart your browser. If website won't work, server refreshing won't work.
 
Ok so you said that at the bottom. It should say.

127.0.0.1 local host.

Mine does say that. But below that line (127.0.0.1 local host)
It says ::1 local host.

So right now. My hosts notepad thing. Looks like this


#    127.0.0.1      Localhost
#    ::1              Local host
126.159.252.73 www.taleworlds.(())com


It still does not work. Taleworlds still does not work. Have i done it right?

Ps: the (()) is just so that i can post it. THey wont let me post this reply with a link in it. But it does have a .com at the end. Not the (())
 
Hi darklit,

The reason why this solution is not working is because you wrote down the wrong IP adress. It's 162.159.252.73
Give it another shot and let me know!
 
This isreally getting annoying... Thank you very much for helping me thiugh. I did what you said . Taleworlds.com is working. But the talewords forums isnt working. Neither is the servers. I now have both ehat you said and what tale worlds twitter said in the hosts file. Servers both arent loading.
 
Hi darklit,

I'm happy that I could be of help. Would you mind posting how you have fixed it for future reference of people with the same situation.
 
Back
Top Bottom