• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

Resolved Cannot Start Game (Tried All Fixes In Sticky) UPDATE: FIXED

Users who are viewing this thread

Version number
Yes, but I removed mods.



I new it I knew it I KNEW it would be something stupid. My OneDrive on the PC had those stupid Mod files saved still, and even after deleting those same files from OneDrive website, it kept blocking me from removing them on my pc. Well, after fiddling with everything I noticed the DELETE option in file explorer, there was a little menu arrow, so I clicked it and just "Why not?" selected Permanently Delete, from the drop down menu. For SOME REASON that successfully deleted the old Mod files from OneDrive, and the game works like a damn charm now.
I have not seen this as a fix ANYWHERE online, so I'll leave up my whole issue and my progress going through it, incase it helps someone else. Not sure how to change the red Unresolved to Solved. Hopefully a moderator can help with that.

I hope this helps someone if they are in the same boat as I was.

Summary: Installed Bannerlord 2 on a new computer. Launcher starts up but when I select Single Player and hit Play, nothing at all happens. If I check steam is says the game is running and I cannot "Stop" it. I have the go to task manager and find the process in Processes or sometimes in Details, and End the Task, in order for Steam to read the game as no longer running. Been doing this for 2 days now trying various fixes I've found online. Nothing has worked for me. (I used to play on an older PC and used Mods. None on THIS new PC)
I have tried ALL the fixes I can find online. I CAN still install and play the game without issues on my old PC, but this new one isn't having it. No issues with any other games. I built it back in January and hadn't installed Bannerlord 2 again till recently. On my old PC I had a couple mods but I purged them, and have NO mods on this PC. The only Mod files I can find at all are in my OneDrive and I cannot delete them. Below is a list of what I can remember trying already.

One odd issue, when testing out if maybe I needed to replicate the same mods I had on the Old PC, I noticed when downloading a mod from Vortex, it would notify me I already the Mod and asked do I want to download again. Not sure if this is just Vortex tracking my account or if it's reading the mod from my OneDrive. I scoured my (NEW) PC for any mods at all to clean them out.

Safe Reboot
Clean Uninstall and Reinstall
Validated Steam files
Verified latest version of Windows 10
Verified latest GPU Drivers
Installed the C++ (etc) files from the sticky
Completely turned off AntiVirus/Firewall just to be sure. (Using AVG. Kind of a pain.)
Deleting the CNs file
Deleting "temp" files
Scouring New PC for any Mod files, especially related to "FIXED Launcher" mod. Could only find ButterLib and MCM files in OneDrive. Could not delete.
Switched to older Bannerlord versions.
Switched to 1.6.3BETA version. (Didn't work so went back to e1.6.2)
Used "-Windowed" command on Steam
Tried using the Bannerlord.exe, Native, BannerBE to launch game. It gives me a loading icon then nothing. In Task manager it shows the processes trying but nothing happens, and I have to End Task.
Set Bannerlord.exe, Native, BannerBE, and TaleWorlds.MountAndBlade.Launcher to "Open as Admin".

None of this has helped or changed the issue even slightly. I feel like it's a simple stupid issue but I cannot seem to get anything to work. Any help is most appreciated.

How to Reproduce: Not sure.
Have you used cheats and if so which: No
Scene Name (if related): N/A
Media (Screenshots & Video): N/A
Computer Specs:
OS: Windows 10
GPU: Radeon RX6800 XFX
GPU Driver Version: 21.9.2
CPU: Ryzen 5800XT
RAM: 32gb
Motherboard: Gigabyte X570
Storage Device (HDD/SSD): SSD NVME M.2 (1TB Samsung and 1TB RocketGaming) Bannerlord installed on (D drive, RocketGaming SSD.
Last edited:


Did some further work and found I CANNOT delete my documents/bannerlord2/config file. Also found these Mods that won't let me delete them. (See images attached.) I wonder if this has something to do with scrambling my game up. And if so, that's crazy, because I never even installed those mods on this PC. I had those on my OLD PC's Bannerlord 2 game.

[url=https://postimages.org/] imagehost[/URL]
[url=https://postimages.org/] [/URL]
[url=https://postimages.org/] [/URL]

My attempt to directly delete a file from the Butterlib Mod.
[url=https://postimages.org/] [/URL]

Any thoughts?
Last edited:

MArdA TaleWorlds

Community Support & Localization
Community Support
Thanks for the update. We have this part on our general workarounds topic. Have you missed this part or this did not helped?
  • Check your OneDrive folder contents. Even if it is disabled we have seen users post that their files have been changed with the previous OneDrive synced files. You should try deleting your OneDrive files. More info about that can be found here.
Last edited:
Top Bottom