Cannot get them to charge

Users who are viewing this thread

Sorban

Recruit
I must be doing something wrong but in the battle mode I cannot get my troops to charge. In videos they simplay say hit F1 and then F3 but that doesn't work for me. I have tried selecting the troops by hitting a number like 1, 2 or even 0 for all the army, then F1 then F3 but that does nothing except makes them into loose formation.

The only command that works for me is the troop number and then F6 which is they take command and then they tend to charge.

I can command them to move to various places on the battlefield using the mouse and then clicking or drawing a rectangle and release but as I said I cannot get them to charge.

Any help would be appreciated. It is a great game and later I feel I would need to know how to command the troops fully.
 
That's odd have you double checked to make sure the relevant F keys are working ?
Have you tried reset.... oh wait wrong fix lol
Can you get them to advance F1 then F4 ?
 

Sorban

Recruit
Thanks for your reply. I cannot get them to advance or charge. This is the screen I get.
IgnFYQw.jpg
 

Sorban

Recruit
I do not get this set of commands shown on some website about Bannerlord.

F1: Movement
  • F1: To position
  • F2: Follow Me
  • F3: Charge
  • F4: Advance
  • F5: Fallback
  • F6: Stop
  • F7: Retreat
  • F9: Return
 

R4MPZY

Sergeant at Arms
M&BWBWF&SNWVC
Normally when you press F1 ( F1 being the movement commands ) it opens up another chain of commands where F3 is the charge order.
Loose formation is F3(formation commands ) and then again F3, maybe it is bug if this doesnt open up another command selection for you ?

This is what you should get;
XvtTPy.png
 
Last edited:

Sorban

Recruit
Yes I see what I should be getting on your screen. Unfortunately I get the formation allignment screen next. This is what I get.
aHyA8PL.jpg

My mouse and keyboard battle commands are standard and I have no mods.
IXbAcnH.jpg

Thanks again for the reply. I must be missing some command.
 
To get infantry to charge it would be 1(select infantry), F1(movement orders),F3(specific commad)
If your F key is working then i would guess a file is corrupted or something.
Try going into steam right click the game properties > local files and verify the integrity.
Uninstall reinstall also a good option to try.
 

Sorban

Recruit
Thanks for the link. After pressing F1 there is not the corresponding follow up orders which include Advance and Charge.
I have Verified the installation and all the files passed good. The game works perfectly other than this one issue.
I have installed it on 2 other computers so will check see if they are different.
 

Sorban

Recruit
So the commands correctly come up on a different computer so it must be this PC or this keyboard.
 

Sorban

Recruit
It was my macros which I had for a different game. They used F1 and F2 for something else.
1XmRptB.jpg


So problem is sorted now. I'll remove those macros and the default commands should work. Thanks to everyone who replied!!
 

R4MPZY

Sergeant at Arms
M&BWBWF&SNWVC
It was my macros which I had for a different game. They used F1 and F2 for something else.
1XmRptB.jpg


So problem is sorted now. I'll remove those macros and the default commands should work. Thanks to everyone who replied!!
Enjoy :smile:
 
Top Bottom