In Progress Bugged double Ballista in Empire town siege battles.

Users who are viewing this thread

Version number
e1.6.5
Branch
Main
Modded/unmodded
No, I didn't use any mods.

MadDog001

Recruit
Summary: During the siege assault on Lageta and other Empire towns that use the same map, there are Ballistae on top of 2 towers and it's actually 2 inside of each other, one regular and one fire Ballista, even though I had destroyed all enemy siege engines during the siege bombardment on the overview map. They can be used simultaneously, so it's 4 Ballistae that seriously drive up my troops death ratio when they shouldn't even be present. This has been brought up before and it was said that is has been fixed, but it is not ->https://forums.taleworlds.com/index...-has-a-second-ghost-ballista-under-it.447708/
How to Reproduce: Besiege Lageta or any other town that uses the same map and attack when they have no siege engines left for defense.
Have you used cheats and if so which: No, but cheats are enabled
Scene Name (if related):
Media (Screenshots & Video):
1234orks9.jpg

Computer Specs:
OS:
GPU:
GPU Driver Version:
CPU:
RAM:
Motherboard:
Storage Device (HDD/SSD):
 

CptMuppet

Sergeant
Damn, dual wielding with siege equpiment. Bannerlord is really ahead of its time, I can easly see other games catching up with this trend when the next Mount&Blade game will be already released. Absolutely love it!
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Do you have a save file of session that you experienced this issue? With your save file, we can reproduce the issue much easier and faster. You can find your save file here:C:\Users\username\Documents\Mount and Blade II Bannerlord\Game Saves
You can send your save files to us via the ticketing system on the website. To send us a ticket, please visit the www.taleworlds.com site and login to your forum account from the top right. Click to "My Account" and then click to "My Open Tickets". You can create a ticket there and include the save file and as well as the forum link of this thread. You can find more info about how to upload files to us with the new ticketing system here. Thanks for reporting and sorry for any inconvenience!
 

Helerek

Recruit
I had same issue in Veron castle. Sadly I play on iron-man mode so I don't have save file. I will try to get it next time. Here is pic. This happened during a siege on Veron Castle. I had 2 fire onnagers + 1 Trebuchet ready, so 1 slot was still open. What suprised me is that I got 1 ballista, despite not building it and it was next to the onager. What suprised me more is that it was actually 2 ballista's.
2cqpw2ylevw81.jpg
 
Last edited:

TechnoSarge

Veteran
I definitely run into this problem a lot, because I siege like nobody's business. I was considering reporting before I found this. I'll see about saving off when I see it again and sending in the save file.

BTW, what tends to get my attention is not "dual-wielding" engines, but when I cream a ballista on the walls with my trebs before going into "lead an assault", its place is immediately taken by the mangonel that was hidden with it. I've regarded that as a big fat cheat against the player; it didn't really occur to me that it could be an issue with particular maps.
 

TechnoSarge

Veteran
OK, I ran into the double-engine issue tonight, at Varcheg. In the picture, my siege engines had just whacked their mangonel on the left tower above the gate, and a ballista appeared with perfect health. I saved, and upon continuing the engine duel the same happened on the right tower.

@MArdA TaleWorlds I am uploading my save file, referencing this thread. The devs ought to be able to see the second hidden engine on the righthand gate tower (though I can't!)
 

Helerek

Recruit
OK, I ran into the double-engine issue tonight, at Varcheg. In the picture, my siege engines had just whacked their mangonel on the left tower above the gate, and a ballista appeared with perfect health. I saved, and upon continuing the engine duel the same happened on the right tower.
That's not a bug. It's AI constructing sieges, while they have all 4 spots taken. In short the AI is storing the abundant sieges in their storage. You can see it sometimes when their siege machine is complete, but it disappears and new one is being constructed in the same spot. Doesn't always happen (might depends on wall lvl or workshops? idk). Also it's different bug than the thread.
 

TechnoSarge

Veteran
You're right - it's a different bug. I'll get off my soapbox.
Turned out I'd over-saved the file I sent in, so it's no good, anyway; it's not at Varcheg. Ah, the hazards of the save-and-exit button!
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
You're right - it's a different bug. I'll get off my soapbox.
Turned out I'd over-saved the file I sent in, so it's no good, anyway; it's not at Varcheg. Ah, the hazards of the save-and-exit button!
Forwarded this issue.
Also opened a ticket for the original reported issue. Will see if QA needs the save file for reporduction. Thank you!
 
Top Bottom