Bug Reports and known issues v2.3

Users who are viewing this thread


Master Knight
Bugs and known issues

Since one bug report topic is getting quite crowded with all the different verisons, we decided to start a new topic for each version from now on. This topic is for Version 2.3, both the Basic and the Expanded version. Please specify in your post if you use the Basic or Expanded version.

Before you post, you might consider looking through the list with reported bugs and known issues. It's possible your bug has already been reported. Also you'd better read the FAQ, because sometimes the errors you get can be solved by solutions posted over there. Furthermore, if you're having trouble, you can also ask for help at support.

General information:
As I work on the next update, I'll cross bugs I've solved.
Current version: 2.3
Next version: 2.4

List with known bugs and issues (v2.3)
- Naked Lords during feasts. No idea yet on how to fix it...
- The village elder in Yaragar is acting as a town guildmaster. Need to check it.
- Mercenary Page is lacking the C3. Fixed in 2.4
- One bright Templar armor: the Teutonic Mail. No idea yet how to edit the mesh in order to fix it
- The Foraging skill pushes the words of Ironskin in the skill list a bit too high. Still have to look into it for a fix: this is a known bug from the original code
- The banner bug. The overland map Banner is not the selected one. Fixed in 2.4
- Some armor hasn't got a female version, so females bulk up. Need to check it.
- Too dark and colourless food items. Fixed in 2.4
- Culture of conquered villages changes to the culture of the conquerer. Need to look into it.
- Nizar starts with a weapon he can't equip. Fixed in 2.4
- No available text in a quest to destroy a bandit lair. Need to look into it.
- City vendors don't display their vendor screen. Fixed in 2.4
- When you zoom into Sarranid cities, the trees that are part of the city model appear very blocky Need to check it.
- Barbary fur coat is missing its legs! My feet are acting independently! Need to check it.
- Some two-handed weapons clip through armors (might not be anything you can do about that though) Need to check it.
- Eastern Haubergon displays a menu icon, but I have an invisible torso while wearing it. Need to check it.
- In the battle menu (i.e. when you press backspace while you're on the field), the Action header is misplaced - it's on the combat map, not where it should be over the actions. Need to check it.
- Some troops cloth keep changing in  battle (such as swadian troops) First time I hear this... Pretty strange that people change cloths during siege. Need to check it.
- itm_armor_early_transitional_blue.dds and others are missing. They are present since 2.2, and are also present in the full version if 2.3. Also the brf-fiels check out correct. No fix needed it seems.
- If you have your own kingdom, all your lords are the rulers, and you are said to be a mercenary working for your own kingdom, faction relations become out of order. Need to look into it.
- No key for prison break. Fixed in 2.4
- No displayed faction name in the notes screen. Need to check it.
- The Savegame compatible version seems to be bugged. I'll have to look into that one.
- There's a crash when you change your hair colour to dark brown. Need to check it.
- Upgrading from I2 Woman Militia gives wrong options. Fixed in 2.4
- Impossible to siege Knudarr castle. Need to look into it.
- Uzundaq Castle is bugged. Need to look into it.

If your bug isn't listed in this list, but you did report it earlier and it's not solved in a next version, please report it again.

The following issues are not bugs!
  • An invalid item at the start of the item list is actually a line of code that determines where the item list starts. Don't worry, this 'item' won't appear in the shops or on soldiers. I can't turn its display in the list off.
  • There are some items, like bolts, which are double and cost nothing. These are actually training and tourney items: the list displays all items, also these. You won't find them at the merchant.
  • There are some head cloths that are displayed sidewards in the list. These are native items which appear correctly in the game.
  • There's a whole bunch of coats with different names but the same Royal mesh. These are all native: apparently they are reserved for future additions.
  • The musket is a native bonus item.
  • Some throwing weapons have double stats: these items can be used both as ranged as melee weapons. Likewise you can find in the one-handed section similar items: the melee versions of these weapons.
  • Seeing trees that are not part of Polished Landscapesis not that strange, since they are also part of this pack.


Plate boots are missing their texture and names no longer fit in the character upgrade screen.




File issue.. Game crashed during the start quest at the city fight portion. itm_armor_costumes1.dds was missing according to the error window after the crash. I just wrote the file name down but double checked before posting here. The file is there in the texture folder, but I did notice that in the error window  "modfolder/textures//filename" missing.. Think the mod probity just error on the // part not the file itself..  :mrgreen:

Bug squashing is fun isn't it?  :lol:


I fixed my missing textures by getting the new 2.3 full download an copying the folders to my installed folder


Using a 2.1 Save, through 2.2, now into 2.3.. (Expanded Mod)..
Downloaded patch (11.47MB right? - could this be put on Downloads thread?) and installed as per instructions..hopefully
Got a list of - Can't find materials - Plate boots, Basinet, Heritage shield and 'we spak2'?
Loads OK though..

*No major issues to speak of - works ok so far, if anything a bit smoother.. :smile: *

Received this error at one point:
Sorry not sure what I was up to .. beating him up I think..

Gonna try the torrent of whole 2.3 Exp instead - when it's through..

Still got no sallet helm texture and some bare chested lords (Urmada), and had a few other red error texts pop up (once in the options menu, can't remember other one..)
'Mercenary Page' has no C3/I2? code..
Do Cavalry dismount when stuck? This would explain some 'empty' horses at my start position during battle.

Could be I've installed it badly. Could be my old save. Could be the patch..
Will give better report after playing 2.3 Expanded whole mod, not the patch.
I will seed torrent as often as I can when it's through..

But ... Like a fine wine (or a strong cheese :grin:) this mod is maturing very nicely...
GREAT WORK PEOPLE and TYTYTYTY :mrgreen:  :oops:
:mrgreen: :mrgreen: :mrgreen:

Ps Already loving the extra stuff: food reports, foraging skill, etc, etc,
(foraging skill pushes the list out at top slightly though..)
Also I stopped training at Yalen .. I don't even own Yalen ...


Hieronymous said:
Received this error at one point:
This should be due to your old save. A new game (since 2.2) shouldn't ever display this error. Someone speak up if they are getting the above error in a game that was new with either 2.2 or 2.3, please.

Hieronymous said:
...had a few other red error texts pop up (once in the options menu, can't remember other one..)
Would be great if you could catch 'em :smile:

Hieronymous said:
Do Cavalry dismount when stuck? This would explain some 'empty' horses at my start position during battle.
Yeah, they can. Annoying AI. Sometimes it helps if you give the cav a "mount" order, or be sure to keep them relatively un-surrounded as you're getting set up before the battle starts.

Hieronymous said:
Ps Already loving the extra stuff: food reports, foraging skill, etc, etc,
(foraging skill pushes the list out at top slightly though..)
Also I stopped training at Yalen .. I don't even own Yalen ...
Which list is foraging crowding out? The Character page skill list?
And the training thing...my guess is that's something to do with the new version of Diplomacy in 2.2 (and in 2.3). Waihti made a number of changes that were a bit less than save-game compatible--annoyances like that message, and paying for patrols you don't own--but they should be lessened in 2.3. If you get that message continually, let us know!


Cheers Caba'drin :smile:
Thought it was to do with old Save..

Have pics of options menu error (pics 1&2) and materials error (pops up on load but then opened recent messages - pic 2):
Pic 1
Pic 2

It's a new menu so...
Probably my old save game too..?
Think the other message was same as earlier pic post ('Received this error at one point')...? just different occasion/lord..?

Ps Torrent 2x, 3x quicker than download sites for me... maybe mention this on downloads page too? Thanks again.

Edit: Ooh yea. It's my character screen..
Not a biggy.. Old save again?
..also sometimes I have a pink border round my intro/splash screen (an old issue pos. from native) so insignificant I never mentioned it before :smile:  :???:
- Ah well! :grin: Thanks


i get the faction error in a new game but i have tweaked :razz: got it after taking quest from guild master in praven then i went back to him



Untill some else who know more bout textures puts up aaz download with the missing ones only way i know to fix is download the full 2.3 and copy the folders into your directory


Thanks for the fast response Hieronymous! I'll need to get back to you on where those other script errors are coming from.


Master Knight
Sorry, it seems that I made a little mistake when I made the patch. I've corrected it now, and replaced the links to the patch. You only need to replace itm_materials.brf and those 16 missing materials aren't missing anymore.
Damn it to hell!

I still have that banner bug :< Whichever banner I pick from the last page (and the last one on the second last page, haven't tried to check some other random ones) turns out to be that brown with someone in gold on it. I don't know what the hell is happening anymore, it was working in 2.1...

Expanded version, full download, new game.


I can confirm the character sheet spacing error. Iron skin gets pushed into the little detail at the top.

I'm not sure if this is a bug or not, but I noticed that some of the armor in the game does not have a female version, so when you put it on it 'bulks up' the female model, making her look very weird. Noticed this in 2.2 as well.

Various food icons (bread, grain, meat, etc) are now very dark and almost colorless. Is this intentional? It looks very odd, especially when compared to some of the new items that are very bright.


Here is my Bug list;

Using Floris Expanded Mod Pack 2.3; on a clean Installed 1.134 game.

The pale looking Food Icons. (artistic direction?)
Merchant of Tulga has a Twin.
A Lord of the Khergit Khanate (forgot his name) was topless.
The Banner problem. The overland map Banner is not the selected one.
Ironflesh obscured by Skill Icon!

Other than that, I want to express my thanx for merging this monster! Kudos for all the hard work

Top Bottom