Resolved Scene Editor BUG: Black texture on Main_Map 1.5.7 & 1.5.8

Users who are viewing this thread

Version number


Hello there,

Summary: When opening the Main_Map (modded or unmodded), either my project or the vanilla one the ground is black. I have verified the files for the base game and the mod tools and uninstalled then reinstalled for both 1.5.7 and 1.5.8. The problem persists.

I have followed a fix that Space_Pot8to from the Discord suggested to delete the ShaderCache in
C:\ProgramData\Mount and Blade II Bannerlord\Shaders\TerrainShaders\module_name\scene_name
But this has not helped.

However I did have some luck in turning the terrain texture back on when playing the game by transferring an older copy of the terrain.bin into the module file. The old terrain.bin was 63.5mb while the one generated by the mod tools was 59.9mb. But soon as I open this 'fixed' version the terrain texture goes back to black in the mod tools.

How to Reproduce: Its always there, I cannot turn it off.
Specific Tool: Official Mod Tools/Scene Editor

Computer Specs:
OS: Windows 10 Home 64-bit (10.0, Build 19041)
GPU: GeForce GTX 970 4GB
GPU Driver Version:
CPU: Intel i5-4690k 3.50GHz 4core
RAM: 16GB Ram 2133MHz
Motherboard: MSI Z97-G45 MS-7821
Storage Device (HDD/SSD): HHD 1TB
The does not work for myself when uploading the files. Please let me know of an alternative way of providing you the files.

If you need any further information please let me know. I hope you can help as this is frustrating to say the least and is hampering progress on my mod :razz: Cheeky plug of Calradia Expanded
Last edited:

MArdA TaleWorlds

Community Support & Localization
Community Support
Forwarded to the developers for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!

Misfit 1-3

I have same problem. Tried dumping the program data files, as well as shader cache files but no dice. Still is a problem with 1.5.8 official patch, seems to be a problem specific to whatever texture was used as the base for the campaign map, as attempting to build my own scene I ran across a texture that produced the same effect, but I can't remember the name of it.


Just touching on this again. I was told that this was going to be fixed in 1.5.9 but with the beta tools its still happening. I understand its low priority but its just frustrating.

Murat Türe

Sorry for your convenience. We have updated the beta editor to 1.5.9. This issue should have been fixed in this version. Can you give it a try?
Top Bottom