Need More Info Blank texture, game freezes(1.8.0)

Users who are viewing this thread

Version number
1.8.0
Branch
Beta
Modded/unmodded
No, I didn't use any mods.

Sciohan

Regular
M&BWB
Greetings! How long do players have to wait for a solution to the problem? 3 months the problem is not solved!
Last I heard, Taleworlds was still trying to acquire a Windows 7 rig to even reproduce the bug on, but that was months ago.

Until it is fixed, nothing is stopping you from using the workaround earlier in the thread.
 

Dziadu86

Recruit
Greetings! How long do players have to wait for a solution to the problem? 3 months the problem is not solved!
My Friedrich but it is. Check previous posts. Just run windows Process Moji
Greetings! How long do players have to wait for a solution to the problem? 3 months the problem is not solved!
I am doing just fine with workaround including Process Monitor. Gdy that came up with it is a friggin genius
 
Last I heard, Taleworlds was still trying to acquire a Windows 7 rig to even reproduce the bug on, but that was months ago.

Until it is fixed, nothing is stopping you from using the workaround earlier in the thread.
Wow! They've been fixing it for 3 months already, it's encouraging!
 

Sciohan

Regular
M&BWB
Process Monitor - does not work for me and gives an error.
The Internet Archive has older versions to try, versions newer than 3.61 sometimes fail to load on Win7 if it's behind on updates, especially those related to driver signing as it does load a driver. Related to that, you'll want to make sure you're running the 64-bit version (ProcMon64) in admin mode (right click -> run as admin)

Just don't forget about limiting its log size and all that.
 
The Internet Archive has older versions to try, versions newer than 3.61 sometimes fail to load on Win7 if it's behind on updates, especially those related to driver signing as it does load a driver. Related to that, you'll want to make sure you're running the 64-bit version (ProcMon64) in admin mode (right click -> run as admin)

Just don't forget about limiting its log size and all that.
Thanks mate, that seems to help.
 

Sheepify

Regular
Is this being worked on?

Experiencing the same issue with current 1.8.0 release version. 64-bit Windows 7 machine. Loading a save from previous game version causes immediate missing models/textures followed very quickly by game hang-up. Character creation fails to load character models during background selection, game hangs. Alt-tabbing and returning into focus switches the frozen view to the generic Bannerlord load screen, nothing happens.

Procmon workaround does not work for me.

I'd like to say I'm surprised a company Taleworlds' size did not plan on having even a single legacy Win7 testing computer available for a product sold as supporting that OS, but am not. Still, would bloody well like to be able to play the game I already paid for, and one that has been working without issues in that regard for a long while.
 
Last edited:

Sciohan

Regular
M&BWB
Is this being worked on?

Experiencing the same issue with current 1.8.0 release version. 64-bit Windows 7 machine. Loading a save from previous game version causes immediate missing models/textures followed very quickly by game hang-up. Character creation fails to load character models during background selection, game hangs. Alt-tabbing and returning into focus switches the frozen view to the generic Bannerlord load screen, nothing happens.

Procmon workaround does not work for me.

I'd like to say I'm surprised a company Taleworlds' size did not plan on having even a single legacy Win7 testing computer available for a product sold as supporting that OS, but am not. Still, would bloody well like to be able to play the game I already paid for, and one that has been working without issues in that regard for a long while.
I've seen in another someone claim to have been told a fix is coming for GeForceNow users who were having the same problem before it got temporarily pulled. Here's to hoping it'll extend to Win7/8 too.

In the meantime, can you elaborate on the workaround not working? Are you also getting a driver load error? Does it appear to be running and populating with events, but not preventing the problem?
 

TrashMan

Veteran
Win7 here.. Also Nvidia GForce (latest drivers) also same problem.

What did they F*** up in 1.8.0 that they cannot figure out in 3 moths?
 

Sheepify

Regular
What did they F*** up in 1.8.0 that they cannot figure out in 3 moths?
It's quite possible that they needed to update dependencies libraries into versions that allow console certifications, and those no longer support legacy systems or have issues with backward compatibility.

Normally you'd test to ensure that this doesn't break anything, especially for legacy support (Win7 is still being advertised on the store page, never mind having ~15% computer market share as of the last statistics I've seen), but this is Taleworlds. They don't even have a working Win7 test machine, much less bother to even try to launch the game before pushing a new release branch on Steam. ¯\_(ツ)_/¯
 

D0c1

Knight at Arms
The Internet Archive has older versions to try, versions newer than 3.61 sometimes fail to load on Win7 if it's behind on updates, especially those related to driver signing as it does load a driver. Related to that, you'll want to make sure you're running the 64-bit version (ProcMon64) in admin mode (right click -> run as admin)

Just don't forget about limiting its log size and all that.

Came here to share a workaround I've stumbled into for my fellow Win7/8 users. I got curious and started ProcMon64 so I could get some info on what was happening up just before it froze... and it simply doesn't. Texture loading performance in general is also much better. Only god knows why it works, but I'm sure the devs would be very interested to know as I imagine other debugging tools running alongside it may also prevent replication of this show-stopper of a bug.

The default log size of ProcMon64 is something like 199 million entries which over a long playthrough is sure to eat up significant RAM, but if you lower it to the minimum 1 million entries it won't be so bad. I don't know if you can grab it by itself either but it's part of the System Internals Suite hosted on Microsoft somewhere, won't be hard to find if you don't already have it.
my man, you're a game saver!
you saved me after i downloaded all those mods
 
Top Bottom