Unresolved Black Screen and painfully slow Loading during Startup

Users who are viewing this thread


Right. I have just confirmed this is also afflicting my installations of the original Mount and Blade (which is installed on GOG), so I will be crossposting this to that thread.

There is no easy way for me to say this, but I have not the slightest idea what has happened. I have had this game for years and years, and after some initial hiccups it was working fine, with quick load times on the whole (unless the mod was an absolute bear) and easy access in glorious Fullscreen.

I do not know what has happened since then, but something has gone badly wrong.

It started out with failed attempts to start up, telling me that Nothing will Render because it recognized the device I had chosen but said nothing would display, for....reasons I cannot comprehend. Like at all.

So I tried to verify the files. Which took a while but turned back with no issue. Only to still have a problem. Then I decided to back up what files I had and delete and reinstall. Still no luck.

Eventually I did some horseplay with the graphics settings, and that worked. Barely. It would now let me see the Talesworld logo, but then it would hit me with a black, unresponsive screen.

Then I try to adjust further, switching it to Directx 7 and/or windowed as some people suggest. That DOES seem to have had an effect, since now after initially hitting me with a black screen the game will show the load screen. But after quickly (and appropriately) finishing the first segment of the loading, it will immediately hit the ".ini file" Section of this and slow to an absolute crawl.

I have let this run and the game WILL load completely (though it takes a couple hours) and spit out the menu, but the game will still be extremely laggy and unresponsive. My few attempts to click beyond that to start a game show it starting up more or less as proper, but in an unplayably slow manner.

My computer is Windows 10 64x. My two display adapters are Intel(R) HD Graphics 530 and NVIDIA GEFORCE GTX 960. I have had both for years without experiencing any problems like this.

I also checked the health of my had drive, and in spite of the odds it seems to be "Good" according to CrystalDiskInfo.

Worse is that this seems to be localized to M&B 1 and Warband; no other game is suffering quite like this.
And as you might imagine as something of a computer neophyte, I am not at ALL eager at the prospect of going about uninstalling my display adapters or doing more radical steps to try and fix this.

Any help would be MUCH appreciated.
Top Bottom