Beta Patch Notes e1.5.8

Currently viewing this thread:

sdstran

Recruit
Seems fixed so far in new game. Been playing about 6 or 7 hors now and they still show up and are listed as expected.
The hotfix says “Fixed an issue that made some notables disappear when loading save files” <—
the last part seems to be important. Can you confirm that the wanderers remain after loading a game. The length of time played never made my wanderers disappear. They always disappeared after loading back into a game.
 

Dutch Toast

Recruit
yeah looks like i still have some existing icon problems.
screenshot as an example where you see the Vlandian footman (lower right corner) not having certain items in his icon.
this will happen also with companions, troops in my party etc.

have just continued from an existing save. will try a new game to see if that resolves.

steam screenshot
 
Why does no one mention the most jarring issue, which is memory leaks whenever you open any menu(character page, page in encyclopedia, settlement quick menu, trade, whatever) on 1.5.8???

From what I've gathered this also occurs on the stable branch, shouldn't this sort of thing get hot fixed?
 

Brocephus

Veteran
Why does no one mention the most jarring issue, which is memory leaks whenever you open any menu(character page, page in encyclopedia, settlement quick menu, trade, whatever) on 1.5.8???

From what I've gathered this also occurs on the stable branch, shouldn't this sort of thing get hot fixed?

I suspected there was a memory leak when I played last night because performance degraded over time. Thumbnail loading seems to be much better. I am still seeing some graphical anomalies in them but they're not as jarring as before.

I am playing with the Tournaments Expanded mod and finding it pretty tough to compete, at least early game. The thing that has always stopped me from participating later game when I can be competitive is that I don't need the prizes. They're really out of balance so I am hoping the mod will change that later game.

I'm also feeling like character progression is REALLY SLOW. Maybe because I was previously using some mods that balanced it better.
 
The hotfix says “Fixed an issue that made some notables disappear when loading save files” <—
the last part seems to be important. Can you confirm that the wanderers remain after loading a game. The length of time played never made my wanderers disappear. They always disappeared after loading back into a game.
Yesterday I loaded the game probably 12 times and still have the wanderers.
 

redmark

Squire
Nice, what I would really like to know is if wanderers are spawning in old saves now.
I should have the save I used to report as a bug initially - will check.

edit: No. My immediate post 1.5.8 upgrade/post-bug report save hasn't reloaded the missing wanderers. Notably, Istiana has disappeared from the encyclopedia search, but she has reappeared in Epicrotea and if I right click on her portrait her location is still 'never seen before' as it was in the pre-fix bugged 1.5.8.

I would guess wanderers spawning after that point should now not disappear, but the fix doesn't resurrect the ones who already disappeared.

(This would confirm the bug occurred on the save, rather than the load).
 
Last edited:

Brocephus

Veteran
I have a save where I am running the caravan escort quest and the caravan doesn't seem to get attacked and then it crashes. Every time. I am running a couple of mods but they are supposed to be good with 1.5.8. It's just so frustrating and disappointing.
 
Did anyone else's performance take a **** with this hotfix? I have been able to consistently run max settings plus DLSS on a RTX 2070 Max Q w/ an I7 but would always have to rollback the drivers. This time, even with rolling back the drivers, the game stutters a **** ton and it's not like I'm running some potato.

Doesn't matter if I turn DLSS off or push the graphics to the lowest setting, the stuttering stays there. Really sucks - back to 1.5.7 I guess

EDIT: Since there are some sad potatoes here - the memory leaks, icon loading, screen delays and menu issues are all gone on my end. Just performance stuttering surfaced.
 
Last edited:
I don't care about overall performance taking a nosedive please just fix these fking memory leaks and make menus open without 1 second delay it's giving me a headache!!!

It was working normally before, where is the problem in reverting whatever shenanigans you did !
 

redmark

Squire
I've only briefly had it running, and comparing to 1.5.7 rather than recent 1.5.8, but for me it seems a bit smoother and more responsive on the campaign map and a little 'crisper' graphically. Always such a variety of reactions after patches, BL seems to be very variable to different hardware setups. And mine is getting pretty ancient.
 

D0c1

Knight at Arms
for me it seems a bit smoother and more responsive on the campaign map
please post set up and frames on campaign map. i'm getting 40ish fps on campaign map before the latest hotfix with my i7-4790k and rx580 on mediumish settings
 

Blood Gryphon

Master Knight
WBVC
I'm checking out boys. I'm going to give these pikers a few months and see if they can get their poop in a group.
giphy.gif
 

redmark

Squire
please post set up and frames on campaign map. i'm getting 40ish fps on campaign map before the latest hotfix with my i7-4790k and rx580 on mediumish settings
Technically, it's pretty much a potato past its sell by date :smile:.

i5-4460, 16gb ram, 2x GTX-760 (one dedicated PhysX, no idea if that helps with BL*). Main issue for BL is GPU - on mostly low settings with a couple tweaked a fraction up, uses almost all available GPU ram. Don't usually have FPS showing on this PC, but just checked and getting a stable 45-48 on campaign map and a large battle; 60 (capped, screen tears if don't cap on my why-did-I-spend-that-much GSync monitor, when I actually need a better GPU) in menus. Compared to recent 1.5.7, subjectively seems smoother, didn't notice as much stuttering and menus definitely less laggy.

Will check on laptop tomorrow, which has a significantly better GPU, but was getting about 35 FPS on medium settings on 1.5.7 (much higher res, so low settings look unacceptably rough)...

*According to a wiki page for games with PhysX support, Bannerlord is listed - which surprised me slightly.
 
Last edited:
On the thumbnail side I put it through the ringer several times by using dev commands to load them all in a menu. Despite loading several times between separate towns they never got the loading screen.

it is possible soldiers thumbnails can look...off. Others have reported they missing a thing or two. For me they have to change uniform color depending on I guess last lord I talked to lol. But they do work
 

El Capitan

Sergeant at Arms
Also my siblings look absolutely nothing like me or my family! Anyone getting this/reported it?
Only Najun (the oldest one) looks like you, I'm guessing the other two are still a work in progress? Just wondering what's taking TW so long to make the other two look like your family member, It can't be that hard if they can do it for Najun. Oh well.
 
Last edited:
Top Bottom