Beta Branch with Telemetry Tools

Users who are viewing this thread

@Callum It looks like Taleworlds update this performance testing branch. Shouldn't you announce it to everyone so that they know?
I had spoken to devops about it yesterday and then had to prep for the german stream for GC. Just didn't get around to giving Callum a shout.

This branch is now using version 1.5.1. The upload issues *should* also be resolved.
 
Just as a general heads-up, we seek to keep this branch up to date with the live version of the game. This means it is currently running version 1.5.9. (It is probably a hotfix behind, but I have inquired about getting it checked and updated.)
 

Ser Jon

Sergeant at Arms
M&BWBWF&SNWVC
Have you guys considered offering the performance branch as a separate entry within libraries? So people don't have to update over their vanilla one and redownload 30gb worth of content every time? It could help a lot, not just for the devs, but for the users and their willingness.
 

Lesbosisles

Knight
Have you guys considered offering the performance branch as a separate entry within libraries? So people don't have to update over their vanilla one and redownload 30gb worth of content every time? It could help a lot, not just for the devs, but for the users and their willingness.
Would've been nice since I, for example, don't want to re-download the whole game once more...
 
Hey everyone,

we have updated perf_test to 1.6.0 and introduced perf_test_beta with 1.6.1. If you are experiencing performance issues on either version, it would greatly help us if you recorded and submitted them as described in the OP.
 
Hey everyone,

we have updated perf_test to 1.6.0 and introduced perf_test_beta with 1.6.1. If you are experiencing performance issues on either version, it would greatly help us if you recorded and submitted them as described in the OP.
@Lesbosisles @Dreed89 @Brentimus Maximus i saw you guys were having performance issues with 1.6.0 and 1.6.1, the performance test branch just got updated…Sending a file to TW should help
 

Dreed89

Sergeant at Arms
@Lesbosisles @Dreed89 @Brentimus Maximus i saw you guys were having performance issues with 1.6.0 and 1.6.1, the performance test branch just got updated…Sending a file to TW should help
Thanks, man. I had already submitted a detailed post with telemetry data for 1.5.10 or something in the past. It only got a little better, and now is worse again.

Starting to lose hope. :smile: Maybe I will do again for 1.6.1 if I can find time. Thanks...
 

Rush09

Regular
Tried to upload a test file throughout the day but from immediate connection reset after uploading, to site can't be reached, I wasn't able to.

Regardless, In my case I can tell what's causing the FPS drops. It's the loading of assets, the game staggers every time it needs to load assets. From constant fps drops while in the campaign map to the slow load of assets at beginning of tournaments and battles (even though the tournaments and battles are fluid once all soldiers and map assets have been loaded). In trade, the game moves sluggish while it tries to load item icons but proceeds to go fluid once all icons have been loaded. It is worse in 1.6.1 than it was in 1.6.0 though.
 
Top Bottom