• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

In Progress [Beta 1.6.0] Rival gang quest removes troops from party

Users who are viewing this thread

Version number
1.6.0
Branch
Beta
Modded/unmodded
No, I didn't use any mods.
Summary: Quest takes 4-5 of your highest tier troops to fight gang, and the remainder go missing from your party. I had 15 Elite Cataphracts, 5 joined the battle, and the other ten weren't in my party afterwards. I also had the quest fail when the opposing gang leader died during the battle.
How to Reproduce: Start quest, wait for gang leader to contact you, join battle and don't switch sides. Couldn't reproduce the second issue.
Have you used cheats and if so which: N/A
Scene Name (if related):
Save File: https://drive.google.com/file/d/1hswNihQCk6isvEW0ZRoFmjX5qJa6i-zN/view?usp=sharing
Media (Screenshots & Video):
Computer Specs:
OS: Windows 10 Home x64
GPU: EVGA GeForce GTX 1080 Ti FTW3 11GB
GPU Driver Version: 466.77 Nvidia
CPU: AMD Ryzen 5 2600X Six-Core Processor 3.60 GHz
RAM: 32gb ddr4 3600mhz
Motherboard: ASUS ROG Crosshair VII Hero (Wi-Fi) X470
Storage Device (HDD/SSD): HDD
 
I think my issue might be the same as this one.https://forums.taleworlds.com/index.php?threads/rival-gang-quest-bug-with-troops.444019/#post-9711636
 
No. I have not used cheats.
I did some testing yesterday. If I move the Fian champions above the cataphracts in my party, they get pulled in instead and I lose them instead. If I dismiss the tier 6 troops, it pulls my tier 5 troops instead. I gathered something like 24 legionnaires and ended up with only 5 after the quest. I believe in the thread I linked, the same thing happened to them. They had 2 billman, it brought one into the battle, and afterwards they only had the one.
 

Aguiazera

Recruit
The same thing just happened to me, i did the quest, had about 85 Fian Champions and after the quest was done, noticed that i only had 5 fian champions in my troops and the rest just disappeared. I closed the game and tried to start the last autosave, but now the game crashes everytime i try to open this save, have other save files from the same campaign but this save was way ahead in progress. What can i do? Patch 1.6.0 btw, and already tried to verify game files and fresh install.
 

oo0filthy0oo

Recruit
Same issue, No mods, New Save (30 days in), No cheats. 1.6.0

Before quest = 17 Infantryman

Battle screen = 3 Infantryman participated in fight (all survived)

After Quest complete = Only 3 Infantryman in party

The quest is using a small part of my army for the quest 3 out of 17 infantryman, the rest are looters under the battle screen. Then after the fight only the 3 infantrymen used in the fight remain. The over 14 infantrymen who did not fight are wiped.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Forwarded to the QA team for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
 
Top Bottom