In Progress [Beta 1.6.0] Garrison troops randomly convert to other troop types

Users who are viewing this thread

Version number
e1.6.0
Branch
Beta
Modded/unmodded
No, I didn't use any mods.

raflegan

Recruit
Summary: From time to time, a unit in the garrison of my city Lageta randomly converts to another troop type. This happens to around 1-2 units in the garrison per day. The troop most often converts from a high-tier unit to an imperial recruit (even if the original troop type was of a different faction), but less often, I have also seen a conversion from imperial recruit to another troop type. It does not seem to be triggered by any obvious event, it happens while I am just waiting in the city and there are no special events happening to the city (no other lords nearby, no food shortages, etc.).
How to Reproduce: I have a save game where this happens quite reliably when waiting in the city for 24 hours. It happened reliably in every one of the 3 times I reloaded the save game, after at most 24 hours (usually much earlier). Although the exact time of conversion and the troop type of the conversion seems to be random.
Save game download: https://drive.google.com/file/d/1ZttLgjQUUH0_HWeivHJvUPmPjI-mbmL0/view?usp=sharing
Have you used cheats and if so which: No
Scene Name (if related):
Media (Screenshots & Video):
Directly after loading the save game: https://drive.google.com/file/d/1k7sQu7K9rE-102_qH_80jOXd47562Gld/view?usp=sharing
After waiting in the city for 12 hours without doing anything: https://drive.google.com/file/d/1r5oMUfH6Gxf_AvoLlNjPyOuGeHBYAsYx/view?usp=sharing
(Note that the number of imperial recruits increased by one while the number of mercenary guards decreased by one - the total number of troops in the garrison always seems to remain the same.)
Computer Specs: This is a Shadow.tech machine
OS: Windows 10
GPU: GeForce GTX 1080
GPU Driver Version: 457.30
CPU: Intel Xeon E5-2677 v3
RAM: 12 GB
Motherboard: Blade ShadowM (probably a special configuration for Shadow.tech)
Storage Device (HDD/SSD): QEMU QEMU HARDDISK SCSI Disk Drive (again probably a special configuration for Shadow.tech)
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Forwarded to the QA team for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
 

Not

Recruit
It happens to me as well. I had a bit less than 200 garrison in each of my two cities. Came back after a while to see the number hadnt changed, auto recruit was off, but there were about 40 imperial recruits in both of my cities each.
Using beta 1.6

Edit: problem seems to be fixed by re-enabling auto recruit. My normal troops were no longer being deleted.
 
Last edited:
Top Bottom