Battle Time - Brytenwalda - How play multiplayer battles.

Currently viewing this thread:

Tchan

Veteran
WB
Hey just asking,  has anyone had any luck with the multiplayer side of things?
I know i need WSE, i have the newest version, but can someone help me out, i don't know what to do with them?
Cheers.
 

DennisBergkamp

Sergeant
All you need to do is copy the latest version of WSE (also make sure you have Warband 1.143 installed) into your warband installation folder.
Then run Brytenwalda by starting up warband through WSELoader.exe.

Now, anytime you start a fight, first click "Give me time to save". Save the game and click on the opponents again you want to battle.
Then, click "Setup Multiplayer battle", which will change into something like "Quit Game (won't save)". Click that, and you will be taken to the main menu. Press Multiplayer Game and click host game. Now you will be hosting the battle from the brytenwalda campaign, which other people should be able to join.

After the battle, click load game, and load your last save. Then click on the opponents you just battled, and select "Use multiplayer results".


I noticed there's still a few bugs with Brytenwalda and Battle Time though, plus a lot of the Brytenwalda-specific stuff (such as shield bash, tripping while walking backwards, extra backstab damage, ...) does not work yet. I also had some funny stuff happening to items, where their prefixes would disappear (a Chipped Warrior Axe turned into a Warrior Axe, for instance, and a Tempered Saxon Sword turned into a Saxon Sword after a fight). Hopefully this will be fixed  :wink: It's still loads of fun though to play with one or two friends.
 

Ninja

Regular
DennisBergkamp said:
I also had some funny stuff happening to items, where their prefixes would disappear (a Chipped Warrior Axe turned into a Warrior Axe, for instance, and a Tempered Saxon Sword turned into a Saxon Sword after a fight).

Yes, this is normal for Battle Time, I played the normal Battle Time! mod a lot and the problem is, that the multiplayer doesn't know other items than the normal ones. So chipped, tempered, balanced, heavy and so on get converted to the standard ones (even large bags of ammunition become normal bags). In the multiplayer it's not that much of a problem imo, but it's not so cool to buy a masterworked celtic longsword for 30k and after a battle via battle time you have a cheap one which has value of 5k or so.
Still, Battle Time is beast  :cool:.
 

Idibil

Grandmaster Knight
For Dedicated Servers:


1. Download and install the dedicated server files (works on your own pc or a rented server).
2. Install the Brytenwalda mod and WSE to the Warband dedicated server directory.
3. In the wse_settings.ini file set the path to be the same folder used by WSE for your singleplayer Warband: "storage_path = C:\Users\xxxx\Documents\Mount&Blade Warband\WSE"
4. Set up the *start.bat and change "mb_warband_dedicated.exe -r Sample_Battle.txt -m Native" to "WSELoader.exe -r Sample_Battle.txt -m Brytenwalda".

Sample
WSELoader.exe -r Battletime.txt -m Brytenwalda

5. You can start the server in co-op mode using "set_mission coop_battle" in the txt configuration file.

Sample
#WARNING: Make sure that you change the capital values with proper ones.
#uncomment the line below when you set a valid administrator password
set_pass_admin ADMIN
#if you have premium members, set a password for them, otherwise delete/comment out the line below
#uncomment the line below when you set a valid private password
#set_pass_private PRIVATEPASS
#uncomment the line below when you set a valid server name
#set_server_name SERVERNAME
#uncomment the line below when you set a valid welcome message
#set_welcome_message WELCOME MESSAGE
#Steam must be running in order to use valve anti cheat
#Also you must use the Steam version of the dedicated server in order to use this option
#set_enable_valve_anti_cheat 1
#setting battle (multiplayer_bt) mode
set_mission coop_battle
#setting max players, first one is non-premium member limit, second one is premium member limit
set_max_players 32 32
#set_num_bots_voteable 20
set_map multi_scene_1
#adding all kingdoms to both sides just to randomize all of them
#adding less kingdoms will reduce the randomization set (used in set_randomize_factions command)
add_factions fac_kingdom_1 fac_kingdom_1
add_factions fac_kingdom_2 fac_kingdom_2
add_factions fac_kingdom_3 fac_kingdom_3
add_factions fac_kingdom_4 fac_kingdom_4
add_factions fac_kingdom_5 fac_kingdom_5
add_factions fac_kingdom_6 fac_kingdom_6
...rest until 31
set_randomize_factions 1
#if the bottleneck is your server's bandwidth, then make sure that you set a correct value for upload limit
set_upload_limit 100000000
#if you are running more than one dedicated server on the same computer, you must give different ports to each of them
set_port 7240
#if you are running the Steam version of the dedicated server, this port must also be set, and same limitations of set_port apply for Steam port
#set_steam_port 7241
set_server_log_folder Logs
set_server_ban_list_file Logs\ban_list.txt
start

6. Once you join the server, go to the admin panel and either pick "Co-op admin panel" if the server is in a Native battle or "Load battle" if it is in a co-op battle.
 

Tchan

Veteran
WB
Thanks a lot, and cheers Dennis always been a fan :smile:

Had a couple of fights last night. One thing, i cannot control my troops like sp, maybe im missing some controls, but they all charged without me being able to stop them. Got my ass kicked too, very quickly. Hopefully the mp can ultimately mesh with the sp set of rules.
Anyways very very cool to be able to do this.
 

Bishimus

Recruit
Do you have a have a dedicated server for this to work? I've tried the steps you guys said to do, and the mp game does open up and is playable. However my friend can not find me on the server list
 

DennisBergkamp

Sergeant
@Tchan: You are welcome :smile:


@Bishimus: You shouldn't need a dedicated server. Is he trying to join on LAN? That should work fine right away (maybe try to kill firewalls on both sides).
If playing online, you need to be sure the router the hosting computer is connected to has ports 7240 and 7241 open.
 

Tsewe

Squire
M&BWB
hey guys i wanted to try for the 1st time with a friend this feature, but we had many problems and couldnt manage to play together. We've been trying for more than an hour now, please help us.

We downloaded the WSE and started the game with its loader. Than i hosted a game, but my friend couldnt join it since he didnot see it in the game list. So we found thi thread, i went to open up my ports 7240 and 7241, and my friend. But then he wanted to open the game with WSE and it crashed, telling a BRF file error. He couldnt open his game with the WSe loader no more (he had done it before though).
And then, i went ingame and tried to setup a multiplayer battle anyway just to see if it would work without him having the WSE, but guess what.... when i clicked on the enemy, the option "setup a multiplayer battle" was gone! it wasnt there anymore!!
I closed the game and reopened it (with WSe as usual) but same problem, when i start a battle, the option to setup a MP fight isnt even shown in the battle menu...

argh
 

jamiehamo

Recruit
Did using the WSE loader screw your village plundering abilitys in the game ? it apears that the WSE loader mess's up the village info and so on so no more plundering is availabel, can you pplase check this on your game guys ?
 

Noobke

Recruit
Brubar said:
hey guys i wanted to try for the 1st time with a friend this feature, but we had many problems and couldnt manage to play together. We've been trying for more than an hour now, please help us.

We downloaded the WSE and started the game with its loader. Than i hosted a game, but my friend couldnt join it since he didnot see it in the game list. So we found thi thread, i went to open up my ports 7240 and 7241, and my friend. But then he wanted to open the game with WSE and it crashed, telling a BRF file error. He couldnt open his game with the WSe loader no more (he had done it before though).
And then, i went ingame and tried to setup a multiplayer battle anyway just to see if it would work without him having the WSE, but guess what.... when i clicked on the enemy, the option "setup a multiplayer battle" was gone! it wasnt there anymore!!
I closed the game and reopened it (with WSe as usual) but same problem, when i start a battle, the option to setup a MP fight isnt even shown in the battle menu...

argh

Brubar.. I know I'm very late with this reply but it's because you probably canceled a multiplayer battle without finishing it, I've done this before and I got the same problem.
Delete the folders in:
C:\Users\<user>\Documents\Mount&Blade Warband\WSE
then start WSELoader.exe and try again, it should show the option 'setup multiplayer battle' now.

jamiehamo said:
Did using the WSE loader screw your village plundering abilitys in the game ? it apears that the WSE loader mess's up the village info and so on so no more plundering is availabel, can you pplase check this on your game guys ?


It seems fine to me, the same options are there in WSE as in plain brytenwalda
 

jamiehamo

Recruit
I dont understand why the WSE is messing my Brytenwalda up then. The option to coop battle when i help say a caravan being raided by bandits isnt there, i cant coop battle on sieges as the otion isnt there and alot of other infomation whist runnung the mod through WSE is all screwd up. Il post some screen shots to show...

Running as normal            http://imageshack.us/photo/my-images/259/runningthroughsteam.jpg/
Running through WSE        http://imageshack.us/photo/my-images/830/runningthroughwse.jpg/
 

Idibil

Grandmaster Knight
jamiehamo said:
I dont understand why the WSE is messing my Brytenwalda up then. The option to coop battle when i help say a caravan being raided by bandits isnt there, i cant coop battle on sieges as the otion isnt there and alot of other infomation whist runnung the mod through WSE is all screwd up. Il post some screen shots to show...

Running as normal            http://imageshack.us/photo/my-images/259/runningthroughsteam.jpg/
Running through WSE        http://imageshack.us/photo/my-images/830/runningthroughwse.jpg/

WSE is done for NAtive, maybe there are some confusion with strings.
 

jamiehamo

Recruit
Also if im a member of a dude faction i cant join a battle in coop either ? is that supposed to happen ? so i cant be in anyones faction and host a battle ?
 

pilouk

Recruit
When playing brytenwalda in WSE (for battle time functionality) it keeps saying that the mead hall is locked and the arena too.
It's been this since 1.38
 

Idibil

Grandmaster Knight
I have tried fix this, but I havent idea because it happen  :???:

Normal it run fine, but with WSE there is conflict with strings and locked doors.
 
Top Bottom