Need More Info Bannerlord won't launch

Users who are viewing this thread

Corndog

Recruit
My problem is that every time i try to run Bannerlord through the steam library it just doesn't launch. After clicking on the "play" button everything seems to be normal, my cursor is changing apperance, my nickname changes color to green as i would be in the game but that's all. After 2-3 seconds game "turns off".

I tried to:
  1. Verify Integrity of Game Files
  2. Run as admin
  3. Run with compatibility to w7,w8
  4. Downloading newest net frame work (though i had latest one)
  5. Several other things
HOWEVER I'm able to launch game from the game files by clicking on the Bannerlod, Bannerlord.Native or Bannerlord_BE app. After short while i'm in the bannerlord main menu ready to play both single and multi player. Also steam shows that i'm in the game, played time is counted but i'm not able to take a screenshot nor open overlay by shiift + tab.
 

Corndog

Recruit
Yeah. multiple things didn't work for me so i'm looking for help. Quite annoying to not be able to fix this **** since early afternoon.
 
Same problem here. The Community Manager posted this, but none of this works if you are on windows 8. I think it's because .net framework won't install on windows 8 as I already have the rest of the dependencies.

------
Software dependencies

If your game is crashing at launch or failing to launch at all, you should download and run the following executables.

Visual C++ Redistributable for Visual Studio 2015
https://www.microsoft.com/en-us/download/details.aspx?id=48145

.net Core
https://dotnet.microsoft.com/download/dotnet-core/thank-you/runtime-2.1.17-windows-x64-installer

.net FrameWork
https://dotnet.microsoft.com/download/dotnet-framework/thank-you/net472-web-installer

Visual C++ Redistributable for Visual Studio 2017
https://aka.ms/vs/16/release/vc_redist.x64.exe

(If any of these cannot be installed, you should try updating your Windows)


Security Software

The game uses a crash reporting tool that may be flagged by anti-virus programs and prevent the game from launching. You should check to see if any security software you have installed is blocking the game from launching.
 
Hey, I had the same problem! Windows 10 tends to identify some game actions as threats. (For me I actually have to do this for just about every game otherwise they won't save my progress. For Bannerlord, the issue manifested the same as yours.)

The fix for me was:

-Click the windows start button, then go to settings. It may take you to a recently accessed part of settings; navigate back to the windows settings home screen

-Go to the "update & security" settings

-Navigate to the "Windows Security" sub-heading

-Click "Virus & threat protection"

-Under the heading "Ransomware protection" click the "manage ransomware protection" button, it's in little blue text.

-Under "Controlled Folder Access" click "Allow an app through Controlled folder access"

-Click "Add an allowed app", "recently blocked apps", and then you should see that it blocked actions from TaleWorld.MountAndBlade.Launcher.exe, if so, click that.

-If it doesn't show up then this wasn't the issue (make sure you try this directly after trying to start the game so that it shows up in the list of course!)

Hope this helps!
 

betrivent

Recruit
Hey, I had the same problem! Windows 10 tends to identify some game actions as threats. (For me I actually have to do this for just about every game otherwise they won't save my progress. For Bannerlord, the issue manifested the same as yours.)

The fix for me was:

-Click the windows start button, then go to settings. It may take you to a recently accessed part of settings; navigate back to the windows settings home screen

-Go to the "update & security" settings

-Navigate to the "Windows Security" sub-heading

-Click "Virus & threat protection"

-Under the heading "Ransomware protection" click the "manage ransomware protection" button, it's in little blue text.

-Under "Controlled Folder Access" click "Allow an app through Controlled folder access"

-Click "Add an allowed app", "recently blocked apps", and then you should see that it blocked actions from TaleWorld.MountAndBlade.Launcher.exe, if so, click that.

-If it doesn't show up then this wasn't the issue (make sure you try this directly after trying to start the game so that it shows up in the list of course!)

Hope this helps!

Hey there, just want to thank you for your input. I tried everything previously and same as OP, my game would run for 2-3 seconds, and my steam icon went green, only for it to shut down. I tried updating everything suggested before, and same thing.

I then went and SPECIFICALLY (IMPORTANT) went to "allow an app through controlled folder access", only then did it show that it was blocking bannerlord executables.
 
I am having the same problem I have tried every fix in multiple forums does anyone know of a fix I'm not waiting for taleworlds to fix it cause I'll be here for ten years waiting
 

PapaNigs

Recruit
I am having the same problem I have tried every fix in multiple forums does anyone know of a fix I'm not waiting for taleworlds to fix it cause I'll be here for ten years waiting
Yeah I have the same problem and I have not been able to play for about 3 weeks now, I think mods might of ****ed up my game but i uninstalled them all and even reinstalled steam and my game and have tried everything
 
Yeah I have the same problem and I have not been able to play for about 3 weeks now, I think mods might of ****ed up my game but i uninstalled them all and even reinstalled steam and my game and have tried everything
yea same man ive uninstalled steam about 4 times the launcher just does not work at all i can launchfrom bannerlordBE.exe and bannerlordnative deleted all traces of mods and vortex deleted all save games havent seen taleworlds reply to anyone asking for a fix so i guess will just have to wait for a patch and hope that fixes it
 
Top Bottom