Need More Info Bannerlord will not launch from the launcher.

Users who are viewing this thread

Version number
e1.7.2
Branch
Main
Modded/unmodded
Unmodded

Cossack

Recruit
Summary: After I hit play (single or multiplayer) from the bannerlord launcher, simply nothing happens.

The same occurs for warband too. I have not been able to play these games for months after owning them for years.

Task manager reports that bannerlord starter is running but nothing else.
Game has been reinstalled multiple times.
Verified integrity multiple times.
Made an exclusion on Windows Firewall
all anti virus software removed.
GPU drivers updated.
How to Reproduce: (steam)
>Press play from game library
>Press play from bannerlord launcher (single or multiplayer)
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: Windows 10
GPU: GTX 1660 NVIDIA
GPU Driver Version: 30.0.14.9649
CPU: Intel i7-9700F 3 GHz
RAM: 16GB
Motherboard:
Storage Device (HDD/SSD): SSD
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Have you checked these workarounds?
‘Launcher not Launching’ / Game is not launching Workarounds
If you experiencing any issues with the launcher, you can try the workarounds below to fix it:
  • The first thing to do when experiencing any issue with the game is verifying the game files. After an update, there is always a chance of some of the game files being corrupted or missing. Doing this will verify that the game files are installed correctly. You can also check our guide regarding this here.
  • Deleting the configs folder of the game located in the Documents folder. Please keep in mind that this will also delete your saved options of the game. Don’t forget to back up the files if you don’t want to lose them. (C:\Users\user.name\Documents\Mount and Blade II Bannerlord\Configs)
  • You can try to delete the contents of the folder below and verify the game files afterwards. "steamapps\common\Mount & Blade II Bannerlord\bin"
  • If you have installed a mod called Fixed Launcher in the past, you need to make sure that you have deleted its files. These files can block the launcher from launching. The files of the aforementioned mod.
  • Check your Windows Defender settings for Ransomware Protection. You should add Bannerlord to the list under the Controlled Folder Access. To do that:
  • - Open Windows Defender Security Center.
  • - Click on Virus & threat protection.
  • - Click the Virus & threat protection settings option.
  • - Under "Controlled folder access," click the Allow an app through the Controlled folder access link.
  • - Click the Add an allowed app button to add Bannerlord.
  • Deleting the “spriteData.xml” file located in the "steamapps\common\Mount & Blade II Bannerlord\GUI\GauntletUI” folder can fix the issue. This is an obsolete xml file that the game is not using. However, if a mod is installed before changing this file, the game tries to use it and crashes.
  • Deleting the logs folder located under the "C:\ProgramData\Mount and Blade II Bannerlord" folder. Please note that the ProgramData folder is a hidden folder by default.
  • If none of the workarounds above helped you, you can try to launch the game via the TaleWorlds.MountAndBlade.Launcher.Singleplayer.exe and TaleWorlds.MountAndBlade.Launcher.Multiplayer.exe files located in the folder below:
  • ...:\SteamLibrary\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client
  • Check your OneDrive folder contents. Even if it is disabled we have seen users post that their files have been changed with the previous OneDrive synced files. You should try deleting your OneDrive files. More info about that can be found here.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Have you tried this?
  • You can try to delete the contents of the folder below and verify the game files afterwards. "steamapps\common\Mount & Blade II Bannerlord\bin"
 

Cossack

Recruit
Just did it then. Did not work.

I have 200 hours on the game. I do not know why it is suddenly not working.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Can you send us the file below after reproducing this issue again? Please keep in mind that the log files will be reset when the game is launched again. It is crucial that you should upload the files right after the issue has happened. Please also note that the ProgramData folder is a hidden folder by default.
C:\ProgramData\Mount and Blade II Bannerlord\logs\rgl_log_xxxxx.txt
You can send me the file via email to arda.gunduz at taleworlds dot com Please include the forum threads URL so that I can find it easily. Thanks!
 
Top Bottom