Modded Bannerlord keeps crashing after I conquer Onica Castle and destroy the Western Empire

Users who are viewing this thread

Version number
1.2.9
Branch
Main
Modded/unmodded
Yes, I used mods.
Summary:
NOTE: I originally posted this on Reddit which is why there is an EDIT section for the second paragraph.

For some reason, after I conquer Onica Castle, the game crashes once I move even a little bit towards a town or village. I've tested a few conditions with this. Even if I let another AI army conquer the castle, it still causes the same thing. Also, if I siege myself without having one of my AI armies take over the siege, it still causes the game to crash once I move too far away from the castle. In the error report, it said that Cheats could be causing the error, so I turned off Cheats (I used Cheats to add an extra companion after Distinguished Service promoted a soldier to companion). However, the crash still happened. The game still works perfectly fine if I load a save before Onica Castle gets conquered. What can I do to solve these issues? I downloaded all mods through Vortex if that's helpful information. I'd really appreciate any help!

EDIT: The issue still hasn't been resolved, but I fiddled around with console commands and it looks like Onica Castle specifically is what's causing the crash. I tried giving one of my conquered cities back to the Western Empire and then conquered Onica Castle. However, even though the Western Empire was still around, the game still crashed when I started moving. I also tried giving all Aserai territory over to the Southern Empire (my faction) to see if that would cause a crash. It didn't.

Have you used cheats and if so which: I used the Cheats mod to give myself an extra companion slot because of Distinguished Service giving a soldier I could promote to companion. I also used console commands during tests to see if it was the Western Empire causing the issues, or whether it was just Onica Castle that caused these issues.

Media (Screenshots & Video):

Here's the error report link:


Computer Specs:
OS: Windows 11
GPU: Intel(R) UHD Graphics 630
GPU Driver Version: 26.20.100.6911
CPU: Intel(R) Core(TM) i7-8750H CPU @ 2.20GHz 2.21 GHz
RAM: 16.0 GB
 
The crash you have reported originates from mods installed prior. Please note that we can’t support any modding-related issues. You can find more information about how to remove modifications here. If you can reproduce the same crash unmodded, please let us know! Thanks for reporting and sorry for any inconvenience!
 
Back
Top Bottom