• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

Resolved Archers shoot at cavalry only from a range of 40 metres or less.

Users who are viewing this thread

Version number
1.5.7
Branch
Beta
Modded/unmodded
No, I didn't use any mods.
As the title says, archers will shoot at cavalry (both melee and ranged) from distance of roughly 40 metres, if you order them to charge from further distance, thay will move towards the cavalry until they reach this aforementioned distance of 40 metres and only then will they start shooting. This behaviour also aplies towards player character if it is mounted. Strangely if you dismount or if you order your mounted units to dismount archers will react from correct range. Also if you and your troops mount your horse again the archers will keep reacting from the correct distance! Even if you dismount and then remount your cav at the beginning of the battle before you are in the range of archers will the archers react correctly. I believe this bug was present for quite some time.
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
As the asked information was not provided within 2 weeks, this thread is marked as solved. If the issue still continues, please update this thread.
 

Ananda_The_Destroyer

Master Knight
As the asked information was not provided within 2 weeks, this thread is marked as solved. If the issue still continues, please update this thread.
OBJECTION! I have the evidence right here! :wink:

Exhibit A: The enemy archers clearly shoot at my dismounted troops but don't shoot at me(mounted)! We are at max distance for this map!

Exhibit B: Only the ballisteer and the 1 Xbow man fire at me!

Exhibit C: All quite and peaceful, until I dismount my horse then the sky darkens with militia arrows! As described by the OP, they continue to fire on me after I re-mount my horse.

(from un-modded 1.5.7 beta)
Something goofy is going on! I have reported already my experiences with ranged units often not fireing on HA and Cav when I expect them too and in other forms being goofy about it! I have seen other report this type of problem too! Something is certainly wrong with their AI.
 

Kenzo-0-

Sergeant
OBJECTION! I have the evidence right here! :wink:

Exhibit A: The enemy archers clearly shoot at my dismounted troops but don't shoot at me(mounted)! We are at max distance for this map!

Exhibit B: Only the ballisteer and the 1 Xbow man fire at me!

Exhibit C: All quite and peaceful, until I dismount my horse then the sky darkens with militia arrows! As described by the OP, they continue to fire on me after I re-mount my horse.

(from un-modded 1.5.7 beta)
Something goofy is going on! I have reported already my experiences with ranged units often not fireing on HA and Cav when I expect them too and in other forms being goofy about it! I have seen other report this type of problem too! Something is certainly wrong with their AI.
That's one hell of a proof
 
Top Bottom