Modded Application Faced a problem, non-launcher launch works

Users who are viewing this thread

Version number
No, I didn't use any mods.


Summary: When i try to launch the game through the launcher it always says that application faced a problem, I tried deleting folders that were mentioned in many tutorials like: languages files, Config in documents, nothing has helped.

I found out that i can launch the game by simply opening TaleWorlds.MountAndBlade.Launcher.Singleplayer.exe in folder where steam launcher is, but there is a problem, cause i cannot play with any other module, cause it just simply opens game, no launcher mentioned. And my reason to write here is to play it with mods. Of course when I tried to play it through the launcher, even without mods turned on, it also didn't work.

I found out i can open the game using CMD command, but it only worked when i typed to launch with only the vanilla mods (Bannerlord.exe /singleplayer _MODULES_*Native*SandBoxCore*CustomBattle*Sandbox*StoryMode*_MODULES_ /anticheat).

The command i used to play with the mods (D:\Steam\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client>Bannerlord.exe /singleplayer _MODULES_*Harmony*ButterLib*UIExtenderEX*ModConfigurationMenuv5*Native*SandBoxCore*BirthandDeathOptions*CustomBattle*Sandbox*StoryMode*Cheats*_MODULES_ /anticheat) didn't work, also the crash of a problem that application faced a problem.

Tried also using CMD command with only Birth and Death Options mod, but also ,,faced a problem...".

Also used CMD and the same command but on other applications of Bannerlord here, like ,,Bannerlord.Native.exe" but also they weren't working or they did, but no mods were used in the game.

I know that you can't solve the problem with modded games, but I think that if you would be able to help me just with the problem of not being able to play the game through the launcher it would be a great help in my path to make my game be able to launch with mods.

Crash report when I tried to launch the game through the steam with mods used: 2023-05-26_19.08.59_ef5f29bacac9ff6d35e2a5bb417393be

Crash report when I tried to launch the game through the steam without the mods: 2023-05-26_21.12.02_ef5f29bacac9ff6d35e2a5bb417393be

Crash report when I tried to launch the game with CMD command, with mods included: 2023-05-26_21.20.23_ef5f29bacac9ff6d35e2a5bb417393be

How to Reproduce: Launching my game
Have you used cheats and if so which: None
Scene Name (if related): -
Media (Screenshots & Video): -
Computer Specs:
OS: Windows 10 Pro
GPU: Nvidia GeForce 1050 Ti
GPU Driver Version:
CPU: Intel(R) Core(TM) i5-7400 Cpu @ 3.00GHz
RAM: 16 GB
Motherboard: Prime B250M-PLUS ASUSTeK COMPUTER INC.
Storage Device (HDD/SSD): HDD


Community Support
Community Support
Hey, we do not offer support for the mods or modded games. Can you try to reproduce the issue on a new campaign after manually removing all the mod files and verifying the integrity of the game files. If the issue is persistent on a new, unmodded campaign please let me know.


The issue did happend as i said, even before i subscribed to any mods on steam workshop, when i freshly installed the game it already didn't let me play the game, and the application faced a problem alert already popped out. I think that problem is within the game, not the mods that i subscribed to later, I already unsubscribed and made my game clear again so that i can get any help from you, because deleting mods did not help, the alert is still showing itself when i try to launch the game from the launcher, so I want some help with launching my game from launcher.

The new dump from when i tried to launch the game, no mods, clean: 2023-05-29_18.10.07_ef5f29bacac9ff6d35e2a5bb417393be
Top Bottom