Resolved Application crashed because a fatal error occured while checking sound bank files

Users who are viewing this thread

Version number
e1.5.8
Branch
Main
Modded/unmodded
Yes, but I removed mods.

RillienCot

Recruit
Summary: When launching the game (before getting to the start menu), an error window appears. I've tried the fix here, but couldn't find any files with the words "sound" or "bank" in them. Game crashes after I press "Okay"
How to Reproduce: It happens every time I load the game. This is also the first time I've played it since the update. I have used mods in the past, but the issue occurs without mods.
Scene Name (if related):
Media (Screenshots & Video): Computer Specs:
OS: Windows 10 Education
GPU: Nvidia Geforce RTX 960
GPU Driver Version: 26.21.14.4141
CPU: AMD FX(tm)-8320 Eight-Core Processor
RAM: 16 GB
Motherboard: Gigabyte GA-78LMT-USB3 6.0
Storage Device (HDD/SSD): HDD
 

RillienCot

Recruit
Deleting them is better.
EDIT: Also, what mods did you use?
Mods Used: PartyScreenEnhancements, ImprovedGarrisons, CulturedStart
Mods I tried, but never got to work: Harmony, ChangingCulture, NobleTitles, RTSCamera, RTSCamera.CommandSystem

I just reverified with all the mods disabled and everything was fine. I will try again with all of the mods deleted.
 

momo1

Sergeant
M&BWBWF&SNWVC
Delete this entire folder C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Sounds\PC
EDIT: And then verify files again.
 

momo1

Sergeant
M&BWBWF&SNWVC
This seems to have solved the issue. Thanks for the help!
My pleasure. About the mods that aren't working, do you have the below mod installed? It has all the basic dependencies needed for mods to work. Before you install it, uninstall Harmony because this mod comes with it.
And a personal piece of advise. Stay away from mods that touch your save game, it's not worth it. Because when Taleworlds releases a new version of Bannerlord, you might be unable to play the new version of Bannerlord with a save game that a mod previously edited, and you would have to start a new game in order to play on the new version of Bannerlord.
Almost every Bannerlord mod specifies in the description whether or not it edits the save game so it's not hard to find out.
 
Last edited:
Hi, have the same issue and deleting C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Sounds\PC and restoring the files didn't work. I also tried deleting C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Sounds completely which didn't work. I even deleted the game, deleted C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord to get a fresh install and that didn't work either. Can you please advise?
 

momo1

Sergeant
M&BWBWF&SNWVC
Hi, have the same issue and deleting C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Sounds\PC and restoring the files didn't work. I also tried deleting C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Sounds completely which didn't work. I even deleted the game, deleted C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord to get a fresh install and that didn't work either. Can you please advise?
Are you, or have you ever used mods?
Is your error message identical?
 

momo1

Sergeant
M&BWBWF&SNWVC
Hi, have the same issue and deleting C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Sounds\PC and restoring the files didn't work. I also tried deleting C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Sounds completely which didn't work. I even deleted the game, deleted C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord to get a fresh install and that didn't work either. Can you please advise?
Did you do all of the below when you uninstalled the game?

Clean Install
The clean install is removing every single game-related file from your computer and installing the game again. Why do you need to remove the game while you just want to remove the modifications? Unfortunately, some of the modifications do not just add a new modules folder but also change or adds contents to the existent modules folder. Without a reinstall, we can't be sure those files are unchanged.

To perform a Clean Install, Uninstall the game. You can do that by right-clicking the game on Steam Library and selecting Delete Local Content. Delete all folders related to the game that remains after the uninstallation. The folders that might have files inside:
Steam: C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord
Epic: C:\Program Files\Epic Games\Mount & Blade II Bannerlord
C:\Users\USERNAME\Documents\Mount and Blade II Bannerlord
C:\ProgramData\Mount and Blade II Bannerlord

Note: You'll need to allow Windows to display hidden folders and files to see the ProgramData folder and its contents.
 

Osaro

Recruit
Please help with this issue I haven’t be able to play for a while now a week I tried everything. I have no mods on the game and still get the message. Please help
 

Osaro

Recruit
i can not post media yet due to the 24 hour restrictions. its the same error message from above mar.17 2021, i will post a SS as soon as the 24 hours is up in a few hours thank you.
 

momo1

Sergeant
M&BWBWF&SNWVC
i can not post media yet due to the 24 hour restrictions. its the same error message from above mar.17 2021, i will post a SS as soon as the 24 hours is up in a few hours thank you.
Did you try deleting \steamapps\common\Mount & Blade II Bannerlord\Sounds\PC and then verifying files?
 

Geoseogan

Regular
M&BWBWF&SNW
I have the exact same issue, same error message (100% identical) to the one posted by the OP. This only happens on my Bannerlord Mod Tools. I tried deleting the PC folder under Sounds, then validating, to no avail. No mods. Tried clean install too, also to no avail, followed by another attempt at deleting PC then validating. Still get the same error message.

I am on 1.5.10 beta. Again, the normal base game works fine, it's just the modding kit that is not working.


Edit:
After attempting these fixes, I gave up. Went to play my normal singleplayer game, and now I get random freezes in which everything pauses even on the main menu, my body randomly turned invisible and some troops randomly turned naked, and other issues. I don't know how or why.
Update: I uninstalled the modding tools, now my game is working as normal.
 
Last edited:
Top Bottom