Resolved Another Can't activate game thread

Users who are viewing this thread


While reading the previous topics, unfortunately the problem is not fully resolved. I bought the steam key and I cannot activate it even the manual activation version does not work, please promptly answer


Also, not just warband.
My 1.011 was relegated to trial mode (despite being activated about 2 months ago), and I cannot activate it again.
Тоже проблема, купил сегодня игру Mount & Blade Fire and Sword в Steam и не могу активировать цтфровой код. Помогите решить этот вопрос


The activation servers should be up now. Sorry for any inconvenience.

Thank you. For me it works, i think.
The game did not asked for another activation code and i can play the story mode above level 7 now. So i think it works now.
Is it regular that i did not have to enter the activation code now? Maybe because my ingame request / pop-up to enter the code was "saved" and automatically send to the activation server after the server was back online?
It's a bit magic for me but it works now ^^
Top Bottom