Resolved Annoying Glitch which was supposedly fixed

Users who are viewing this thread

Version number
No, I didn't use any mods.


Summary: I was in the middle of defending one of my vassal's castles in a siege against one of the empires, when the Aserai declared war on me, followed by me being kicked out of the castle out of nowhere with a popup saying "you are no longer at war with the Battanians", who I was not at war with, and the siege continued on without me in the castle. I tried to reload the save from before the siege, and noticed, huh, its saying "achievements disabled" despite me playing on vanilla with cheat mode disabled, AND having been able to earn achievements on this save as recently as yesterday. I tried restarting the game, and loading from a slightly earlier autosave, and its still saying achievements disabled.
How to Reproduce: Be in a castle your vassal owns while its being besieged, and have a different kingdom declare war on you.
Have you used cheats and if so which: None, cheat mode is off.
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: Windows 11
GPU: GTX 3070
GPU Driver Version: Current
CPU: Intel(R) Core(TM) i7-12650H
Motherboard: built in
Storage Device (HDD/SSD): SSD
This issue is fixed on the v1.1.0 version which is now in beta on Steam.
  • Fixed a bug that caused the player party to be ejected from their current settlement due to an unrelated peace between other factions.
Top Bottom