In Progress AI refuses to assault the walls of Llanoc Hen Castle

Currently viewing this thread:

Version number
e1.5.7
Branch
Main
Modded/unmodded
Yes, I used mods.
As the title says.

Summary:
Troops, either led by you or the AI just stop before the walls. They put the ladders up, and just wait around at the foot of the ladders. I even went in, and opened the gates, and they still decided not to come in and assault. This happens in e1.5.7.

Edit: This happened before using mods, and after it. (I don't use AI changing mods) My friend experienced the same issue, the AI just stands around instead of climbing the ladders, or breaking the gates.

How to Reproduce:
Assault Llanoc Hen Castle (Modified from: Assault a castle or town with Vlandia.)

Scene Name (if related):
Llanoc Hen Castle (Modified from: Any castle or town assault.)

Media (Screenshots & Video):
None

Computer Specs:
OS:
Windows 10 Pro 64-bit
GPU:
AMD Radeon RX 5600 XT
GPU Driver Version:
AMD 21.1.1
CPU:
AMD Ryzen 7 2700X
RAM:
16 GB RAM
Motherboard:
MSI B450 Gaming Plus Max
Storage Device (HDD/SSD):
SSD
 
Last edited:

uçanbiblo

Community Support
M&BWBWF&SNWVC
Hello, can you reproduce the issue on a new campaign after manually removing the mod files and verifying the integrity of the game? If the same issue happens on a clean new game please send the save file to us so we can further inspect the issue. You can upload the file to http://upload.taleworlds.com:8080/ address. Please paste the link to this thread as description so i can identify it.
 
Yes, I will try, I'm right on it.

Ps.: Where do I get the link of my upload? Started uploading the saves, it says it was succesful, but there is no different link provided. :sad:
 
Last edited:
So, for some reason I have issues uploading the saves, it constantly states Upload aborted, (before saying that upload was succesful (?)) but here is what I found:
If there is a battering ram, they will not use ladders as long as the battering ram reaches the gates. They will just stand around. If you walk up to a ladder, and put it up yourself, they will recognize that the ladder is there and usable, and they will fully start using it as intented.

They will start pushing the siege towers at the start though, so that is absolutely working.

Now, this is weird, because I experienced the same phenomenon in my Imperial playthrough. (with mods)
So far, I couldn't reproduce the standing around effect.

Ps.: The event that was in my original report was only different that in that, I was a Battanian, leading Battanian troops, fighting as a merc for the Vlandians, and we sieged a Battanian castle. In my little test right now, I was a Vlandian, leading Vlandian troops, fighting as a merc for the Vlandians, and we sieged a Battanian castle.
 
I'm such an idiot, misunderstood what you asked.... okay, so I'm currently uploading the saves.
Before siege save is straight forward.

After Siege 1: In this save, we only had the battering ram, I stood around, just protected myself, and didn't do anything. The soldiers pushed the ram to the gate, started breaking in, and in that moment, the rest started using the ladders.

After Siege 2: In this save, the lord built a Siege tower as well. The ram got pushed, the tower got pushed, but they were just eying the ladders. I ran up to a ladder, started putting it up (got killed in the process) but suddenly, the soldiers decided that the ladders could be used, rushed them, then slowly, one by one started assaulting the walls on them.

After Siege 3: In this save, the lord again, built only a ram. This time, I saw the popup, "Infantry and Infantry are waiting for siege machines", and below that "Infantry using siege machines". They started pushing the ram, but the rest just stood around. (except the archers, they were shooting and hiding) I ran up to a ladder, started prepping it up, and everyone decided to rush the ladders (all four of them), and put them up. After that, they went up one by one. :sad:

I will try using the same save, but with the mods applied. Will upload an after siege save of that one as well.
 
Last edited:
After Siege 4: So I reinstalled and enabled all the mods, tried the siege again, and voila. Same results as in the save After Siege 3. It's not worth writing it out, because it was exactly the same. It still seems a bit weird that your troops ignore the ladders until something is at the walls, but if it is intentional, I can understand that.
Also, even though the ladders were up, they were still a bit "unwilling" to climb them. :smile:
 
Last edited:

uçanbiblo

Community Support
M&BWBWF&SNWVC
Hello, we are aware of the Siege AI behaviour problems and working on them. I will inform the QA team about this post as well. Thank you for taking the time to update the post.
 
Okay, I was able to recreate the bug! Llanoc Hen Castle it is, with Level 1 walls! The attacker just stays outside, unless we give them the good old F1 + F3 orders (This time it happened when I was attacking as Battania).

Before war with Vlandia.sav is literally before the declaration of war, I instantly sieged down Llanoc Hen Castle.

Llanoc Hen Castle Captured.sav is after I captured the place. I built only one siege tower, which my troops pushed up to the walls, but then just stopped. I put up the ladders, and they just stood around. Killed a lot of the defenders who just ran one by one up to the ballistas, and to remove my ladders, but nothing else happened. So both the defenders and the attackers just got shocked. When I pressed F1 + F3, everyone instantly started rushing in.

Hope this helps!
 
Last edited:
Top Bottom