Need More Info After clicking play/continue on the launcher it closes

Users who are viewing this thread

Version number
1.8.1
Branch
Main
Modded/unmodded
No, I didn't use any mods.

Kaidinlol

Recruit
Summary:
Hi, Taleworlds support team I just downloaded Mount and blade Bannerlord 2 after not playing it for a few months maybe 6-8ish months and when I click on the game it takes me to the launcher, and if I click play/continue the launcher goes away and it says Bannerlord is running on steam but it does not pop up for me and allow me to play it since it doesn’t take me to the game it also does not even appear in my task manager so the only way for it to run is to reset my PC. I have looked through and tried many “fixes” and so far nothing has worked I am really disappointed I waited years to play this game and wanted to play it again and it does not work. If you guys could help me solve this problem or diagnose what the issue is I would appreciate it a lot, thank you.
Sincerely, Kaidin
How to Reproduce This happens to me when I attempt to play the game
Have you used cheats and if so which: No
Scene Name (if related):
Media (Screenshots & Video): I have none since it doesn't show much except the launcher closing
Computer Specs:
OS: Windows 11
GPU: 2080 super
GPU Driver Version: 517.40
CPU: Ryzen 5 5600x
RAM: 16gig 3200 cl19 ram
Motherboard: Not sure
Storage Device (HDD/SSD): SSD
 

Amau1989

Recruit
Same issue... First time playing in months. Never had this issue before. tried about every fix I could find online. HELP PLEASE!

How to Reproduce Click PLAY. Launcher pops up. click either play or continue.
Have you used cheats and if so which: No
Scene Name (if related):
Media (Screenshots & Video): once launcher closes nothing to show
Computer Specs:
OS: Windows 11
GPU: AMD Radeon RX 6600M
GPU Driver Version: 30.0.13014.2005
CPU: AMD Ryzen 7 5800H with Radeon Graphics
RAM: 16.0 GB (13.9GB usable)
Motherboard: LENOVO LNVNB161216 SDK0T76461
Storage Device (HDD/SSD): SSD
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Have you tried these workarounds?
‘Launcher not Launching’ / Game is not launching Workarounds
If you experiencing any issues with the launcher, you can try the workarounds below to fix it:
  • The first thing to do when experiencing any issue with the game is verifying the game files. After an update, there is always a chance of some of the game files being corrupted or missing. Doing this will verify that the game files are installed correctly. You can also check our guide regarding this here.
  • Deleting the configs folder of the game located in the Documents folder. Please keep in mind that this will also delete your saved options of the game. Don’t forget to back up the files if you don’t want to lose them. (C:\Users\user.name\Documents\Mount and Blade II Bannerlord\Configs)
  • You can try to delete the contents of the folder below and verify the game files afterwards. "steamapps\common\Mount & Blade II Bannerlord\bin"
  • If you have installed a mod called Fixed Launcher in the past, you need to make sure that you have deleted its files. These files can block the launcher from launching. The files of the aforementioned mod.
  • Check your Windows Defender settings for Ransomware Protection. You should add Bannerlord to the list under the Controlled Folder Access. To do that:
  • - Open Windows Defender Security Center.
  • - Click on Virus & threat protection.
  • - Click the Virus & threat protection settings option.
  • - Under "Controlled folder access," click the Allow an app through the Controlled folder access link.
  • - Click the Add an allowed app button to add Bannerlord.
  • Deleting the “spriteData.xml” file located in the "steamapps\common\Mount & Blade II Bannerlord\GUI\GauntletUI” folder can fix the issue. This is an obsolete xml file that the game is not using. However, if a mod is installed before changing this file, the game tries to use it and crashes.
  • Deleting the logs folder located under the "C:\ProgramData\Mount and Blade II Bannerlord" folder. Please note that the ProgramData folder is a hidden folder by default.
  • If none of the workarounds above helped you, you can try to launch the game via the TaleWorlds.MountAndBlade.Launcher.Singleplayer.exe and TaleWorlds.MountAndBlade.Launcher.Multiplayer.exe files located in the folder below:
  • ...:\SteamLibrary\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client
  • Check your OneDrive folder contents. Even if it is disabled we have seen users post that their files have been changed with the previous OneDrive synced files. You should try deleting your OneDrive files. More info about that can be found here.
 

Jmesser1982

Recruit
I'm having the same issue. Have not been able to play the game no matter what trick I've tried (found some ideas on the internet for steam issues). Other steam game is working fine. Really weird to buy a game and not have it work at all.

Version: 1.0.0.3729
Mods: None
 

Jmesser1982

Recruit
I requested my refund a couple days ago and was denied by steam because it was past the 2 week window. I haven't played a single minute of the game but have spent 10 hours trying to get it to actually work by following all the recommended fixes I could find on these forums and elsewhere. Where other players would respond their issue was fixed I haven't gotten past the launcher. My cpu meets the requirements, I've shut off the filters and firewalls, I've uninstalled and reinstalled, I've verified game files every day for a month, I've deleted strange files from the game that should have been removed if they weren't important and causing players issues, I've quadruple-checked and never had a beta selected.

I wrote all those from memory but there are other fixes attempted that I can't remember. Can the company help me with a refund since steam is going to laugh all the way to the bank?
 
Top Bottom