In Progress General AccessViolationException in ScriptingInterfaceOfIUtil.GetSnowAmountData

Users who are viewing this thread

Version number
1.8
Branch
Beta
Modded/unmodded
Modded

Space_Pot8to

Recruit
We are having this recurring problem for a custom campaign map for 1.8. The map works fine on previous versions, but now there is a crash in ScriptingInterfaceOfIUtil.GetSnowAmountData. Here's our snow map And here's the call stack
Code:
     [Managed to Native Transition]
>    TaleWorlds.Engine.AutoGenerated.dll!ManagedCallbacks.ScriptingInterfaceOfIUtil.GetSnowAmountData(byte[] snowData) (IL=0x002D, Native=0x00007FF978605DA0+0x137)
     TaleWorlds.Engine.dll!TaleWorlds.Engine.Utilities.GetSnowAmountData(byte[] snowData) (IL=0x000B, Native=0x00007FF978605D40+0x3F)
     SandBox.dll!SandBox.SandBoxSubModule.InitializeGameStarter(TaleWorlds.Core.Game game, TaleWorlds.Core.IGameStarter gameStarterObject) (IL=0x0054, Native=0x00007FF9786053E0+0x171)
     TaleWorlds.MountAndBlade.dll!TaleWorlds.MountAndBlade.MBGameManager.InitializeGameStarter(TaleWorlds.Core.Game game, TaleWorlds.Core.IGameStarter starterObject) (IL=0x001F, Native=0x00007FF978605250+0xAE)
     TaleWorlds.CampaignSystem.dll!TaleWorlds.CampaignSystem.Campaign.OnInitialize() (IL=0x00BD, Native=0x00007FF9781092F0+0x312)
     TaleWorlds.Core.dll!TaleWorlds.Core.Game.Initialize() (IL=0x004A, Native=0x00007FF9780ACC90+0x10C)
     TaleWorlds.CampaignSystem.dll!TaleWorlds.CampaignSystem.Campaign.DoLoadingForGameType(TaleWorlds.Core.GameTypeLoadingStates gameTypeLoadingState, out TaleWorlds.Core.GameTypeLoadingStates nextState) (IL=0x0025, Native=0x00007FF9780AC230+0x99)
     TaleWorlds.Core.dll!TaleWorlds.Core.GameType.DoLoadingForGameType() (IL=0x002C, Native=0x00007FF9780AC0D0+0x89)
     TaleWorlds.Core.dll!TaleWorlds.Core.Game.DoLoading() (IL≈0x0006, Native=0x00007FF9780AC070+0x3A)
     SandBox.dll!SandBox.SandBoxGameManager.DoLoadingForGameManager(TaleWorlds.Core.GameManagerLoadingSteps gameManagerLoadingStep, out TaleWorlds.Core.GameManagerLoadingSteps nextStep) (IL≈0x00EF, Native=0x00007FF9780A07A0+0x247)
     TaleWorlds.Core.dll!TaleWorlds.Core.GameManagerBase.DoLoadingForGameManager() (IL=0x00A2, Native=0x00007FF9780A05C0+0x12F)
     TaleWorlds.MountAndBlade.dll!TaleWorlds.MountAndBlade.GameLoadingState.OnTick(float dt) (IL≈0x000F, Native=0x00007FF9780A04D0+0x6C)
     TaleWorlds.Core.dll!TaleWorlds.Core.GameStateManager.OnTick(float dt) (IL=0x002F, Native=0x00007FF9778C8050+0xBF)
     TaleWorlds.MountAndBlade.dll!TaleWorlds.MountAndBlade.Module.OnApplicationTick(float dt) (IL=0x01A4, Native=0x00007FF9778747B0+0x6B1)
     TaleWorlds.MountAndBlade.dll!TaleWorlds.MountAndBlade.CoreManaged.TaleWorlds.DotNet.IManagedComponent.OnApplicationTick(float dt) (IL=0x000B, Native=0x00007FF977874750+0x45)
     TaleWorlds.DotNet.dll!TaleWorlds.DotNet.Managed.ApplicationTick(float dt) (IL=0x0038, Native=0x00007FF977871F20+0xAC)
     TaleWorlds.DotNet.AutoGenerated.dll!ManagedCallbacks.LibraryCallbacksGenerated.Managed_ApplicationTick(float dt) (IL=0x0006, Native=0x00007FF977871ED0+0x2C)
This sometimes happens, sometimes doesn't. Sometimes deleting shaders fixes the problem, other times no. Maybe there is a connection to this thread https://forums.taleworlds.com/index.php?threads/main-map-snow-flowmap-bugs.450416/.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Forwarded to the QA team for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
 
Top Bottom