A problem with "server transfer"

Currently viewing this thread:

Martin7

Recruit
Hey there.
I recently got an issue while trying to make Combined Worlds work from one server to another.
I got all database things set up, scripts work in 100% and now when all is supposed to work, I got this:

18:17:33 - Name server: player Martin (xxx): Waiting for server transfer...

and here is part of strings
("http_s1_checkplayer_password_s2_id_reg1_uid_reg2_name_s3", " http://{s1}/checkplayer.php?password={s2}&id={reg1}&uid={reg2}&name={s3}"),
  ("http_s0_admin", "{s0}&admin"),
  ("http_s1_startserver_password_s2_server_name_s3_scene_name_s4", " http://{s1}/startserver.php?password={s2}&server-name={s3}&scene-name={s4}"),
  ("http_s1_storeplayer_password_s2_format", " http://{s1}/storeplayer.php?password={s2}&id={reg1}&uid={reg2}&to-server={reg3}&link={reg4}&inst={reg5}&gold={reg6}&\
troop={reg7}&agent-troop={reg8}&wpn1={reg9}&ammo1={reg10}&wpn2={reg11}&ammo2={reg12}&wpn3={reg13}&ammo3={reg14}&wpn4={reg15}&ammo4={reg16}&head={reg17}&body={reg18}&foot={reg19}&hand={reg20}&\
horse={reg21}&hp={reg22}&horse-hp={reg23}&food={reg24}"),
  ("http_s1_loadplayer_password_s2_id_reg1_uid_reg2", " http://{s1}/loadplayer.php?password={s2}&id={reg1}&uid={reg2}"),
  ("http_s1_clearplayer_password_s2_id_reg1_uid_reg2", " http://{s1}/clearplayer.php?password={s2}&id={reg1}&uid={reg2}"),
  ("name_server", " ht tp://solidd.cba.pl/pwnameserver/checkplayer.php",
  ("name_server_password", "secret"),

It looks like its a connection problem pw -> nameserver

I would appreciate any help :]
 

Gishank

Master Knight
WBWF&SNWVC
You should probably take note that the "Combined Worlds" feature that Vornne developed, at least as far as I am aware, has never been properly tested.

I'm not an expert on the module_system, so I can only pinpoint one obvious issue - the name_server URL leads to a non-existent page ("404"); plus, the nameserver URL in strings should not be prefixed with http://, as this will break things when it compiles and sends the HTTP Request.
 

Martin7

Recruit
Well I changed the URL for a random one so its not an issue, but that thing about HTTP might indeed cause the problem too. Ill check.
And the feature itself works, at least it looks like it works
 
I tried to but it was too messy for me so I rewrote it.
Imo it's too much effort needed to get it properly running.
 

Azrayel

Sergeant Knight at Arms
domipoppe said:
I tried to but it was too messy for me so I rewrote it.
Imo it's too much effort needed to get it properly running.

Did the re-write function?  Ever have it working?  And if so, could you be convinced to share it?
 
Top Bottom