[1.7.1] Unable to start sandbox with Custom troops (Mod preview too!)

Users who are viewing this thread

Hello!

I'm making a mod and I'm at the end of my rope here. I have my troops implemented using parties, but the moment I add them to my SPCultures file the game freezes on sandbox startup. No crash or error, just never starts.
Totally at a loss here on why it isn't starting. Is there something wrong with my custom troops?

I've put together a small test file that isolates the problem to just the custom troops and the culture file. I should be able to complete my mod but I've been totally unable to get around this issue so the new troops spawn in villages rather than just with NPC parties:

<?xml version="1.0" encoding="utf-8"?>
<NPCCharacters>
<!-- VLANDIAN MERCENARIES -->
<NPCCharacter id="vlandian_recruit_new"
default_group="Infantry"
level="6"
name="{=H5HJUejD}}Mercenary (Spear)"
occupation="Soldier"
is_basic_troop="true"
culture="Culture.vlandia">
<face>
<face_key_template value="BodyProperty.villager_vlandia"/>
</face>
<skills >
<skill id="Athletics" value="0"/>
<skill id="Riding" value="0"/>
<skill id="OneHanded" value="0"/>
<skill id="TwoHanded" value="0"/>
<skill id="Polearm" value="0"/>
<skill id="Bow" value="0"/>
<skill id="Crossbow" value="0"/>
<skill id="Throwing" value="0"/>
</skills>
<Equipments>
<EquipmentRoster>
<equipment slot="Item0" id="Item.western_spear_2_t2"/>
<equipment slot="Head" id="Item.nasal_helmet_over_padded_coif"/>
<equipment slot="Cape" id="Item.hood"/>
<equipment slot="Body" id="Item.padded_coat"/>
<equipment slot="Gloves" id="Item.reinforced_leather_vambraces"/>
<equipment slot="Leg" id="Item.plated_strip_boots"/>
</EquipmentRoster>
<EquipmentRoster>
<equipment slot="Item0" id="Item.western_spear_2_t2"/>
<equipment slot="Head" id="Item.nasal_helmet_over_padded_coif"/>
<equipment slot="Cape" id="Item.hood"/>
<equipment slot="Body" id="Item.padded_coat"/>
<equipment slot="Gloves" id="Item.reinforced_leather_vambraces"/>
<equipment slot="Leg" id="Item.plated_strip_boots"/>
</EquipmentRoster>
<EquipmentRoster>
<equipment slot="Item0" id="Item.western_spear_2_t2"/>
<equipment slot="Head" id="Item.nasal_helmet_over_padded_coif"/>
<equipment slot="Cape" id="Item.hood"/>
<equipment slot="Body" id="Item.sleeveless_padded_coat"/>
<equipment slot="Gloves" id="Item.reinforced_leather_vambraces"/>
<equipment slot="Leg" id="Item.plated_strip_boots"/>
</EquipmentRoster>
<EquipmentRoster>
<equipment slot="Item0" id="Item.military_fork_t2"/>
<equipment slot="Head" id="Item.padded_coif"/>
<equipment slot="Cape" id="Item.hood"/>
<equipment slot="Body" id="Item.padded_short_coat"/>
<equipment slot="Gloves" id="Item.reinforced_leather_vambraces"/>
<equipment slot="Leg" id="Item.plated_strip_boots"/>
</EquipmentRoster>
<EquipmentRoster>
<equipment slot="Item0" id="Item.peasant_pitchfork_1_t1"/>
<equipment slot="Cape" id="Item.hood"/>
<equipment slot="Body" id="Item.sleeveless_padded_short_coat"/>
</EquipmentRoster>
<EquipmentRoster civilian="true">
<equipment slot="Item0" id="Item.peasant_2haxe_1_t1"/>
<equipment slot="Item2" id="Item.throwing_stone"/>
<equipment slot="Body" id="Item.bandit_envelope_dress_v1"/>
<equipment slot="Leg" id="Item.wrapped_shoes"/>
</EquipmentRoster>
</Equipments>
</NPCCharacter>
</NPCCharacters>

Here's the isolated test module file as well. At the end of my rope here unfortunately so anything helps

If you'd like to see the full version as is, here is that as well. Cultures is commented out in the module so it actually doesn't freeze on sandbox start:
 
Top Bottom