Resolved 1.6.0 Cannot create new party unless hero is already in party. "This hero is busy"

Users who are viewing this thread

Version number
Yes, I used mods.
Summary: I can't create a party normally from the clan/parties menu unless a character is already in my party. The message "This hero is busy." is displayed when the hero would normally be able to create a new party
How to Reproduce: The save was originally 1.5.10, but was converted to 1.6.0. this is when the problem occurred.
Have you used cheats and if so which: None, I have only used a mod which replaces a single texture
Scene Name (if related):
Media (Screenshots & Video):

Computer Specs:
OS: Win 10 x64
GPU: NVIDIA GeForce GTX 1660 Ti
GPU Driver Version:
CPU: Intel Core i7-9750H @ 2.60GHz
RAM: 16.0 GB
Motherboard: Eluktro Pro (X Opt) Global Platform
Storage Device (HDD/SSD): 500GB-PRO-X-SS (SSD)


Community Support
Community Support
Hello, This problem should be fixed with the released patches since you have reported this issue. Are you still experiencing this issue?


I'm now on e1.6.1 and the issue has not been fixed for me. Do you mean that the issue is fixed for the beta branch?
I tried in 1.62 beta and there it works.
You can assign the hero to a party, and they will after abit of time start collecting troops etc.
I havent tested on earlier versions like the 1.60 or 1.61.


Community Support
Community Support
Hey, i am glad the issue is solved. Please let us know if you encounter any other issues.
Top Bottom