1.6.0 and 1.6.1 (Constant fps drops and CPU 100%)

Users who are viewing this thread

TKnight

Sergeant
Way to Fix : Move the game to SSD disk.
1.6.0 has constant fps drops on the global map.. (and long loading times in any inventory , each time i open my character window i can see trough his soul , due items not loading) it takes 5-10 seconds each time i open any window to load the items.
1.6.1 got even worse , not only it lags on the global map , now it stutters on the battle map too. (on Arenas and fights 400v400)
(the loading times got a bit better but still it takes more time to load different pages then play the game...)
This need to be adressed..

I am playing on a Gaming Laptop with :
Intel Core i7-7700HQ CPU 2.8GHz
32 Gb Ram
Nvidia Geforce GTX 1080
1920x1080 , 120 hz


And i am playing on ~High settings with
Anti Analising - FXAA
Bloom OFF
Film Grain OFF
Motion Blur OFF
Texture FIltering - Bilinear.
Shadow Filtering - None
Shadow Quality - Medium
Oclusion Method - Tsao
Number of Rag dolls - 10
Number of Corpses - High
Battle Size - 600
Animation Sampling Quality - Low
(Rest of the settings are on High)

(on 1.6.0)
Ingame Battles were decent , not so much fps drops , but Global map was just lagging and stuttering non stop. (and the loading times are just crazy high for a game when most of the time we open the same inventory/character screen/army screen )

(on 1.6.1)
The game is constantly dropping from 120 fps to 60-40-30 , on the global map sometime to 1 fps when entering/exiting and opening any shops in settlements , and to be assured its not the problem from my end , i am playing Metro Exodus on High settings on 120-140 fps without any issues , same with Witcher 3 , Overwatch (150 fps), For Honor (~120 fps).

Sorry if the post is in the wrong section.
 
Last edited:
By a chance does it drop from high fps when your cpu cores are 100% full? In my experience game literally freezes when my cores are at 100% for few seconds (i5 9600K) so bandaid is to avoid using cpu at 100%, by using vsync, reduced ragdolls, corpses, increased resolution etc.
 

TKnight

Sergeant
By a chance does it drop from high fps when your cpu cores are 100% full? In my experience game literally freezes when my cores are at 100% for few seconds (i5 9600K) so bandaid is to avoid using cpu at 100%, by using vsync, reduced ragdolls, corpses, increased resolution etc.
Cpu is running at 100% almost everytime , the fps drops are constant.
 
Cpu is running at 100% almost everytime , the fps drops are constant.
Try capping your fps at the level when you have 80-90% usage, maybe it will help. Also since you are using laptop, at 100% usage your CPU migh be overheating to the point when it automatically downclocks to prevent heat inflicted damage, this is generall at 100°C, so you wann be below that to have stable clock (ideally 90°C or less).
 

black_bulldog

Knight at Arms
WBWF&SVC
Cpu is running at 100% almost everytime , the fps drops are constant.
I'm no computer expert but running a cpu at 100% for an extended time can't be good. I'm guessing it will overheat it unless you have a great water cooled system and god forbid if that screws up at all.
 

TKnight

Sergeant
Try capping your fps at the level when you have 80-90% usage, maybe it will help. Also since you are using laptop, at 100% usage your CPU migh be overheating to the point when it automatically downclocks to prevent heat inflicted damage, this is generall at 100°C, so you wann be below that to have stable clock (ideally 90°C or less).
I think you are not seeing the problem here , this is litteraly the only game lags so much for me , and the problem with the CPU and FPS appeared after patch 1.6.0
(The fps is capped at 150 in Bannerlord in settings)
 

Shaxx

Squire
Has it at any point not had these glaring issues for you?

A couple things I am noticing:
Intel Core i7-7700HQ CPU 2.8GHz - Definitely a weak CPU by modern standards, especially for heavily multi-thread optimized applications. I have seen Bannerlord fully use 18 threads on occasion in battle, for example. Also the frequency is on the low side compared to most modern desktop CPU's, which has been a crutch for this game, at least for me, in regards to scraping by with performance.

No SSD? This can definitely throw a wrinkle into load times if you do not have one of these.

32 Gb Ram - I know a lot of laptops bury this information, but any idea of the frequency and CAS latency of your memory?

That said, some of the issues you are having are of course unacceptable no matter the hardware.
 
Last edited:

Duh_TaleWorlds

Developer
We intend to update the telemetry branch for 1.6.0 and also dedicate another one for 1.6.1. Once they are updated / available, it would be great if you could record the issues you are experiencing and submit it to us.
 

TKnight

Sergeant
Has it at any point not had these glaring issues for you?

A couple things I am noticing:
Intel Core i7-7700HQ CPU 2.8GHz - Definitely a weak CPU by modern standards, especially for heavily multi-thread optimized applications. I have seen Bannerlord fully use 18 threads on occasion in battle, for example. Also the frequency is on the low side compared to most modern desktop CPU's, which has been a crutch for this game, at least for me, in regards to scraping by with performance.

No SSD? This can definitely throw a wrinkle into load times if you do not have one of these.

32 Gb Ram - I know a lot of laptops bury this information, but any idea of the frequency and CAS latency of your memory?

That said, some of the issues you are having are of course unacceptable no matter the hardware.
I have an SSD , but the game is on HDD. (since SSD is 250 GB only , and i have other soft installed on that disk)
Screenshot_1.jpg
 

Gandamula

Sergeant at Arms
We intend to update the telemetry branch for 1.6.0 and also dedicate another one for 1.6.1. Once they are updated / available, it would be great if you could record the issues you are experiencing and submit it to us.
Since 1.5.9 the game us much more the HD to load things in the moment. Those things should be loaded before to Ram.
 

Terco_Viejo

Spanish Gifquisition
Grandmaster Knight
The same thing here as well (1.6.0).

Patch after patch my playable experience in terms of performance has been getting poorer. Load times, both for scenes and assets on models are excessively lengthy, as well as lag-stuttering (serious fps drops) in the scenes.

Obviously this only happens to me in Bannerlord as I have other games installed running perfect according to the game-hardware requirements.
 

TKnight

Sergeant
(Patch 1.6.0) (Tested with tons of mods ~40)
For my interest iv moved the game from my HDD to SDD , and i was surprised , the difference is night and day how well the game runs on an SSD , (no stutters , no lags , global map works perfectly fine , items loading , character loading ,city loading are instant - only lags a mil second when the daily wages are paid (might be bcs of the mod) , but the rest is smooth as butter)
I think this game need a heavy optimization pass for a HDD type , TW please test the game on HDD , it is a mess what is happening when playing on it. (not everyone has an SSD)
 

Gandamula

Sergeant at Arms
(Patch 1.6.0) (Tested with tons of mods ~40)
For my interest iv moved the game from my HDD to SDD , and i was surprised , the difference is night and day how well the game runs on an SSD , (no stutters , no lags , global map works perfectly fine , items loading , character loading ,city loading are instant - only lags a mil second when the daily wages are paid (might be bcs of the mod) , but the rest is smooth as butter)
I think this game need a heavy optimization pass for a HDD type , TW please test the game on HDD , it is a mess what is happening when playing on it. (not everyone has an SSD)
Sadly most of us have small ssds and we have to install the game in HD, as we do to all the other games, no other game have this issues, it's all about ram management, the game should load the inventory to Ram and not use the HD each time we open it.
 
The same thing here as well (1.6.0).

Patch after patch my playable experience in terms of performance has been getting poorer. Load times, both for scenes and assets on models are excessively lengthy, as well as lag-stuttering (serious fps drops) in the scenes.

Obviously this only happens to me in Bannerlord as I have other games installed running perfect according to the game-hardware requirements.
This!

If I remember right I first played on about 1.56, with medium settings. The game ran great. But with every patch it's gotten slower, and slower, and slower. Now I'm playing on low settings and it's barely chugging along.

What the hell?
 

Duh_TaleWorlds

Developer
This!

If I remember right I first played on about 1.56, with medium settings. The game ran great. But with every patch it's gotten slower, and slower, and slower. Now I'm playing on low settings and it's barely chugging along.

What the hell?
Have you used the telemetry branch to submit data about the problems that you are experiencing? The latest version should be 1.5.10. Ideally, it will be updated this week to 1.6.0 and 1.6.1.
 

Gandamula

Sergeant at Arms
Have you used the telemetry branch to submit data about the problems that you are experiencing? The latest version should be 1.5.10. Ideally, it will be updated this week to 1.6.0 and 1.6.1.
The problem is obvious in the delay in showing the items in the inventory, in previous versions the items take some time the first time they were loaded then it goes fast, by now every time you open the inventory, the game always loads the items from the HD, it seems that nothing is stored in RAM.
 
Top Bottom