• Please note that the developer team will be on leave until 26th of July. All technical support tickets will be handled when we're back in action. Thank you for understanding.

Need More Info Mesh Editor 1.5.6 Crashes Plus 1.5.5 Mod Tools 3d viewer crash

Currently viewing this thread:

Version number


Hey, popped into a old post here https://forums.taleworlds.com/index.php?threads/model-viewer-crashes-toolkit.432847/#post-9618914.

The game worked perfectly fine yesterday on 1.5.5. The only issue I ran into was when I was working in the mod tools. I could open the material editor, bone editor and the FBX 3d viewport just fine (maybe sometimes crashes sure). But when I went to open the Mesh viewer or the Cloth Editor the 3d view would be pure black and the mod tools would stop responding and I would have to Crt Alt Delete out of them. I tried reinstalling multiple times and doing fresh installs each time. I also tried both the beta and normal versons, matching the versions to the game and being both installed in the same SSD, and trying mutliple SSDs. Sooooo as of 1/12/2021 you updated the game tried lauching it, I get a black screen now on launch of the base game and mod tools where if i dont ALT out I would get a whole PC CRASH! blue screen of death. If I alt out It just crashes and I can send a crash report (will attach the reference to it) also i put in all the comments "willemsen".)) I also got one error box which i screenshoted but not to sure if that was when the versons were not matching when I launched the mod tools. Soo now we tried trouble shotting, everything is updated, windows graphics driver, chip processor..... I got this weird fix when I removed the C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Shaders\D3D11 folder. I could now see the launch loading screen and the menu. On the menu was a crazy mess (i will upload the picture). If i did a custom battle it was super laggy the ui but everything loaded in nice looking. The issue then was in the battle everything was popping in and out. Put that folder back in and BAM black to the black load screen of death. My specs are in the previous post and see the attached images.

This is 1.5.5 stuff is working


1.5.5. Sometimes the material and fbx viewer

1.5.5. Mesh viewer and Cloth editor


1.5.6. ALL THE NEW ISSUES, i cant even play the regular game now :sad:


1.5.6 after removing the folder

Graphics Card: ZOTAC Gaming GeForce RTX 2070 Super Mini 8GB GDDR6 256-Bit 14Gbps Gaming Graphics Card, IceStorm 2.0, Super Compact, ZT-T20710E-10M https://www.amazon.ca/GeForce-256-Bit-Graphics-IceStorm-Zt-T20710E-10M/dp/B07XSPWMP9
Time of this report: 1/12/2021, 21:12:39
Operating System: Windows 10 Home 64-bit (10.0, Build 19041) (19041.vb_release.191206-1406)
Language: English (Regional Setting: English)
System Manufacturer: Micro-Star International Co., Ltd.
System Model: MS-7C37
BIOS: H.10 (type: UEFI)
Processor: AMD Ryzen 5 3600 6-Core Processor (12 CPUs), ~3.6GHz
Memory: 32768MB RAM
Available OS Memory: 32718MB RAM
Page File: 12765MB used, 24815MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
DirectX Database Version: 1.0.8
DxDiag Version: 10.00.19041.0546 64bit Unicode

Update 1/12/2021.
I can turn back the version to 1.5.5 and perfectly run the game, of course you cant turn back the mod tools and of course that wouldnt fix the mesh and cloth editor
Last edited:

MArdA TaleWorlds

Community Support & Localization
Community Support
Forwarded to the developers for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!


@MArdA TaleWorlds So with your new patch today, i can now launch my game and play! It even fixed the issue where when I select a culture i cant see the 3d model in the character creator unless I backed out and picked it again. That being said, the cloth editor and mesh viewer are still having the same issue :"(

MArdA TaleWorlds

Community Support & Localization
Community Support
Do not know about him but i am experiencing the same thing in 1.5.9. Stops responding upon opening Model Viewer and Resource Browser. Occasionally i can enter resource browser, but upon trying to open a module it stops responding.
Forwarded, thanks!
Top Bottom