In Progress 1.5.2 Campaign Map Freezing Often

Currently Viewing (Users: 0, Guests: 1)

paladinx333

Sergeant at Arms
Best answers
0
1.5.1 was usually fairly smooth, but 1.5.2 is freezing for a few seconds quite often. Post battle and when I leave a town after a tournament are the worst times. Sometimes I will click to move someplace and the game will freeze for two seconds before it decides to let me go. It's getting old in a hurry.

Anyone else experiencing this?
 

redmark

Sergeant
Best answers
0
Yes. This wasn't happening in 1.5.2 beta, but is happening in 1.5.3 beta, so I would guess it's a result of one of the fixes which are common to both updates.
 

Shun

Sergeant
WB
Best answers
0
Happens to me often, too. New since 1.53 beta for me (was playing 1.5.2 beta before).

One notable occurence, but not the only one is, after a battle when the game autosaves, it freezes for a few saconds. Also sometimes when panning the map.
 

GeluHUN

Regular
Best answers
0
It happend to me on 1.5.2 all the time, and in 1.5.3 also. When you click on a new target to go to after some sceene (battle, village etc.). It feels like there is an auto save done in the background, but I see no save file with that time and date.
 

NLCRich

Sergeant at Arms
Best answers
3
I can confirm this is happening to me. Other than one crash, this is the first performance issue I've had in 500+ hours of gameplay. It's quite distracting. My system is high end, so not sure why all of a sudden I am having these problems when BL was running great before.
 

BrokenOlive

Recruit
M&BWBWF&SNWVC
Best answers
0
It's caused by the game autosaving only when you move on the map instead of during loading screens for whatever reason.
I don't know why they made that change, but they either did it intentionally or unintentionally.
 

TechnoSarge

Regular
Best answers
0
I'm seeing the hitch in 1.5.2 for the first time, too. I figured it was the autosave... but I really wish they'd do that just BEFORE a battle and not right after!
 

Flesson19

Sergeant
Best answers
0
I reported it also, it started with the last hotfix patch for 1.5.2, so 1.5.3 inherited it. And I hope it does get fixed soon, it is so annoying after doing anything to get a 1-3 second pause constantly
 

Shun

Sergeant
WB
Best answers
0
Hi, are you still having the same problem on our current build?
Lag after battle still happens on beta 1.5.3 with today's hotfix installed. Maybe worthy of note is that, after the battle has ended, the camera can be moved and does not lag, and no autosave is created. As soon as a move order is given, there is noticable lag, and a new autosave is created.

Also, when entering a town and choosing "trade" option, there is noticable lag for me, more than in versions before 1.5.3 beta. No autosave is created in that instance.

In the time I had to play tonight, I did not experience any campaign map lag , e.g when just clicking on the map, the game would start to lag like after a battle. Will update when I experience it again.
 
Last edited:

Fell

Recruit
M&BWBNWVC
Best answers
0
I used to get this, and sometimes still do. Occasionally try reverifying game files (seems to help many issues or at least reduce impact of some).

Some of it could just be initial start up delay (after loading the save, it takes some time before item thumbnails, inventory item previews and such will fully render).