1.010 Bug Reports

Red River

Sergeant Knight
Best answers
0
when defendin' sieges with bow it's like I'm shootin' blanks sometimes. the shots just don't register. in order to fix it I have to fire away or just move 'bout a little bit and relocate. everythin' is in first person mode. that happens when shootin' streight forward so it's not an acute angle issue.
 

Lurdze

Knight
Best answers
0
Red River said:
when defendin' sieges with bow it's like I'm shootin' blanks sometimes. the shots just don't register. in order to fix it I have to fire away or just move 'bout a little bit and relocate. everythin' is in first person mode. that happens when shootin' streight forward so it's not an acute angle issue.
Can confirm. The shots do register, just not with it's intended target. If there is a person behind the one you fire at, the arrow will hit him. Moving so you can fire into his sides usually helps - but it is annoying. Usually happens with enemies w/o their shields raised.
 

macethump

Sergeant Knight
Best answers
0
1.011 - still have the "instant bolt reload" bug.  I have the "access inventory at siege tweak" installed, and every time I go to inventory, my crossbow bolts magically reload.
 

Shik

Baron
M&BWBWF&S
Best answers
0
There's a bug with damageable shields. It doesn't work.

In battle, sometimes when you get your shield broken, a message that comes up saying "shield deformed."

However, the shield does not deform after battle, and by pressing the "switch shield" key, (default is scroll down with the mouse) your shield is regenerated in battle.

Damageable shields worked in .751, so why don't they work now?  :neutral:

Also, ammunition (bolts, arrows, thrown weapons) instantly replenished when you go to your inventory - another bug. It was fixed before in previous versions, so why is it broken again?  :neutral:

Also, the horsemen not couching their lances AI bug is still there.

Also, Sword Sisters sometimes won't draw their weapons. (because of the siege crossbows on their back. Something is messed up with the AI.) It wasn't like this in .960.
 

Kleidophoros

Marquis
M&BWBVC
Best answers
0
Bolts Missing from inventory after training field practice.

last night i started a new game. my starting inventory was a "tools", dried fish, a horse, a sword, a shield and a crossbow + a pack of bolts.
i went to Training Field near Tihr. ranged practice with a crossbow. i used 9 bolts and when i was about to shot the last target training ended and game told me it went well.
i left the training field and found a bunch of looters, 3 of them and thought i ould take them out; engaged. in the battle i had 1 bolt only. when i used it game told me i wasnt carryign any bolts. after the battle i checked my inventory, the bolt was really gone.
 

Warger

Squire
M&BWB
Best answers
0
Probably been reported already but in 1.011, after the first or second looter party has been found in the looter quest, all the other's are nowhere to be seen, making the quest impossible to complete.
 

Kleidophoros

Marquis
M&BWBVC
Best answers
0
Soem animation problem

i had a bow, 2 pack arrows, a 2handed sword. ran out of arrows, picked up new ones. in the process dropped the bow and sword, i had to pick/drop/pick/drop stuff a few times till i got the sword, bow and arrows back. but i did mange to at the end. yet, game thought i was still holding the sword. i could fire the arrows by the way.






Warger said:
Probably been reported already but in 1.011, after the first or second looter party has been found in the looter quest, all the other's are nowhere to be seen, making the quest impossible to complete.
i dont think so. once i got that quest from Wercheg, i found looters near Jelkala. they just run away from everyone and end up on the other side of map.
 

rasz

Banned
Best answers
0
version 1.011, this thread is sticky so Im guessing this is where bugs are submitted

I got two missions with same lord (Doru).
One is to get him give back the money he owes (3000), the second one is to talk him into peace with Swadia. If I get the money he owes first  game triggers are getting messed up and giving him the money for the second quest results in "received 3000" message in the log and second quest not registered as completed .. and the game doesnt give me those 3000, it removes 7000 it takes him to make peace with Swadia, he gets stuck in a constant 'taking 7000 from me and printing in log "gave 3000"' loop :sad:
hard do explaint so i made a ZIP with screenshots and save file :
http://www.mediafire.com/?w9m10gjbgy9
 

Kleidophoros

Marquis
M&BWBVC
Best answers
0
Changelog for 1.011 says "Fixed bug where sometimes a horseback character would be thrown forward unrealistically after being killed. "
but this fellow here is Lord Matheas


and this is a Swadian Knight


both going balistic. i dont have any screens for characters thrown forward but that too really happens almost always when i kill a mounted enemy.

****************

Also, sometimes (happened 2 or 3 times) when all defenders are killed or knocked out, you still get these screens below, it goes on a few times then the siege ends and attackers leave.







 

Rongar

Master Knight
M&BWB
Best answers
0
1. It is not certainly bug, but the upgrading scheme in update_volunteer_troops_in_village and update_npc_volunteer_troops_in_village looks odd.
Code:
         (store_random_in_range, ":random_no", 0, 2),
         (troop_get_upgrade_troop, ":upgrade_troop_no", ":volunteer_troop", ":random_no"),
         (try_begin),
           (le, ":upgrade_troop_no", 0),
           (troop_get_upgrade_troop, ":upgrade_troop_no", ":volunteer_troop", 0),
         (try_end),
For troops with 2 upgrade branches probability are 2/3 and 1/2 for the first and  the second branches correspondingly.
I suppose it should be symmetrical. So form the code above only one line should be left.
Code:
      (troop_get_upgrade_troop, ":upgrade_troop_no", ":volunteer_troop", 0),
2. It seems change_screen_buy_mercenaries  works fine in dialogs but I was unable to run it normally  for game menu or triggers.
 
Best answers
0
1. Whenever I'm in a battle and I press escape, the game crashes. This happens in every battle.

2. Sometimes when I'm in a battle, usually a large one where I'm helping a king, the battle starts but I can't see it. I can hear the battle, and I can still hear myself shooting my bow, but the screen stays at the command page before a battle. The screen stays like that forever, even after you finish a battle, and the only way to solve this is reboot.

3. I'm not sure if it's random, but I can't see a trend as to why it comes up. I can't reproduce it at will, but sometimes it just pops up randomly. If I check on my party and click on any unit, I can't see his/her outfit. I get a weird picture, which looks like an inventory, but sized down to fit the size of where you usually see your unit's picture.

These are all in 1.011.


 

Gabeed

Master Knight
Best answers
0
So have we determined whether the military scythe's inability to swing from the left or right was a bug, or a conscious decision?  It's easy to mod it so it does swing, I was just wondering what the developers' intentions were--if they thought a military scythe was too powerful if used like a glaive, or something.
 

Miles

Recruit
Best answers
0


- My gamelog isnt working properly. Theres always text missing on the bottom of the page. (the ingame time was 12 may 1259)

- Whenever I sneak into an enemy town and then visit the prison Im running around with my actual gear again instead of the pilgrim outfit. Also the door of the prison seems to be locked so I cant go back to the town square. I do am able to push TAB and exit town.
 

Papageno

Veteran
Best answers
0
I'm finding the same gamelog bug in my Steam version of the game (1.010), FWIW.

Suddenly, however, I've run into just inexplicable graphics corruption--I was playing the game a good long time today (probably about 4 or 5 hours) without incident, then saved and quit, but when I came back later and started playing again, I got the game text suddenly becoming illegible blocks, and then the colors going all screwy.

I've got an nVidia 8800GT Superclocked, 512MB from eVGA, running the drivers previous to the ones that just came out this week--I'll try uninstalling those and installing the current ones.
Otherwise, a Core 2 Duo E8400 3 GHz, and a Gigabyte EP45-UDR3 motherboard.  Also, an SB Audigy 2 ZS.  Windows XP is all patched up properly.

In case I need to reinstall the game, how do I save my character? Just save the games in the My Documents hierarchy?  Finally, is it possible that my savegame itself got corrupted?



 

Miles

Recruit
Best answers
0
- 'Troublesome bandits'-quest: you always lose this quest when an allied party kills the troublesome bandits. Even when you join the fight.

- 'Following spy'-mission: you always lose this quest if you have 0 points in Prison Management.
 

Arjuna

Recruit
Best answers
0
Running 1.010 and got a failed quest notice.  It was from the guild master in Wercheg to kill the bad guys harassing the town.  I had just checked that there were 18 days left on the quest.  My party rested overnight in town and the next morning there was a message that the quest had failed. Don't have a save prior to the problem so I can't attempt to reproduce it.
 

Boiled Ice

Regular
Best answers
0
This happens mainly when defending a siege.  My arrows pass straight through the people all the time.  It also happens in normal battles rarely when shooting down at a sharp angle, similarly to the angles experienced when shooting from a wall in a siege.  So I'm guessing it's the sharp downward angles which is causing it.  It's very annoying.
 

WhindGhost8

Recruit
Best answers
0
Quest to transport lady to another castle/town: When you ask where she is, the lord will reply that she has been captured by her enemies.
I have been able to repeat this when i had the quest again later.
 

Rongar

Master Knight
M&BWB
Best answers
0
After return from a trade screen (items or prisoners) with traders or companions the information on the relation bar disappears
The quick solution for modders to call script_setup_talk_info after appropriate change_screen_*