1. Resolved Crafted weapons' blade length set bigger than default causes the part to levitate

    Summary: Whenever I craft a weapon and make the blade part bigger than default, the part levitates, detached from the rest of the parts. The crafting preview does not show the glitch at first, it only appears after leaving the smithy. The problem does not appear if I keep the size of the blade...
  2. BlueMonkey

    Resolved Scrolling doesn't work in Smithy when selecting character

    Summary: Scrolling doesn't work in Smithy when selecting character How to Reproduce: Have more than 14 companions in your party, go to a town and Enter Smithy. Select your character to expand the character list to choose any of your companions. Only the first 14 characters show up (I have 39 in...
  3. Resolved Crash entering Smithy

    Summary: When entering the smithy from any city on a new save with no mods, game will crash and exit. I have posted the crash log (which is reproducible) below How to Reproduce: Enter Smithy Have you used cheats and if so which: No Scene Name (if related):prt_crafting_scene Media (Screenshots &...
  4. Joe Friday

    Crafting Fine, Masterwork and Legendary Weapons?

    I have a quick question. How does one tell if the weapon the player creates is a fine, masterwork or legendary weapon? I'm sure it's staring me in the face. Whenever I create two handed sword for instance, all it ever says is crafted two handed sword. It never says fine two handed sword etc. I...
  5. Resolved Smithy UI bug

    Summary: After updating to 1.6. i have had this issue. How to Reproduce: Have you used cheats and if so which: No Scene Name (if related): Media Computer Specs: OS: Windows 10 Pro GPU: Gtx 980 ti GPU Driver Version: 471.96 CPU: AMD Ryzen 5 3600 6-Core Processor 3.95 GHz RAM...
  6. Resolved Crash when entering the smithy

    Summary: Crash whenever I enter the smithy How to Reproduce: Enter the smithy. Which town doesn't matter. I have started multiple new campaigns and all of them crash. Have you used cheats and if so which: no Scene Name (if related): Media (Screenshots & Video): Computer Specs: OS: Windows 10...
  7. vth_Musketeer

    In Progress Crash during Smithing

    Summary: I just conquered the city of Razih while playing as Western Empire. I did a couple iterations of working in the smithy. While I was in the middle of refining some material the game just crashed on me. How to Reproduce: Don't know Quest/Settlement Name (if related): Razih Media...
  8. GalahadIV

    Save Blueprints in Smithy

    Not a very important feature, but it would be cool to be able to save the weapons I create in the Smithy as blueprints, in order to forge them later on.
  9. Knobbed Guards are small

    I've noticed the knobbed guards are scaled quite small for the sword so small im not entirely sure it isn't a bug. Assuming that they are based on the upswept quillions of Highland Claymores historically they should be quite larger. I understand that they are also single handed sword options...
  10. Resolved [1.5.8] Companions can't smith anymore

    I have a companion in my party and she is Nawa the Spicevendor. However, she is not listed in the Smithy screen as shown below.
  11. Need More Info crashing while smithing

    i entered smithy and tried smelting and within 2 minutes game crashes
  12. Resolved [CRASH] When selecting "short pine shaft" at the smithy

    The game crashes when I am selecting items at the smithy. How to reproduce: I select "two handed polearm" to forge. I select shaft. When I click on "short pine shaft," the game crashes.
  13. Resolved Apocaliptic bug around installing the community patch mod from that specific website

    Hi there. ive messing with this bug twice, the first one what in the last patch, and now in the 1.5.2. Basically is everytime that mod is entering in my life, everytime i load the save and load something around models (tournaments, smithy, ingame cities, etc), it crushes and destroying the...
  14. NamFlow

    [✅ PARTIALLY IMPLEMENTED] The Smithy — 3 annoying problems with its UI (video included)

    Game version: v1.5.1.240715 1) If you have a lot of companions, not all of them show up in the selection of character who could be used to smelt, forge and craft items. That means you have to got your party screen and move companions on the bottom to the top for them to show up correctly. This...
  15. Resolved [BUG] Smithy can only show maximum of 10 people

    Latest main version e1.5.0.239030 Where: at the smithy How to reproduce: Have more than 10 heroes in your party The problem: I can't access the 11th hero to use at the smithy I have a party with 11 heroes. The smithy can only display 10.
  16. BL Coding How do i properly implement new crafting templates?

    i understand some of it that i can make a new template xml and add stuff however i please, but when i try to make a completly new template to have seperate crafting stuff i get this i seem to have trouble finding where i can change the text in the smithy to take my new template id, in this case...
  17. Likbjorn

    Resolved [Beta 1.4.1] Smithy: weapon parts being unlocked, but missing in parts list or belong to wrong weapon type.

    Summary: While smelting weapons, I get notification about new parts being unlocked. When I tried to use these parts for crafting, I found that they are missing. After some search, I found that they belong to wrong weapon type. This mostly happens to Two-Handed Sword Grips, which are available...
  18. Troops upgrade only in settlement with smithy

    Another small thing that I find kind of bothersome in its abstraction. Why is it possible for troops to upgrade to something with distinctly different equipment outside of facilities that have smithing services to, at worst, fit the armor to the person? It just doesn't make sense that a bunch...
  19. ZydrateTheSmoothCriminal

    Weapon parts should be available for purchase [Suggestion]

    Title, pretty much. Grinding smithing is already a big pain in the ass but the randomness of unlocking weapon parts makes it so much more frustrating I had to download a mod to unlock them.
  20. Need More Info crash when trying to enter smithy

    game crashes when I try to enter smithy in empire towns. tested on multiple saves on the newest public patch. to reproduce go to argoron, danustica, onira or lycaron. buy 2 hardwood at trader and enter smithy (game will freeze) to reproduce go to argoron, danustica, onira or lycaron. go to...
Top Bottom