not starting

  1. Unresolved Mount and blade warband starts on steam but then nothing happens.

    Hi Guys I'll press the play button for Warband on steam, it then says I'm playing but the screen those choose viking conquest, warband, napoleonic etc doesn't even pop up and so I'm unable to play the game. I've tried basically every method I could find online: Making sure my drivers and...
  2. Aknas

    Resolved Crash on launch, tried multiple suggested solutions, help please

    Summary: I have played Bannerlord in the past with mods and uninstalled it after many hours of fun. Recently I wanted to give it another go so installed the game anew. I was interested in the 1.8.0 version so installed this first. The game crashed on launch. Not trying to determine the problem...
  3. I cant start bannerlord

    Whenever I try to start bannerlord nothing happens. A window doesn't even appear. It just stays 'starting' on steam then turns back to play. I have tried validating the files three times but there isn't any fault. Help.
  4. Need More Info Game is not starting.

    I had brought the game when it was first released and I haven't been able to play the game since. Whenever I start the game, It'll start doing the first time setup and after that nothing occurs at all and the game doesn't launch. I've tried many fixes that I've found but nothing I do seems...
Top Bottom