Search results

  1. Corbul

    SP Tutorial World Map Easily moving all fiefs on Thorgrim's map editor

    But what about castles and training camps? Also, when I try replacing the icons as the tutorial says, all villages get a 'snowy' town icon, Haringoth Castle gets a 'caravan' icon, and Training Camps don't have an icon at all. :neutral:
  2. Corbul

    Other 3D Art The Specialist's OSP Models - v1.2b Released on 11/14

    Sorry to necro again, but with MBRepository going down, the links are busted. :sad:
  3. Corbul

    SP Tutorial Module System Complete Guide to Adding Factions

    (troop_set_slot, "trp_temp_array_b", 8, factions[fac_kingdom_1][6]),
    Is this something out of a specific mod? I can't find something similar in Native (which might be why you haven't encountered such yet). You will need to check that presentation to see what it is doing and what might cause the issue.
    Yes, it's from Diplomacy.
    As you've requested, I'm adding the solution from Discord, kindly provided by user dstn (not sure if they have an account on the forums here)
    Comment out that section with the python lists and build, then uncomment the section. Looks like it's trying to build a list from the previous build's data but using the new additions indices so the new additions are pushing it out of range
  4. Corbul

    SP Tutorial Module System Complete Guide to Adding Factions

    How are you creating a custom culture?
    Like the tutorial says: go to mod_factions, copy culture 6, change it to culture 7, then copy the relevant troop entries in mod_scripts so they use the new troops.
  5. Corbul

    SP Tutorial Module System Complete Guide to Adding Factions

    Hey, I've come across an issue. So I follow the instructions, and when I am to finally create a custom culture, I get this during compilation:
    *** Warband Refined & Enhanced Compiler Kit (W.R.E.C.K.) version 1.0.0 ***
    Please report errors, problems and suggestions at

    Loading module... FAILED.
    MODULE `presentations` ERROR:
    Traceback (most recent call last):
    File "", line 127, in <module>
    from module_presentations import *
    File "C:\Users\Administrator\Desktop\HoW source\", line
    8783, in <module>
    (troop_set_slot, "trp_temp_array_b", 8, factions[fac_kingdom_1][6]),
    IndexError: tuple index out of range

    What's strange is that I've used this tutorial in the past and never had this issue.
    Anyway, how do I fix this? I've tried adding the two new factions to the list, editing the order, but all that does is to just display the same error with a 10 instead of the 8. :mad:
  6. Corbul

    Anyone have a pig head to use for a custom race?

    In the meantime there is the cooked pig model in Native, you can use that as a base.
    Thanks. I actually went with this, except that the new head doesn't have any eyes and since I don't know how to wrap\ unwrap, I can't even assign it a proper texture. :cry:
    Ah, but at least it's something, for the time being. :grin:
  7. Corbul

    Anyone have a pig head to use for a custom race?

    I remember -IYI-O-R-T- had a thread on here, where he took commissions for different heads and bodies for people to use in mods, but that was a long time ago, and Mort hasn't been online since 2020. He's also not been online on moddb in forever, it seems. So I was wondering if anyone has a hog\...
  8. Corbul

    Diplomacy for 1.174

    Hey, I've come across an issue: whenever I try to attack routed enemies, instead of saying their usual "we don't want to fight anymore" dialogue, they say "we are Routed Enemies, on our way to {playername}" and the reinforcements' sound file plays ("by the sword and by the spear!"), and if I choose to attack them, I get a decrease in relations with 'neutral'.

    Also, can anyone tell me how to remove Custom Battles heroes from the tournament participants roster? I've tried commenting them out, but whenever I try to get into a tourney, the game immediately forfeits me.
  9. Corbul

    OSP Code Campaign Claimant's Rebellion

    Does anyone still have this?
  10. Corbul

    How to recruit custom faction troops during claimant rebellion?

    I am not sure if your concept is that the recruits are different if the village is owned by the pretender faction or if you want the recruits of the village depend on if you support the pretender or not.
    Actually, either option is fine.
    Thanks for this! :xf-smile:(y)
  11. Corbul

    OSP Kit Optimisation ModMerger framework 0.2.5

    Guys, I'm at my wit's end, modmerger doesn't seem to work for me! :cry:
    So I downloaded v1.5 from the Nexus, copied the files into my module system folder, ran the install, selected to install, then the window started "installing", then disappeared after a second. Compilation doesn't give any errors. So far so good. Then I get KAOS political kit and copy its files into the module system folder, add the entry to, run the compilation. Successful. When I run the game, nothing changes. So I wonder if I need to actually add every KAOS individual file's name to and compile. Again, no errors, but there are still no changes. "Ok, maybe I need to make the manual edits, as instructed in KAOS' readme", I think. So I do the edits, and what results is errors, because the scripts don't see the new male and female titles, as defined in KAOS' file. Additionally, there are no .bak files in my module system folder after installation. Way I understand it, the modmerger itself doesn't actually install for some reason. What do I do?
  12. Corbul

    LSP Kit Campaign KAOS Political KIT 1.5 Updated

    Hey, I seem to have messed something up. I'm trying to merge KAOS with native, and I followed the readme, and it finally compiled, but when I ran the game, nothing really changed except that right from the get-go I'm the ruler of the "Empire" and "Rebel" factions. What gives?
  13. Corbul

    How to recruit custom faction troops during claimant rebellion?

    Ok, so I'm making a mod, and I want one of the features to be so that the claimant has his own type of troops during the rebellion (i.e. if you're helping Isolla, the troops you recruit from Swadian villages should be different from the standard Swadian troops), and should replace the standard...
  14. Corbul

    OSP Code SP 1 vs 1 Tournament

    Can you please reupload it? MnBRepository is dead :cry:
  15. Corbul

    Getting "'int' object has no attribute '_getitem_'" error

    [(ti_on_weapon_attack, [(play_sound,"snd_pistol_shot"),(position_move_x, pos
    1,27),(position_move_y, pos1,36),(particle_system_burst, "psys_pistol_smoke", po
    s1, 15)])]],

    recount these square brackets (2 vs 3).
    That's just it, I copy-pasted the code from the flintlock pistol, and since I'm using Notepad++ I can see which bracket closes what.

    ["coal_shooter", "Coal Shooter", [("mortar_1",0)], itp_type_musket |itp_merchandise|itp_primary|itp_next_item_as_melee|itp_two_handed, itcf_shoot_musket|itcf_reload_musket| itcf_carry_crossbow_back,
    349 , weight(4.5)|spd_rtng(41) | shoot_speed(6:cool: | thrust_damage(58 ,pierce)|max_ammo(1),imodbits_crossbow
    [(ti_on_weapon_attack, [(play_sound,"snd_pistol_shot"),(position_move_x, pos1,27),(position_move_y, pos1,36),(particle_system_burst, "psys_pistol_smoke", pos1, 15)

    Just in case:
    Last square bracket (green) is for "coal_shooter";
    Second square bracket (red) is for "ti_on_weapon_attack";
    Round bracket (blue) is also for "ti_on_weapon_attack";
    Next square bracket (purple) is for "play_sound";
    Last round bracket (yellow) is for "particle_system_burst".
  16. Corbul

    Getting "'int' object has no attribute '_getitem_'" error

    It looks like you have one too many closing square brackets.
    No, I've checked and they all correspond to an opening bracket.

    I've tried only adding the code to play the sound...
    [(ti_on_weapon_attack, [(play_sound,"snd_pistol_shot")
    And it still gives me the error, even though I closed all the brackets as needed.
  17. Corbul

    Recovered MBRepository Files

    I say, I remember there was a pack on MBRepository that had some modern-ish items, among these were an American football helmet and an 'afro' hairstyle hat. The items were lo-poly, most likely made for MnB Classic. Anyone know the pack?
  18. Corbul

    Getting "'int' object has no attribute '_getitem_'" error

    Ok, so I'm trying to add muskets into my pet mod, and I've succeeded in creating the weapon itself, and want to add the muzzle, smoke and sound effects to the gun. I copy-pasted the effects code from the native flintlock pistol, but when I'm trying to compile, here's what I'm getting: Any...
  19. Corbul

    LSP Kit QoL Animated Menu Making.

    Anyone have a link to the file? The file was deleted on moddb. :sad:
  20. Corbul

    Diplomacy for 1.174

    Hit enter to go to the next line.
    Thanks :smile:
Top Bottom