• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

Search results

  1. Antiquity OSP 3D Art Greek Shield

    Hello. I have poor English) as the three shared a nice shields. 100% of my work. License bearware (bet me a beer and meet me.) Link: http://www.mbrepository.com/file.php?id=2480 If the link is expired please let me know in the topic Here Screenshots:
  2. Help! The problem with patches.

    Hi! I downloaded the full version of Mount and Blade Warband 1.127, but is still the same error. But the fashion version of an 1.127 work correctly. Please help. :cry:
  3. Help! The problem with patches.

    ok thanks :oops:
  4. Help! The problem with patches.

    Hi! I have a problem I play Mount and Blade Warband on patch 1.127 When I enter the server it pops me an error that I have version 1.125. What can I do to be able to play on the servers? :roll:
Top Bottom