Search results

  1. Native Expansion v .586 for Mount & Blade (NOT WARBAND!). Download details.

    Patch 0.580 is mainly some bug fixes.
    I'm off the internet for about a month now due to work/moving/life/bad luck so there may or may not be any updates for quite a while. (He does the compiling, Python doesn't work for me :razz:)
  2. Bug Reports and Known Bugs

    I'm gone for a week working on my master's thesis and you guys post a TON.  Successfully defended today, though, so I'll be more active again.

    cadaver: When you say you can't recruit elite troops after giving a town to a lord, if it's the special once per week units that require the special buildings, this is intentional.  The lord that owns the town gets all the troops generated.  If you mean nobles... I need to look into that, as that would be a bug.

    In regards to the bug about going to war with your own faction, I'll try to add even more checks to the code to prevent this.

    I tried "fixing" the looter quest, but I think I broke it worse than it was.  I may just change it back to spawning merc parties instead of bandits until I can give it a closer inspection.

    Admittedly I haven't been playing at all the past week, but I have yet to see these 0 troop patrols, I'm dying to encounter one for myself so I can try to figure out what's causing it.

    Mini Marine: Importing and exporting is hard code.  We raised the skill caps in the module system, but the import/export system doesn't seem to support the raises.  Nothing we can do other than what you've already described as your fix.

    Gwyllion: A number of the trade markets were changed with .570 and are randomized to some extent every game.  That might be the cause.  But, raising the amount of money at each town WILL cause problems.  I've explained it before.  Every 1 or 2 weeks the game looks at the amount of money every merchant has, and takes away chunks of 3000 denars.  These chunks are then converted to prosperity for the town.  So if the merchant always has over 3000 regardless of what the player does, you will generate an endless cycle of prosperity for the town.

    DiegoRock: If you saw that error shortly after a huge battle then you can ignore it.  It has to do with lords getting lost in giant battles.  The teams go over the hard coded limits in the number of troop types that can be included, so the game forgets to do anything with the excess, and if it's a lord whose team is defeated then they aren't handled properly.  I've added a ton of error checking to the game to fix it as they're encountered, and since you only saw that error once I think the error checking is working correctly.  If you see the error 5 or 6 times in a row close together, then we might have another problem.

    Anyone still experiencing clone problems please make sure you're running .570 and that you've started a new game.  If you have, and you still encounter a clone of yourself, then let me know.  If you report a clone and do not specifically say you are running version 0.570 and have started a new game then I'm going to assume you haven't, and ignore you, as it appears this is the new replacement for indicating what people haven't installed the patch.  We went from "Lol Tihr slave trader offers 128471894710927189 denars" to "Hey! I killed myself!"  oh well...
  3. Oddest bug ever - I killed myself? I took myself prisoner? Twice?

    First, this should probably be in the Native Expansion subforum, as it appears you're using an outdated version of the mod.  The clone problem did occur in .550 and .560, but should be fixed in all new games started in .570.

    Second, please put your images behind spoiler tags as they take quite a while to load...
  4. Bug Reports and Known Bugs

    Tismanu: She's still in.  You just haven't found her yet is all I can say.  As for the HP bug you're reporting, I can't seem to duplicate that... I've tried activating and not activating the camera, I've tried open field battles and sieges, I just can't get it to give me 100% health like you describe... Is anyone else experiencing this bug?

    Shawyn: Thanks for pointing that out, was easy enough to fix, so it'll be corrected in the next patch.

    ollijo: I have no idea why the camp menu is causing your game to crash, but this is the first I've heard of that, so there might be something else wrong with your install.  Don't know what else to tell you.

    Adrius: Thanks for pointing that out, I completely overlooked that.

    The "invisible parties" joining battles are probably happening near villages, castles, or towns.  They're parties that are in those centers coming out to help.  I made sure the garrisons to the towns and castles don't come out to help, but there were some party types that have no identifier flags to look for so I skipped them.  I'll work on sorting them better for the next patch.
  5. Suggestions for Implementation within the Mod

    Installing that map mod would require starting over to see most of the changes, because it does change the locations of some objects on the map which are set at the start of a game.  And look at the timestamp on almost all the .txt files.  Every time we rebuild the module system it updates most of the txt files whether they need to be or not.
  6. Special items?

    Looting is still looting.  Kill a unit and have a chance at getting anything it's equipped with.
  7. v560 vs 570

    .55 and .56 both had a bug that would cause clones of the player to be created at the start of a game.  They were hidden in 4-6 lord's parties usually all over the map.  This is why .57 is not compatible, the code to fix it HAD to go into the code that sets the games up, and every game made with .55 and .56 had this bug.  You will eventually see very strange things if you hadn't already.

    On a side note, both .56 and .57 should require hitting the jump key to go into free camera mode after the player is knocked out.  It's only supported in battles that will not end when the player is knocked out, of course.
  8. Legacy of the King - Brand new mod! [Work in Progress]

    I may be wrong, but isn't http://forums.taleworlds.com/index.php/board,9.0.html where this should have been posted?  This forum is for people discussing how to implement things in mods, the linked forum is for listing the mods themselves...
  9. map a key to overhead sword swing

    The best you can hope to do is write a full script that mimics an attack, but you can never write a script that forces an attack.  It's one of the limitations of the module system.  So you can write something that causes the animation when the key is pressed, but then you also have to write in all the code that calculates and delivers the damage as well as ranging, readiness, etc.

    I hope someone proves me wrong on this, but I don't think I am.
  10. Suggestions for Implementation within the Mod

    We haven't edited either parties or the map, so I just installed and tried out that map thing.  Works fine for me, though I'm not particularly fond of it, myself.  If you tried it with .550 or .560 and were experiencing errors, those errors probably had little to do with that mod. :wink:  Try it now, with .570.
  11. Bug Reports and Known Bugs

    Jenbu: couldn't tell you, if you reinstall and still get that message, then it sounds like something IS affecting your file and maybe you do have a virus.  Try submitting it to http://www.virustotal.com/ and see what it says.  But honestly I have no clue.

    Leona: Shield textures are not changed.  If you're still running .544 then you can keep doing so without worry, you just don't get the new added features.  If you're running .550 then I strongly recommend you move to .570.  All .550 games are broken.  You just may not have realized it yet, but you will eventually encounter a horrible bug.

    Stylus: Sounds like you're suffering the bug that was fixed in .560.  You'll want to update to .570 and start a new game anyway so it's kind of moot, but have the Dark Knights invade immediately, and see if you still have that problem after the invasion.

    Tismanu: I'll double check on the 100% HP, but everything else is exactly as from Native.  If you have enough troops to not be a total defeat then it forces the end of the siege and the AI has a chance to change its mind about having the siege if it lost too many troops.  If you start the battle and immediately retreat without any losses on either side the AI should decide it still wants to siege, but something more important might come up, you never know.  The AI is a fickle thing.
  12. Auto-Equip Command.

    First off, this should be in the suggestion for implementation.  Second, it's already mentioned in that thread about 10 times by other people.  Third, no.  The auto-loot code has problems with it that make it incompatible with our mod.  The amount of rewriting that I would have to do to work that into this mod is immense and I might as well start from scratch.  I might start from scratch and implement something similar eventually.  Maybe.  But not for a while.  Next time, please post in the correct thread, this one is now locked.
  13. Bug Reports and Known Bugs

    There were some pretty bad bugs well hidden in both 550 and 560 which is why I'm ignoring ALL bug reports from people not running 570.  When you get hidden clones of the player running around there's no telling what strange errors can occur.  So first off, upgrade to 570 and see if you get the same errors.  Second, if you DO get script errors, please tell me exactly what they are.  SOMETHINGSOMETHING is no help.
  14. Native Expansion v .586 for Mount & Blade (NOT WARBAND!). Download details.

    Version 0.560 and 0.570 were major bug fixes.  They were bound to happen with the amount we changed in 0.550....
    It also adds a toggle to start the camera after being knocked out in battle.  Hit the jump key to start free motion on the camera.
  15. Bug Reports and Known Bugs

    *sigh*

    Well this is certainly game breaking.  Why I never saw this in any of my testing I have no idea, but it tells me it was one of the more recent changes I made to the code that is causing it...

    Clones of the player are being spawned in parties.  I'm not entirely sure why, but I have a few ideas and I'll be staying up tonight until I get it fixed and a patch out.  This is also probably the cause of the random XP gains, as the parties the clones are in do things that get them xp, the player is awarded the same xp.

    EDIT: Found it and fixed it.  I really LOVE finding bugs from Native that have lain dormant until a change we make shows bad programming on their side.  Anyway, I shouldn't lay blame, I should've put more error checks into my code anyway.  Another patch is forthcoming, unfortunately it's .570 because it will break saves yet again.  But that's mainly because everyone's game is already broken anyway, they may just not realize it yet...
  16. B Tutorial Module System String typer kit v0.76 **updated**

    In the line:
    (troop_get_slot,reg1,"trp_temp_array_b", "$str_len"),
    Change it to:
    (troop_get_slot,reg1,"trp_temp_array_b", ":mad:count"),
  17. Troubles creating a new town as per Module System Documentation part 2

    I'm going to assume you are rebuilding your module after adding the line and before loading mount and blade.  Because I can assure you, the only change I made was adding that one line, and there was a new town called Modd down in the Khergit territory up on a hillside.  If it's not showing up for you then you have something wrong with your module system or python install and I can't help you.
  18. Bows??

    At least two other threads have covered this topic before.

    First: http://forums.taleworlds.com/index.php/topic,54029.0.html
    Second: http://forums.taleworlds.com/index.php/topic,51406.0.html
  19. Troubles creating a new town as per Module System Documentation part 2

    Using a new icon shouldn't be a problem at all, as long as you actually have the new icon in your mod.

    I added the line:
    ("town_19","Modd",  icon_town|pf_town, no_menu, pt_none, fac_neutral,0,ai_bhvr_hold,0,(20, -69),[], 135),
    to my module_parties file, recompiled, and started a new game, and sure enough I could see the town.  Of course, keep in mind there's a lot more to adding a new town than just adding that one line.  There's a lot of setup script in the game_start script that sets up the towns for use.  Do a search for "# Towns:" and look at the many many many lines of code below it.
  20. Troubles creating a new town as per Module System Documentation part 2

    You have failed to say what the problem you're having actually is.

    ("town_19","Modd",  icon_newtown|pf_town, no_menu, pt_none, fac_neutral,0,ai_bhvr_hold,0,(20, -69),[], 135), looks fine.

    ("newtown",0,"mcn_no_shadow", 0.35,0), is probably what you want if you used an existing town icon as a base for your new icon.  So what's the problem you're having?
Top Bottom