Search results for query: *

  • Users: Piet
  • Order by date
  1. Household Guard/Knighthood Order System tutorial?

    I am looking to add a new feature to my mod. I was inspired by mods like perisno which has a system that gives certain lords their own unique troops or pendor which has knighthood orders that are tied to fiefs. I have searched for a bit and could not find a tutorial for a similar system. It...
  2. Cannons

    I have looked around for a while and have not found a conclusive guide anywhere. I would like to replicate the cannon feature in singleplayer mods like L'aigle but I don't know from where to begin. I don't expect anyone to create an in depth guide just for me but if there are any resources...
  3. Equipment randomness not working well

    Does it change something if you change the order of the items at the troop tuple (given that they have still the same stats and prices etc.)? If you switch the item entries' position with each other, does that change something?
    No nothing changes, the first item on the list appears on all troops but one of them who has the second list item.

    I think I will move on from this, it is a bummer. The final thing I am going to test is replicating the same thing on maybe the VC modsys and see if it behaves differently and try to learn why. I thank you for the help and communication.

    Edit: what is also silly is that the randomness seems to work fairly well with enemy armies, i will see if also works with friendly armies.
  4. Equipment randomness not working well

    At which place did you add your new items? At the same place at which the other armouries and helmets are or at the bottom of the list?
    Originally when I made this post they were at the bottom, now I have put them with other armours and helmets and now the second item doesnt show up even once.

    Edit: Im also using a separate inventory model and the main model is rigged, can that possibly effect the randomness? It is still weird that only one different soldier is spawned though.
  5. Equipment randomness not working well

    Are you testing it in multiplayer, in a singleplayer campaign or in a custom battle?
    singleplayer campaign
  6. Equipment randomness not working well

    I am aware about the way assigning armour to troops works in Warband, about all the flags and how soldiers treat the items you list in the modsys as more of an inventory to pick from. That being said, I can't explain this issue. I have added two available body armours and two helmets, the first...
  7. Morgh's M&B Editor - Crash Problem

    If you are working with a Module System anyway you could just leave Morgh's Editor away and add new troop and item lines by yourself. It is basically a copy pasta of other lines with edits like you want to have them.
    Yeah I might have to do that, just morgh's was a quick and useful tool to edit and remove stuff cleanly without leaving things out, just wish I could get it working again.
  8. Morgh's M&B Editor - Crash Problem

    I have used morgh's editor before to make changes to a normal module system and it worked fine, still does. Yet when I try to open a diplomacy plus module system for warband and lets say I try to use the troop editor, the editor window opens blank without any information and when I try to click...
  9. Banner Shapes

    Perhaps this here is still a help for you:
    Yes! thanks. I apologize for not spotting that before I made this post.
  10. Banner Shapes

    In Warband there are three types of banners carried by the lords on the main map. For my mod, i dont want the horizontal or the square banner, i want all the lords to carry the vertical shape. What part of the module system handles deciding what to give certain lords or what banner is always a...
  11. Map icons remaining bright at night

    Check at OpenBRF which shader the material uses and compare it with the one of Native map icons.
    thanks this is it, I think most mods just use shaders in the CommonRes folder. Thanks for the help
  12. Map icons remaining bright at night

    After making a custom city icon and successfully loading it in game, I have noticed that when night time approaches, the icon remains bright instead of becoming darker like the native models already in game. How would one go about fixing this? Thanks
  13. Texture not found in OpenBrf

    Check in your module.ini file if you have set scan_module_textures = 1. Also there should be a material and a texture entry at OpenBRF, additional to your mesh entry. Do you have them?
    Thanks for explaining that I needed the material and texture entry, I didn't know that.
  14. Texture not found in OpenBrf

    I think I have everything set up correctly but I'm not sure if I understand the way this works. All I know that's working for sure is that the mesh is properly referenced in the module.ini file and well implemented into the module system. The game works and the model shows up in game yet its all...
  15. Change Currency

    There's a script that is called by the engine named script_game_get_money_text whenever it needs to display the amount. You can edit it here, or go to module_strings and find "str_1_denar" and "str_reg1_denars"

    So,
    Python:
      #script_game_get_money_text:
      # This script is called from the game engine when an amount of money needs to be displayed.
      # INPUT: arg1 = amount in units
      # OUTPUT: result string = money in text
      ("game_get_money_text",
        [
          (store_script_param_1, ":amount"),
          (try_begin),
            (eq, ":amount", 1),
            (str_store_string, s1, "@1 Flim-flam"), # "@" Denotes a quickstring, it's a fast way to add non-reused text to a script
          (else_try),
            (assign, reg1, ":amount"),
            (str_store_string, s1, "@{reg1} Film-flams"),
          (try_end),
          (set_result_string, s1),
      ]),

    Or

    Code:
      ("1_denar", "1 Flim-flam"),
      ("reg1_denars", "{reg1} Flim-flams"),

    The second one would be nicer for translation or localization efforts later down the line because the true value of the script is that it can be used for more exciting things like splitting money across different valuations like silver, gold, platinum, etc.

    Python:
      #script_game_get_money_text:
      # This script is called from the game engine when an amount of money needs to be displayed.
      # INPUT: arg1 = amount in units
      # OUTPUT: result string = money in text
      ("game_get_money_text",
        [
          (store_script_param_1, ":amount"),
          (try_begin),
            (eq, ":amount", 1),
            (str_store_string, s1, "@a point"),
          (else_try),
            (lt, ":amount", 100), # Fewer than 100
            (assign, reg1, ":amount"),
            (str_store_string, s1, "@{reg1} points"),
          (else_try),
            (store_div, reg2, ":amount", 100), # Dividing by 100 will remove 10s and 1s places
            (store_mod, reg1, ":amount", 100), # Mod 100 will leave ~just~ the 10s and 1s places
            (str_store_string, s1, "@{reg2} BIGpoints and {reg1} points"),
          (try_end),
          (set_result_string, s1),
      ]),
    thanks this is just what I needed, appreciate it
  16. Change Currency

    I have been looking round the forum and round all the module system files trying to find something relating to the currency that is displayed in game. I have found instances of the word "denars" used in conversation with the npcs but I don't think I have come across the code which displays the...
  17. Cant get my map to load

    Yeah ok issue isnt bloodpass it was just a fluke with my map, the model had something wrong with it.
  18. Cant get my map to load

    Im at my wits end. I have no clue what is causing the issue. This was all working fine up until a few days ago. Maybe someone can share what versions of java they are using that makes bloodpass work so I can try replicate the same thing.
  19. Cant get my map to load

    I have no experience whatsoever as a mapper, so forgive me asking such obvious question: are you working with the original game (M&B) when working with the editors? At least one of them (Thorgrim's) works with the original M&B only.
    From what I gathered from this forum and my own experience, saving the map in Thorgrim's modifies the original M&B map.txt file but if the file is copied over to WB module then it works just fine.
  20. Cant get my map to load

    Ok I've narrowed the issue down to a problem with my copy of the Bloodpass editor. Using only what Thorgrim's outputs works so i guess ill have to try to get as much done with it as possible.

    Just leaving this here if maybe someone will face the same quirk as I'm having in future.

    Edit: When I export the Bloodpass map and load it successfully into Thorgrim's and then export it from there, it still doesnt work so Bloodpass might somehow be corrupting it in a way. I dont know if this is a one time fluke but it would hurt to lose this map and start from scratch nontheless.
Back
Top Bottom