• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

Recent content by LFerryT

  1. OSP 3D Art Open Source Project - Weapons

    HELP ME ERROR BLUNT-WEAPON
    95145045.jpg

    AND ERROR OSP_POLEARM AND SWORD
    29185827.jpg
  2. OSP Medieval 2D Art maw's Shield Pack

    I want to ask ospshield and horse can work do so in m&b v1011 ?
  3. LSP Medieval 2D Art maw's Armor Pack 1208 UPDATED

    sorry . Your mod is very good  :mrgreen:
Top Bottom