Author Topic: Version 1.152 Compatibility?  (Read 14784 times)

0 Members and 1 Guest are viewing this topic.

shooter215

  • Recruit
  • *
    • View Profile
  • Faction: Nord
Version 1.152 Compatibility?
« on: April 27, 2012, 11:56:29 PM »
Is the current Diplomacy Mod able to work on 1.152? It worked fine on 1.151 and I'm just wondering :?:

SandmanX2

  • Veteran
  • *
  • These Colors Don't Run
    • View Profile
  • Faction: Khergit
  • M&BWBWF&S
Re: Version 1.152 Compatibility?
« Reply #1 on: April 28, 2012, 07:38:24 AM »
yep it works. itll say "the current compatiable version is 1.143 and you have 1.152 installed, do you wish to continue installation" Just install and viola! I havent had any issues with it. Only thing you cant run WSE(unless its been updated over past week that im unaware of)

Galdus

  • Veteran
  • *
  • Galdus
    • View Profile
  • Faction: Rhodok
  • MP nick: _Macleod
Re: Version 1.152 Compatibility?
« Reply #2 on: May 09, 2012, 05:57:34 AM »
What will loosing WSE do to the game? I have the battle orders installed as well.

Caba`drin

  • Administrator
  • *
  • It's time to toss the dice.
    • View Profile
  • Faction: Nord
  • MP nick: Caba_drin
  • M&BWBWF&SNW
Re: Version 1.152 Compatibility?
« Reply #3 on: May 09, 2012, 04:21:03 PM »
What will loosing WSE do to the game? I have the battle orders installed as well.
You'll get a host of script errors (and broken features) if you are trying to play the Diplo+PBOD that requires WSE.

Is the current Diplomacy Mod able to work on 1.152? It worked fine on 1.151 and I'm just wondering :?:
Just note that you aren't getting any of the campaign script bugfixes from the 1.15x patches when you're playing your 1.143 Diplomacy on 1.15x. Other than that, it should work fine.



Mister Six

  • Recruit
  • *
    • View Profile
  • Faction: Nord
Re: Version 1.152 Compatibility?
« Reply #4 on: May 14, 2012, 01:09:36 AM »
I have 1.152 installed through Steam, but when I went to install Diplomacy it said I had an 'unknown' version of Mount and Blade Warband installed :(
The mod appears to open up fine to the main menu, but the list of saved games is empty, so it seems I can't import my Native save file onto this, any ideas how I'd go about doing this?

Alyiakal

  • Sergeant
  • *
    • View Profile
  • Faction: Neutral
  • M&BWBWF&SNW
Re: Version 1.152 Compatibility?
« Reply #5 on: May 14, 2012, 02:41:20 AM »
You have to go to your savegames folder, which should be under "My Documents". There will be a folder in there called "Native", which contains your native savegames. If you haven't made a Diplomacy save yet, just copy the folder and name it "Diplomacy".

Cornelius Constantine

  • Veteran
  • *
  • CHAAAAAAAAARGE!
    • View Profile
    • GWHobby.net
  • Faction: Nord
  • WB
Re: Version 1.153 Compatibility?
« Reply #6 on: May 22, 2012, 08:09:16 PM »
Updating the topic... is it compatible with 1.153?

Caba`drin

  • Administrator
  • *
  • It's time to toss the dice.
    • View Profile
  • Faction: Nord
  • MP nick: Caba_drin
  • M&BWBWF&SNW
Re: Version 1.152 Compatibility?
« Reply #7 on: May 22, 2012, 08:27:35 PM »
Still applies:
Just note that you aren't getting any of the campaign script bugfixes from the 1.15x patches when you're playing your 1.143 Diplomacy on 1.15x. Other than that, it should work fine.



Carnivorious

  • Sergeant at Arms
  • *
  • Carnivorious ™
    • View Profile
    • Carnivorious
  • Faction: Rhodok
  • MP nick: Carnivorious
  • M&BWBWF&S
Re: Version 1.152 Compatibility?
« Reply #8 on: June 12, 2012, 08:58:04 PM »
Maybe it's just me, but it seems none of the towns will load. If I take a walk around the streets, things get ugly and all the citizens clutch together...
(click to show/hide)
(click to show/hide)

Bismarck

  • Knight
  • *
    • View Profile
  • Faction: Neutral
Re: Version 1.152 Compatibility?
« Reply #9 on: June 13, 2012, 12:50:35 PM »
In theory, you only need to copy the diplomacy code into the module system for Warband 1.153 and it should work again. So, why hasn't anyone tried it?
A little cooperation could achieve this very fast. Every person takes care of a single python file and after some bughunting and testing, diplomacy for 1.153 would be finished.

koteko

  • Sergeant
  • *
  • Butt-kicking! For goodness!
    • View Profile
  • Faction: Swadian
Re: Version 1.152 Compatibility?
« Reply #10 on: June 14, 2012, 07:08:31 PM »
I've just finished doing it. It was a pain..a real pain. I've bug-hunted it decentely and finally there are no errors in compiling.

Sadly, it crashes quite soon. I'm a bit too tired of that thing, now, but if anyone is willing to try to find out what's wrong with it, here it is:

http://dl.dropbox.com/u/23664530/diplomacy1153.zip

Just one note: "lord_find_alternative_faction" in module_scripts has been commented out and replaced with the "old" diplomacy one, because it was too different. It was the last script and I hadn't got the will to think how to integrate the two.

Sernays

  • Knight
  • *
    • View Profile
  • Faction: Swadian
Re: Version 1.152 Compatibility?
« Reply #11 on: June 16, 2012, 05:10:22 PM »
Hi, I accidentally launched Diplomacy in 1.153 and my save is corrupt to the previous versions. This patch posted by Koteko does not work for me. I can run the game but performance in battle are considerably reduce it. You have a solution or is screwed? Thank you.
« Last Edit: June 16, 2012, 05:30:08 PM by Sernays »

koteko

  • Sergeant
  • *
  • Butt-kicking! For goodness!
    • View Profile
  • Faction: Swadian
Re: Version 1.152 Compatibility?
« Reply #12 on: June 16, 2012, 07:00:57 PM »
Mine is not a patch, and was not supposed to work (in my pc, it doesn't).

Normal diplomacy with 1.153 should work flawlessly, I play with it since 1.151..

Sernays

  • Knight
  • *
    • View Profile
  • Faction: Swadian
Re: Version 1.152 Compatibility?
« Reply #13 on: June 16, 2012, 07:23:36 PM »
I have lost fps, the screen freezes 1 second, then 1 second after it freezes again ...

There is no way to retrieve a save corrupted  :|?

BDK

  • Recruit
  • *
  • An axe to the face
    • Steam - thebdk
    • View Profile
  • Faction: Neutral
  • MP nick: EpicMustache
  • WB
Re: Version 1.152 Compatibility?
« Reply #14 on: June 28, 2012, 03:13:56 PM »
It's pretty bugged when you run your own faction. Lords auto join which I don't like. I need to be able to approve and assign fiefs before they join, but with diplomacy installed it completely skips that step. Grr such a shame.