Author Topic: 1866 - Bug Reports (v0.9.1 only)  (Read 16927 times)

0 Members and 1 Guest are viewing this topic.

yellowmosquito

  • Moderator
  • *
  • Seize Him!
    • View Profile
  • Faction: Bandit
  • WB
1866 - Bug Reports (v0.9.1 only)
« on: April 19, 2011, 06:17:02 AM »
Please report any bugs, problems, or unintended effects for 1866 v0.9.1 here.   


BEFORE POSTING ABOUT A BUG/CRASH:

Please read/search this thread to see if a bug has already been reported.  If your bug has already been reported, your post may be removed. 

Be as specific as you can, and tell us how we can reproduce the problem if you can.  Remember: if we can't find it, we can't fix it...  If you experience a CTD (Crash to desktop), please fill out the form below:

Copy/Paste this form and fill it out to make sure you tell us most of what we need to know:

(click to show/hide)
The problem:
  • What is the problem? -
  • How did it happen? -
  • Where were you? -
  • What were you doing? -
  • Any other important details? -
My computer:
  • Operating System -
  • CPU -
  • Total Memory -
  • Video Card -


It is also a good idea to check the fixed bug list to see if your problem has already been resolved in an upcoming version or patch:




Common Technical Issues

I keep getting random crashes that say "RGL error - Unable to restore vertex buffer"!
This seems to be a potential problem when playing 1866 on Windows 7 or with a video card with limited video memory.  You can usually get this to go away by reducing the texture size in the Mount & Blade configuration options.
You may have an awesome computer, but M&B has it's limits when it comes to textures.  Please reduce the texture size until your crashing stops.
(click to show/hide)
Please refer to these posts for additional troubleshooting hints:

http://forums.taleworlds.com/index.php/topic,197235.0.html
http://forums.taleworlds.com/index.php/topic,166209.msg4029442.html#msg4029442
http://forums.taleworlds.com/index.php/topic,163377.msg3957912.html#msg3957912
http://forums.taleworlds.com/index.php/topic,163547.msg4022088.html#msg4022088
If you still are experiencing problems, please file a bug report or create a separate thread for the issue.


I can't get 1866 to work at all!
1) Did you try installing this for Warband? If so, it won't work.  1866 will only work for M&B v1.011.

2) Have you modified your core M&B game files?  Some mods don't play nice with others.  If you've done this (or even think you may have done this), please first try reinstalling M&B AND 1866.

3) Was your download somehow corrupted?  Try re-downloading 1866 and attempt a reinstall.  Alternatively, you can also check the MD5 hash of the executable you downloaded with the one in the release thread to make sure your download was not somehow corrupted.



Thanks in advance for your help!!
« Last Edit: December 31, 2011, 09:55:26 AM by yellowmosquito »

MariusThePaladin

  • Knight
  • *
  • Medieval facepalm
    • View Profile
  • Faction: Swadian
  • MP nick: MariusThePaladin
  • WB
Re: 1866 - Bug Reports (v0.9.1 only)
« Reply #1 on: April 19, 2011, 11:41:44 AM »
First bug :

 Ammunation in trainning ground are too much.


Rifle

(click to show/hide)

Pistol

(click to show/hide)


Second bug : Living Deads become humans, and the Tull music doesn't play when I enter Tull. lol

(click to show/hide)
« Last Edit: April 19, 2011, 03:44:31 PM by MariusThePaladin »

If you like Mech, check this game out, still in early beta though.
mwomercs.com/

Kitfux

  • Veteran
  • *
    • View Profile
  • Faction: Khergit
Re: 1866 - Bug Reports (v0.9.1 only)
« Reply #2 on: April 19, 2011, 01:16:51 PM »
The 40 rounds are probably working as intended to prevent convenient abuse of firearms training for insta-levelling of troops  :P

Some minor bugs:
#1: Still get randomly messages that I have finished the casket quest when entering villages. And the corresponding quest log entry.
#2: Weird lighting in Kuhtu Commander's Room/Cave for Indian characters with naked torso. Works when warpaint is applied, though.
#3: The images in the pic_*.dds files get stretched by something like 30% horizontally when displayed in-game, leading to somewhat squat looking characters compared to the originals.


Digital Donut

  • Regular
  • *
  • Demacia, now and forever!
    • View Profile
    • Parallel Voltage
  • Faction: Rhodok
  • MP nick: a rusty donut
Re: 1866 - Bug Reports (v0.9.1 only)
« Reply #3 on: April 22, 2011, 03:10:26 AM »
Shady Vally Hotel is still unattackable for AI's, every time they besiege it, they never go in and attack, longest I'v tested this was 1 year and 3 months game time...

Male NPC's STILL act like females, including myself. (some NPC's like bill hamilton and remington robert don't have this problem for some reason)
« Last Edit: April 22, 2011, 03:13:37 AM by Digital Donut »

nomad1414

  • Squire
  • *
    • View Profile
  • Faction: Neutral
Re: 1866 - Bug Reports (v0.9.1 only)
« Reply #4 on: April 22, 2011, 12:36:21 PM »
hi
thanks for the nice mod :D :D :D :D
but in quick battles sometimes my bullets don't affect the enemy although i'm good at shooting
especially in a mission like "the man with no name"
it's not a big problem anyway
in future versions make more and more quick battles
If death is a must , it is a deficit to be a coward .

hokomoko

  • Recruit
  • *
    • View Profile
  • Faction: Neutral
Re: 1866 - Bug Reports (v0.9.1 only)
« Reply #5 on: April 24, 2011, 02:24:31 PM »
About shotguns and dynamites,
it appears that you receive no XP from kills made with them (or at least no message is shown).
Moreover, I have a suspicion that when you get shot by shotguns, the damage isn't reduced according to the game options.

Sirion

  • Recruit
  • *
    • View Profile
  • Faction: Neutral
  • M&BWBWF&S
Re: 1866 - Bug Reports (v0.9.1 only)
« Reply #6 on: April 24, 2011, 02:27:33 PM »
Starting as American Indian, having no money at all I am still able to pay 3 dollars to various outlaws to leave me alone. Also sometimes seem that my bullets just passing through the enemy with no harm (Singleplayer mode).

hokomoko

  • Recruit
  • *
    • View Profile
  • Faction: Neutral
Re: 1866 - Bug Reports (v0.9.1 only)
« Reply #7 on: April 24, 2011, 05:21:06 PM »
And another one, it seems the Duvalle family purchased a cloning facility somewhere in 1865:
(it's 2 screenshots superimposed)
(click to show/hide)
I've found my Duvalles as prisoners of Gordon or Ross (can't remember) and offered them to join me.

Shrugging Khan

  • Sergeant Knight at Arms
  • *
  • Schiavona to the face!
    • View Profile
  • Faction: Swadian
  • MP nick: Shrugger
  • WBNW
Re: 1866 - Bug Reports (v0.9.1 only)
« Reply #8 on: April 25, 2011, 03:16:23 AM »
Upon loading a saved game: RGL Error, Invalid number of Item Kinds.

Game is unplayable.
  THE BEATINGS SHALL CONTINUE - UNTIL MORALE IMPROVES! 

MariusThePaladin

  • Knight
  • *
  • Medieval facepalm
    • View Profile
  • Faction: Swadian
  • MP nick: MariusThePaladin
  • WB
Re: 1866 - Bug Reports (v0.9.1 only)
« Reply #9 on: April 25, 2011, 02:46:52 PM »
1. You could be hurted by shotgun at far range, while you can't deal that much damage by shotgun from the same range.  :? (In other words, AI could snipe me with shotgun. :| )

2.Your companions (not sure about regular bomber) do not use dynamite in battle, even when you give it to them as only weapon. They just hold it and running around.

If you like Mech, check this game out, still in early beta though.
mwomercs.com/

yellowmosquito

  • Moderator
  • *
  • Seize Him!
    • View Profile
  • Faction: Bandit
  • WB
Re: 1866 - Bug Reports (v0.9.1 only)
« Reply #10 on: April 25, 2011, 06:12:21 PM »
Upon loading a saved game: RGL Error, Invalid number of Item Kinds.

Game is unplayable.

No, v0.9.0 savegames are just incompatible.

Shrugging Khan

  • Sergeant Knight at Arms
  • *
  • Schiavona to the face!
    • View Profile
  • Faction: Swadian
  • MP nick: Shrugger
  • WBNW
Re: 1866 - Bug Reports (v0.9.1 only)
« Reply #11 on: April 25, 2011, 06:21:24 PM »
Well, that explains a lot.
  THE BEATINGS SHALL CONTINUE - UNTIL MORALE IMPROVES! 

Danny-Q

  • Sergeant
  • *
    • View Profile
  • Faction: Neutral
  • M&BWB
Re: 1866 - Bug Reports (v0.9.1 only)
« Reply #12 on: April 27, 2011, 08:51:47 PM »
Game crashes everytime I move towards the bar of the Cottonwood saloon, dunno if it would crash in other ones yet.

Edit:
That's strange, went to another town first instead then tried Cottonwood, didn't crash on me this time.
« Last Edit: April 27, 2011, 08:58:34 PM by Danny-Q »

yellowmosquito

  • Moderator
  • *
  • Seize Him!
    • View Profile
  • Faction: Bandit
  • WB
Re: 1866 - Bug Reports (v0.9.1 only)
« Reply #13 on: April 29, 2011, 04:25:15 PM »
Game crashes everytime I move towards the bar of the Cottonwood saloon, dunno if it would crash in other ones yet.

Edit:
That's strange, went to another town first instead then tried Cottonwood, didn't crash on me this time.

If this really bugs you, try lowering your texture slider a bit each time this happens until this doesn't happen any more.

shikaka

  • Sergeant at Arms
  • *
    • View Profile
  • Faction: Neutral
  • WB
Re: 1866 - Bug Reports (v0.9.1 only)
« Reply #14 on: May 02, 2011, 08:22:47 AM »

1. I took the 'train villagers and then face bandits quest' in Tres Pierdas (or Tres Pedras, dunno, Mexican city near El Paso), the trainees don't show up after I am done with the session. I am spawned alone in the village, noone to fight.

2. I met Carl Bine with an indian character, and he wanted me to die. I got the duel popup, retreated 8 steps, but nothing happened. When I then tabbed out of the city (it was the apache capital), I received a message saying that I failed the Billy's crescet mission.

3. After the Carl Bine incident I entered the commanche capitol, and I got -10 relations with the city. (might be because I had Smiling Rabbit in the party?)