Author Topic: Warband CPU Usage at 25% Capped  (Read 1980 times)

0 Members and 1 Guest are viewing this topic.

Renaud de Châtillon

  • Squire
  • *
    • View Profile
  • Faction: Neutral
  • MP nick: Ingolfr_Ivarrsson_Jomsborg
Warband CPU Usage at 25% Capped
« on: April 10, 2011, 12:04:11 PM »
Hello there,

My M&B Warband doesnt go higher then 25% of CPU Usage this is very annoying as the game gets really slow (I´m using an AMD Phenom 9950 Quad-Core 2,6 Ghz)
So far I´ve tried everything but nothing seems to work.
I´ve set Numproc to 4 on boot.ini.
I´ve set Affinity on Warband.exe in Taskmanager to 4 Cpu´s (all 4 cores are being used by the game but it wont go higher then 25% in overall. I also tried some tricks out posted on taleworlds about Affinity setting on Task Manager but they wont work either.)
I also tried it with Force Single Threading on and off aswell I tried to modify Warband.exe with Runwithaffinity but the game is still capped at 25% CPU Usage (with all 4 cores running the game)
My CPU does not seem damaged I´ve Stress tested it and it reaches 100% on Prime95 for example.

I´m having this problem on every version so far on M&B Warband its not because of 1.134

My Spec is:

(click to show/hide)
« Last Edit: April 10, 2011, 12:23:01 PM by Renaud de Châtillon »

saltjunkie

  • Regular
  • *
    • View Profile
  • Faction: Neutral
Re: Warband CPU Usage at 25% Capped
« Reply #1 on: May 24, 2012, 07:34:02 PM »
Hey there, did you ever find an answer to your important question? I'm having the same problem, and the solutions I'm trying are useless. Thanks.

Vincenzo

  • External Developer
  • *
  • Coder of code
    • View Profile
    • Flying Squirrel Entertainment
  • Faction: Neutral
  • MP nick: FSE_Vincenzo
  • M&BWBWF&SNW
Re: Warband CPU Usage at 25% Capped
« Reply #2 on: May 24, 2012, 08:37:55 PM »
Most stuff from the engine is run in the main thread, which is singlethreaded.
 

saltjunkie

  • Regular
  • *
    • View Profile
  • Faction: Neutral
Re: Warband CPU Usage at 25% Capped
« Reply #3 on: May 25, 2012, 09:14:37 AM »
Oh, well that makes sense. Is there any good tweak related to this?

kaleena

  • Regular
  • *
    • View Profile
  • Faction: Bandit
  • M&BWBWF&SNW
Re: Warband CPU Usage at 25% Capped
« Reply #4 on: May 25, 2012, 08:47:07 PM »
25% on a quad core is normal, the game doesn't really use more than 1 threads so 100%/4=25%. I think I've seen it go a bit higher on some occasions and I did no special tweak.

Since the fps is a bit higher when not using the "force single threading" the game is still taking advantage of having more than one core so you should just leave it as it is.
« Last Edit: May 25, 2012, 10:42:44 PM by kaleena »

saltjunkie

  • Regular
  • *
    • View Profile
  • Faction: Neutral
Re: Warband CPU Usage at 25% Capped
« Reply #5 on: May 26, 2012, 03:11:49 AM »
Thanks so much, that's very useful info. My rig is overkill and it can't run the 1000 man battles like others claim to; 500 at lowest settings seems like the playable limit. The two videos where I've seen it being done, their rigs were similar but less beefed. Moreover, one guy was only getting 25-30 fps, and the other had massive stutter...no thanks. Assuming that there are people with my rig that can run 1000 man battles, what I wonder is making the difference? Any ultimate factors that you've figured out?

My specs: Rigged for OCing w/ appropriate cooling. I monitor usage and temps.

CPU: i7 950 3.07  OCed to: 3.20, or 3.45, or 3.65 (Doesn't seem to make a huge diff. but should.)
Mobo: GA X58A-UD3R 1366
RAM: 12 GB ddr 3 triple channel corsair dominator extremeGT 2000 @ 1600, or 1860, or 1920
GFX: Evga GTX 470 x2 (SLI)(Fermi) 1280 mb--(gpu usage is always low and running at cooler temps., so no prob there. Also, the usage during Warband is spread evenly across both GPUs)
PSU: Silverstone Fortress series case w/ 850 watt
HDDs: A-DATA S599 SSD's in Raid 0, but game is in STEAM on my Samsung Spinpoint 1TB sata.
OS: Win 7 Professional 64-bit service pack 1
Warband Mod: Peloponnesian War -- THE ABOVE ISSUE IS RELATIVELY THE SAME IN THE VANILLA VERSION.

Thanks so much for info, and help everyone.

Vincenzo

  • External Developer
  • *
  • Coder of code
    • View Profile
    • Flying Squirrel Entertainment
  • Faction: Neutral
  • MP nick: FSE_Vincenzo
  • M&BWBWF&SNW
Re: Warband CPU Usage at 25% Capped
« Reply #6 on: May 26, 2012, 07:59:23 AM »
Try disabling SLI.
 

saltjunkie

  • Regular
  • *
    • View Profile
  • Faction: Neutral
Re: Warband CPU Usage at 25% Capped
« Reply #7 on: May 26, 2012, 06:13:14 PM »
THANKS FOR INPUT. Will do, but what are the reasons behind trying it? On that note, should I also run some tests with the SLI on but placing the PhysX processing solely on the second card?
 FYI, I employ NVidia Inspector to aid SLI function in varying games...i realize that it still might not have an effect in this case. Also, the cards temps are always great and OC'ing the card doesn't seem to improve performance with large battles.

Another note: I can play 250 man battles with max settings (no HDR) and all horsemen and get 50-60 fps even during clashes. For obvious reasons, I play with this size most of the time, but with hoplite battles would like to see if larger battles are possible. With the size of the maps, 600 men seem to be a perfect fit for the battles of Peloponnesian Wars mod.

saltjunkie

  • Regular
  • *
    • View Profile
  • Faction: Neutral
Re: Warband CPU Usage at 25% Capped
« Reply #8 on: May 30, 2012, 01:25:38 AM »
UPDATE: Turning off SLI didn't seem to do anything. When playing 600 man battles, the standard for all my current testing, I noticed that my gpu usage is at about 10-15% while using SLI and when it's off. It seems that while employing large numbers in battles, e.g., 300, 500, 600, etc., my GPU use goes down dramatically. Any Ideas; Is it that my cpu is the bottleneck here and the gpu is idling a lot? What do you all think is happening and any possible solutions, if any? Thanks.

sirbrocoli

  • Regular
  • *
  • IMA FIRIN MURAZOR!!!!!
    • View Profile
  • Faction: Swadian
  • MP nick: SA Brocoli
Re: Warband CPU Usage at 25% Capped
« Reply #9 on: May 30, 2012, 02:38:02 AM »
i have a decent rig and i cant seem to run anything great in M@B lol. 200 man battles i get like 15 frames and i dont understand.

rig:
phenom x6 t1035 3.1 ghz
8gb dual channel ram (unsure what brand)
evga gtx 560ti 2gb

can someone explain to me how to get it to run faster lol people with worse comps then me get better frames in warband and i dont understand
There should be a race for self righteous, stuck up people who display their false sense of superiority over the internet.

saltjunkie

  • Regular
  • *
    • View Profile
  • Faction: Neutral
Re: Warband CPU Usage at 25% Capped
« Reply #10 on: May 30, 2012, 05:57:07 PM »
Same question here. The fact that the game can't multithread, in terms of the CPU or GPU, would explain why our great systems can't play with too much more than 150 men on field, but the fact that others with lesser systems are doing it makes me wonder if there's something I can try. Have you tried all the known tweaks? If you do and something works, let me know...i'll do the same for you.  I've tried many tweaks, but no go.

Tweaks: forums.taleworlds.com/index.php?topic=138091.0

BTW, if you haven't tried tweaking your graphics card (gpu) in the Nvidia control panel, I'd start there first.
1) try setting the pre-rendered frames to zero, and see if there's a difference
2) you might want to try different drivers, esp. older ones--make sure they are right for your 560ti
3) I too have an EVGA, and I use the EVGA precision app to monitor my gpu usage, and temperatures. You can even use it to overclock your gpu a little and see if that helps at all. Just do NOT overclock and also check the Windows Start Up box selection...if the new speeds you select crash your pc, when it reboots your GPU will be at it's default speeds again and not starting up with the system crashing overclock specs.

*that being said, it's likely your cpu is causing the limit and not your GPU. Your CPU is just fine, but the game it seems is more CPU processing intensive than GPU, but ya never know if a gpu setting is limiting things until you rule it out. When I set my battles to 400-600 men (low fps and stutter occur), my gpu is barely used which tells me the hold up may very well be my CPU. Even overclocking my cpu doesn't seem to make much difference--I just don't think the game engine is really coded properly to be able to handle too much more than 150 men. However, others with less system "claim" to be able to, so what gives?