Author Topic: RGL Error : Unable to lock vertex buffer. Possible ways for fix error.  (Read 31204 times)

0 Members and 1 Guest are viewing this topic.

MAXHARDMAN

  • Knight
  • *
    • View Profile
  • Faction: Khergit
  • M&BWBWF&S
Mod    Speed&Stability 1.0    for v.1.011
Author: MAXHARDMAN.

- improve Native game speed and stability.
- fix or reduce number RGL error’s with vertex buffer memory.
- include improved version my “RGL Error – Missiles Fix”.
- if you don’t need speed , you may increase units number.

Mount&Blade used LODs (Level Of Detail) system for improve game performance but unfortunately not all models have LODs .
I make LODs for all other models in game ( more then 300 ) .

Same gamers ( and I too ) have RGL error’s with vertex buffer memory.
Then on screen to many objects with high polygons, video card don’t enough video memory , reduce number polygons fix this problem .

Mod may not really help if you use other mod with many new items and textures.
For sorry most modders not make LODs for his mods .
But mod anyway increase Speed & Stability.

New version 1.0.01
Make better compatibility with other mods . Must work now with all mods , but you need first install Speed&Stability and after another mods.


INSTALLATION : run Speed&Stability_1.0.exe and choose <Mount&Blade v1.11> folder.

UNINSTALLATION : run S&S_Uninstall.exe and choose <Mount&Blade v1.11> folder.

LINK : http://www.mbrepository.com/file.php?id=1545


About effectiveness my mod :
I use program 3DAnalyze to log parameters in game , so I must say PPS ( polygons per second ) drop in 2-3 time ! I test in open field ( quick battle 4 ) with 400 units ( 240 horseman ) In Native PPS was from 6-10 Mln polygons , after I install S&S PPS drop down to 3-5 Mln polygons :)


OLD POST :
Possible ways for fix  RGL Error : Unable to lock vertex buffer.

So how you know many peoples have this error then use battlesizer and/or big mods .
Here official description about this problem: http://forums.taleworlds.com/index.php/topic,68486.0.html

Like says in this article : “To resolve this you need to reduce the number of entities spawning.”
Recommendation : Disable corpse and reduce battlefield and also reinstall drivers.

I must say on early versions I play with 600 units and all corpse on and increase battlefield to 150 %  , and don’t have any problem . Why now on 1.011 I play with 300 and have this error in battles , specially in sieges ? Even then I disable corpse !?

1. In new vers ( and 1.011) after any man killed he drop weapon , and I must say many models in Native ( and MOST models in mods) don’t have LODs , so all this hi-poly staff just stay on field ! In siege you have min 200-400 units , after kill same number units dropped weapons grown dramatically !
2. I use siege tactics – before melee attack , I give my archers ( half from my man )  shoot all his arrow in enemy . Every arrow/thrown weapon have 100-200 polygons ( without LODs ) So then after fire from 100-arhcers I try to go on wall (go close – disable LODs) game is crash .

Spawning models :
1.   Dropped weapons.
2.   Units.
3.   Missiles ( arrows and thrown weapon) .

Hire ways for solution problem:

1.   Disable dropped weapon ! General problem ! I don’t find way for fix it in module . I think its hardcode . But if sameone know way for disable it , give us known ;)
I suggest for authors make option in menu for disabled dropped weapon. ( Or just disable this option , anyway its looks weird (non realistic) in game ).
2.   Disable corpse ( or make it small number ).
3.   Download my fix for missiles ( arrows and thrown weapon).

Authors mods also must think about add LODs and lo-poly model for ALL missiles models .

RGL Error – Missiles Fix .

In fix I remake and change to lo-poly every missile model in game . I try make lo-poly models looks like hi-poly . I hope you don’t see really big change in game. ;)

All arrows now have about 30 poly , in Native about 100-170 . Thrown weapons 30-70 , in Native 100-220.

After I make this fix RGL-error don’t disappear ( look I write about general problem ) BUT number error’s down in many times ! Now I can self fight on walls (early almost always game crash) Same time I have error AFTER finish siege ( 300-1000 units ) in loot menu. After restart game I may continue ( I use auto save regime ). So this fix really help me , and hope you too find it helpful . ;)

http://www.mbrepository.com/modules/PDdownloads/singlefile.php?cid=10&lid=1436
« Last Edit: October 31, 2009, 07:48:45 PM by MAXHARDMAN »

kavien

  • Sergeant at Arms
  • *
  • Permanently Banned
  • The Motherland
    • View Profile
    • Blades of Valiance Forums
  • Faction: Nord
Re: RGL Error : Unable to lock vertex buffer. Possible ways for fix error.
« Reply #1 on: August 08, 2009, 05:23:26 PM »
I get that error all the time in star wars conquest.
it always happens after I CTRL+Click on to many items, troops etc.
Bringin' Vintage Back

Divine_hammer

  • Recruit
  • *
    • View Profile
  • Faction: Neutral
Re: RGL Error : Unable to lock vertex buffer. Possible ways for fix error.
« Reply #2 on: August 09, 2009, 04:40:43 AM »
It is clearly the number of entities that are spawning in the battle. Which is why less number of rag dolls helps this. So the solution is clearly all these dang arrows and javelins stuck into everything those need to drop off just like bodies do. I am not sure if this is controllable in MB in its current state but I will take a look. This is also why reducing the polys for the arrows helps as well. If they just dropped off you could keep your high poly errors. However I am guessing they did not do this because then you wouldnt be able to have arrows stuck in your shield all battle which is cool but may have to sacrifice it to have less crashes.

jasonxfri13th

  • Sergeant Knight
  • *
  • He is Jesus and a Raptor combined
    • View Profile
  • Faction: Neutral
  • MP nick: jasonxfri13th
  • M&BWB
Re: RGL Error : Unable to lock vertex buffer. Possible ways for fix error.
« Reply #3 on: August 19, 2009, 05:42:53 AM »
finally, maybe I can turn corpses on again?

zdietz

  • Recruit
  • *
    • View Profile
  • Faction: Neutral
Re: RGL Error : Unable to lock vertex buffer. Possible ways for fix error.
« Reply #4 on: September 20, 2009, 07:53:51 PM »
I am getting this "Unable to lock vertex buffer" message as well. How do I go about doing the advised steps such as disabling corpses? I just bought this game and would really enjoy actually being able to play it...

Demoche

  • Recruit
  • *
    • View Profile
  • Faction: Khergit
Re: RGL Error : Unable to lock vertex buffer. Possible ways for fix error.
« Reply #5 on: September 22, 2009, 02:42:46 PM »
I have yet to find a solution to this error, near as i can tell lowering the graphics detail reduces the occurence but will not get rid of it (tho it is usually only a problem with sieges for me). The following is what i have noticed from my experiences, and the settings i currently use. I have up to date ATI Catalyst drivers for my 4850 512mb.

DirectX = I have found that i dont get these errors with DirectX 7 setting, if you can stomach the change then do it.

Resolution = I play in 1440x900 and tried 1280x960 and didn't notice any change in error regularity

Corpses = I play with it set to 0, which has all but stopped the error for normal battles.

Ragdoll = Again set to 0, after a while you get used to it.

Detail, Textures and character= at full, pride won't let me lower them, but likely would reduce errors.

Grass density = all the way down.

Blood Stains = off, i don't think they look all that great anyway

Shadows = if it has 'shadow' in its description then its off or as low as i can get it.

Dynamic lighting = i still have 'on' but this may change in future

Particle Systems = off, i did until recently have it on, but regularity of error was bugging me (excuse the pun).

AF = Turned it off, would be nice but cant play game with it and i dont care about how crisp the error box appears.....

Faster Water Reflections = On, don't tend to see much water reflections anyway and according to the performance % its better to have it on   

Pixel shader = off, honestly don't know how much it affects errors.

Vsync = i have kept on, reduces graphical 'screwups'

max frame rate = i kept on 100, didn't worry about changing it.

AA = Currently on 2x was on 4x (couldn't fight through a siege battle and running out of graphical options to decrease, lowered it from 4x to 2x and was able to finish battle).
 
Battlesize, smaller= less chance of vertex buffer issues, however with siege battles this seems to be irrelevant as as enemies will keep spawning until there all gone rather than breaking up battle into 'small chunks' like normal battles. I currently have it set to 200.

I have been trying many different mods and each one has had this error at least once (including native). I am also using the Missiles fix haven't noticed anything visually, and cant be sure if its improved stability but it hasn't affected the game adversely so i will keep using it.

The general rule of thumb seems to be that to get rid of the error ( and i don't know if its ATI, the games or Microsoft (explain the latter in a jiffy)) you lower the detail until you are happy with the stability you are getting.

With ATI settings i disabled certain features, seems to be important with a lot of games unfortunately, the way i figure it is that if i let the catalyst control centre to any of its 'adapting', customising or improving then games start to have problems. best i can say is a bit of trail and error in the '3d' settings. Also i don't know about others but sometimes when i get the error i will also get the ('scuse the wording) "ATI drivers had a heart attack but was revived, hoped you saved recently" sign in bottom right. A while back i checked the event viewer, (Right click ATI Control center in the whatzit... bottom right corner) and selected to look at 'Administrative Events' and found that the driver dying often occurred within a minute of 'windows defender' finding something with unknown program (in my case the unknown program had something to do with my catalyst drivers)......
I'm afraid i have no idea what performance or stability is like with Nvidia or any other brands cards, but if your getting the Vertex buffer errors then i'm assuming that lowering details will improve perfomance with those cards as well

I hope that my post helps, as the common rules regarding turning off or reducing ragdolls and corpses didn't work very well for me and it seems for others as well.

 
If i may make a recommendation regarding further development (via mods or later patches), could there be an option to turn off or reduced timespan for weapons, shields etc that get dropped from the dead, as i believe that this would drastically improve game performance and stability (that and siege battles look a tad... strange.. when theres a couple hundred weapons and shields surrounding the top of the ladder).




Praesi

  • Recruit
  • *
    • View Profile
  • Faction: Neutral
Re: RGL Error : Unable to lock vertex buffer. Possible ways for fix error.
« Reply #6 on: September 28, 2009, 06:22:45 PM »
Hi Everyone.

I got the same Probleme...like countless other people in the net. I searched every forum i could found..

I try everything. Lower everything, new drivers ect. I play Games since years...i know normaly what to do.
I reinstalled M&B, i "played" with mods..without mods....NOTHING helps.

There is just no way my computer cant handle this Game.
E8400
8800GTS
2GigRAM


I'm losing my patience!!

And try to play in dx7 ??..That must be a baaaaad joke...

The developers should put out a Patch to fix that...and that in a hurry.. :evil:

davek

  • Recruit
  • *
    • View Profile
  • Faction: Swadian
Re: RGL Error : Unable to lock vertex buffer. Possible ways for fix error.
« Reply #7 on: September 28, 2009, 07:43:51 PM »
I've found a solution for the unable to lock vertex buffer problem, which seems  to be working (at least for me). I copy the whole thing here:

ok this is a simple fix and i stumbled upon it while searching other forums for a os page pool memory problem.
BE WARNED THIS SOLUTION, IF NOT DONE CORRECTLY MAY BE HARMFUL TO YOUR COMPUTER.
Heres the solution:
Start Menu > Run > regedit

Surf down to this key. The REG_DWORD "PagedPoolSize"
Code:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Session Manager\Memory Management

Double click on "PagedPoolSize". Hexadecimal is listed first.
Change the "Value Data" to one of these below:
Note: You only need to enter EITHER Hexadecimal or Decimal.
They both are the same. I recomend using 256Mb should solve the problem.
Code:

Megabytes Hexadecimal Decimal
192Mb 0c000000 201326592
256Mb 10000000 268435456
384Mb 18000000 402653184

You do not need anything bigger than 400Mb... in most cases 300Mb is too much as well.

Once you are done, make sure you reboot your computer.


I don't know how does it work, but before it I got the vertex buffer message in every situation, no matter what dx version, even at the simplest grahpics settings and at a battle size only 25. So I can tell that its working for me, but I use a hexadecimal value of 20000000 (512MB) because with 256 and 384MB settings I was only able to play normal battles, but no sieges. Please notice that my board only supports x4 PCIE, so you should get good results with smaller settings (like 256MB).

My specs are:

Gigabyte G43 (PCIE x4)
E5200 @ 3,33GHz
4650 512MB DDR2
2x2GB 800MHz DDR2

All the above was originally for Half-life 2 for the same vertex buffer problem. I think they made a patch later for those, who payed for their product. Maybe Taleworlds should do the same, because it seems a lot of ppl suffer from this problem.
« Last Edit: September 28, 2009, 07:46:24 PM by davek »

Praesi

  • Recruit
  • *
    • View Profile
  • Faction: Neutral
Re: RGL Error : Unable to lock vertex buffer. Possible ways for fix error.
« Reply #8 on: September 28, 2009, 09:48:07 PM »
I've found a solution for the unable to lock vertex buffer problem, which seems  to be working (at least for me). I copy the whole thing here:

ok this is a simple fix and i stumbled upon it while searching other forums for a os page pool memory problem.
BE WARNED THIS SOLUTION, IF NOT DONE CORRECTLY MAY BE HARMFUL TO YOUR COMPUTER.
Heres the solution:
Start Menu > Run > regedit

Surf down to this key. The REG_DWORD "PagedPoolSize"
Code:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Session Manager\Memory Management

Double click on "PagedPoolSize". Hexadecimal is listed first.
Change the "Value Data" to one of these below:
Note: You only need to enter EITHER Hexadecimal or Decimal.
They both are the same. I recomend using 256Mb should solve the problem.
Code:

Megabytes Hexadecimal Decimal
192Mb 0c000000 201326592
256Mb 10000000 268435456
384Mb 18000000 402653184

You do not need anything bigger than 400Mb... in most cases 300Mb is too much as well.

Once you are done, make sure you reboot your computer.


I don't know how does it work, but before it I got the vertex buffer message in every situation, no matter what dx version, even at the simplest grahpics settings and at a battle size only 25. So I can tell that its working for me, but I use a hexadecimal value of 20000000 (512MB) because with 256 and 384MB settings I was only able to play normal battles, but no sieges. Please notice that my board only supports x4 PCIE, so you should get good results with smaller settings (like 256MB).

My specs are:

Gigabyte G43 (PCIE x4)
E5200 @ 3,33GHz
4650 512MB DDR2
2x2GB 800MHz DDR2

All the above was originally for Half-life 2 for the same vertex buffer problem. I think they made a patch later for those, who payed for their product. Maybe Taleworlds should do the same, because it seems a lot of ppl suffer from this problem.

Hi.

Didn´t work 4 me. After restart not 1 .exe works anymore. And no Systemprogramm worked. Only with Safemode it was possible to restore the reg.
I chosed 256 like u said :(

Damn it, i want to play this game so bad :/

davek

  • Recruit
  • *
    • View Profile
  • Faction: Swadian
Re: RGL Error : Unable to lock vertex buffer. Possible ways for fix error.
« Reply #9 on: September 29, 2009, 07:48:44 AM »
Are you sure you typed it correctly? If "hexadecimal" is selected, then the value is: 10000000, if "decimal" is selected, then: 268435456. Its no matter which one is selected, but you should give the value which belongs to that one. How much ram do you have?

I've found a solution for the unable to lock vertex buffer problem, which seems  to be working (at least for me). I copy the whole thing here:

ok this is a simple fix and i stumbled upon it while searching other forums for a os page pool memory problem.
BE WARNED THIS SOLUTION, IF NOT DONE CORRECTLY MAY BE HARMFUL TO YOUR COMPUTER.
Heres the solution:
Start Menu > Run > regedit

Surf down to this key. The REG_DWORD "PagedPoolSize"
Code:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Session Manager\Memory Management

Double click on "PagedPoolSize". Hexadecimal is listed first.
Change the "Value Data" to one of these below:
Note: You only need to enter EITHER Hexadecimal or Decimal.
They both are the same. I recomend using 256Mb should solve the problem.
Code:

Megabytes Hexadecimal Decimal
192Mb 0c000000 201326592
256Mb 10000000 268435456
384Mb 18000000 402653184

You do not need anything bigger than 400Mb... in most cases 300Mb is too much as well.

Once you are done, make sure you reboot your computer.


I don't know how does it work, but before it I got the vertex buffer message in every situation, no matter what dx version, even at the simplest grahpics settings and at a battle size only 25. So I can tell that its working for me, but I use a hexadecimal value of 20000000 (512MB) because with 256 and 384MB settings I was only able to play normal battles, but no sieges. Please notice that my board only supports x4 PCIE, so you should get good results with smaller settings (like 256MB).

My specs are:

Gigabyte G43 (PCIE x4)
E5200 @ 3,33GHz
4650 512MB DDR2
2x2GB 800MHz DDR2

All the above was originally for Half-life 2 for the same vertex buffer problem. I think they made a patch later for those, who payed for their product. Maybe Taleworlds should do the same, because it seems a lot of ppl suffer from this problem.

Hi.

Didn´t work 4 me. After restart not 1 .exe works anymore. And no Systemprogramm worked. Only with Safemode it was possible to restore the reg.
I chosed 256 like u said :(

Damn it, i want to play this game so bad :/

Praesi

  • Recruit
  • *
    • View Profile
  • Faction: Neutral
Re: RGL Error : Unable to lock vertex buffer. Possible ways for fix error.
« Reply #10 on: September 29, 2009, 09:01:59 PM »
Are you sure you typed it correctly? If "hexadecimal" is selected, then the value is: 10000000, if "decimal" is selected, then: 268435456. Its no matter which one is selected, but you should give the value which belongs to that one. How much ram do you have?

I've found a solution for the unable to lock vertex buffer problem, which seems  to be working (at least for me). I copy the whole thing here:

ok this is a simple fix and i stumbled upon it while searching other forums for a os page pool memory problem.
BE WARNED THIS SOLUTION, IF NOT DONE CORRECTLY MAY BE HARMFUL TO YOUR COMPUTER.
Heres the solution:
Start Menu > Run > regedit

Surf down to this key. The REG_DWORD "PagedPoolSize"
Code:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Session Manager\Memory Management

Double click on "PagedPoolSize". Hexadecimal is listed first.
Change the "Value Data" to one of these below:
Note: You only need to enter EITHER Hexadecimal or Decimal.
They both are the same. I recomend using 256Mb should solve the problem.
Code:

Megabytes Hexadecimal Decimal
192Mb 0c000000 201326592
256Mb 10000000 268435456
384Mb 18000000 402653184

You do not need anything bigger than 400Mb... in most cases 300Mb is too much as well.

Once you are done, make sure you reboot your computer.


I don't know how does it work, but before it I got the vertex buffer message in every situation, no matter what dx version, even at the simplest grahpics settings and at a battle size only 25. So I can tell that its working for me, but I use a hexadecimal value of 20000000 (512MB) because with 256 and 384MB settings I was only able to play normal battles, but no sieges. Please notice that my board only supports x4 PCIE, so you should get good results with smaller settings (like 256MB).

My specs are:

Gigabyte G43 (PCIE x4)
E5200 @ 3,33GHz
4650 512MB DDR2
2x2GB 800MHz DDR2

All the above was originally for Half-life 2 for the same vertex buffer problem. I think they made a patch later for those, who payed for their product. Maybe Taleworlds should do the same, because it seems a lot of ppl suffer from this problem.

Hi.

Didn´t work 4 me. After restart not 1 .exe works anymore. And no Systemprogramm worked. Only with Safemode it was possible to restore the reg.
I chosed 256 like u said :(

Damn it, i want to play this game so bad :/

2gig RAM

Praesi

  • Recruit
  • *
    • View Profile
  • Faction: Neutral
Re: RGL Error : Unable to lock vertex buffer. Possible ways for fix error.
« Reply #11 on: September 30, 2009, 01:00:34 AM »
Are you sure you typed it correctly? If "hexadecimal" is selected, then the value is: 10000000, if "decimal" is selected, then: 268435456. Its no matter which one is selected, but you should give the value which belongs to that one. How much ram do you have?

I've found a solution for the unable to lock vertex buffer problem, which seems  to be working (at least for me). I copy the whole thing here:

ok this is a simple fix and i stumbled upon it while searching other forums for a os page pool memory problem.
BE WARNED THIS SOLUTION, IF NOT DONE CORRECTLY MAY BE HARMFUL TO YOUR COMPUTER.
Heres the solution:
Start Menu > Run > regedit

Surf down to this key. The REG_DWORD "PagedPoolSize"
Code:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Session Manager\Memory Management

Double click on "PagedPoolSize". Hexadecimal is listed first.
Change the "Value Data" to one of these below:
Note: You only need to enter EITHER Hexadecimal or Decimal.
They both are the same. I recomend using 256Mb should solve the problem.
Code:

Megabytes Hexadecimal Decimal
192Mb 0c000000 201326592
256Mb 10000000 268435456
384Mb 18000000 402653184

You do not need anything bigger than 400Mb... in most cases 300Mb is too much as well.

Once you are done, make sure you reboot your computer.


I don't know how does it work, but before it I got the vertex buffer message in every situation, no matter what dx version, even at the simplest grahpics settings and at a battle size only 25. So I can tell that its working for me, but I use a hexadecimal value of 20000000 (512MB) because with 256 and 384MB settings I was only able to play normal battles, but no sieges. Please notice that my board only supports x4 PCIE, so you should get good results with smaller settings (like 256MB).

My specs are:

Gigabyte G43 (PCIE x4)
E5200 @ 3,33GHz
4650 512MB DDR2
2x2GB 800MHz DDR2

All the above was originally for Half-life 2 for the same vertex buffer problem. I think they made a patch later for those, who payed for their product. Maybe Taleworlds should do the same, because it seems a lot of ppl suffer from this problem.

Hi.

Didn´t work 4 me. After restart not 1 .exe works anymore. And no Systemprogramm worked. Only with Safemode it was possible to restore the reg.
I chosed 256 like u said :(

Damn it, i want to play this game so bad :/

2gig RAM

I tryed again and this time it worked, BUT the crash happens anyway..
The only change now is, that i can do 2-3 Fights bevore it crashes.

I like this game, but its not playble with this error.........

Praesi

  • Recruit
  • *
    • View Profile
  • Faction: Neutral
Re: RGL Error : Unable to lock vertex buffer. Possible ways for fix error.
« Reply #12 on: September 30, 2009, 11:55:01 AM »
Is there a patch comming soon to fix that ??..

OMG.

Here are Threads from LAST YEAR with this Problem and till now nothing happens to fix that?.

U cant be serious.....
« Last Edit: September 30, 2009, 12:10:36 PM by Praesi »

davek

  • Recruit
  • *
    • View Profile
  • Faction: Swadian
Re: RGL Error : Unable to lock vertex buffer. Possible ways for fix error.
« Reply #13 on: September 30, 2009, 06:52:03 PM »
The admin keeps sayin' that its a problem with drivers or system resources, although it affects both ati and nvidia cards, even top-class configurations, and most of us don't have any problems with games at all - except this one. Its very sad... Warbands beta is coming, but what about the original game? We want a fix ASAP!

Is there a patch comming soon to fix that ??..

OMG.

Here are Threads from LAST YEAR with this Problem and till now nothing happens to fix that?.

U cant be serious.....

MAXHARDMAN

  • Knight
  • *
    • View Profile
  • Faction: Khergit
  • M&BWBWF&S
Re: RGL Error : Unable to lock vertex buffer. Possible ways for fix error.
« Reply #14 on: October 30, 2009, 06:55:17 AM »
For same reasons ( I think because sign “&” ) when you before try download Speed&Stability_1.0.exe you have file Speed without “.exe” , so you may rename file to Speed.exe and install mod , or reupload fixen name file SpeedStability_1_0.exe
Sorry about that, I must test it self, just upload file last night in 2 am  :roll: