Author Topic: If you have Performance Issues, Crash and RUNTIME ERRORs Look here  (Read 93074 times)

0 Members and 1 Guest are viewing this topic.

Idibil

  • Moderator
  • *
    • View Profile
    • Nova Regula
  • Faction: Nord
  • MP nick: CeltíberoIdibil

If you have runtime or crash, maybe you need use some of these performance patchs:

If you have PC old: <4 GB of memory and <1GB of graphic card, you can try this performance patch:

http://www.4shared.com/rar/TOVY_O0-/brytenwalda512x512.html

 

If you have a PC very old: (<2 GB memory), you can try this other patch:

http://www.4shared.com/rar/7taQHHsh/brytenwalda256x256.html


If this dont fix your issue, then continue reading...


----------------------------

    If you have continous CTD issues you need read this guie, but before you try this (steps copy of JohnT)
1) remove the mod and the game completely
2) defrag all hard disk drives/partitions on your PC
3) re-install the game
4) before launching the game, disable/kill all applications that run in the background
6) if you have no network sharing [i.e. single computer at home] disable your memory resident antivirus for limited extra performance gain
    A Good Graphics Card with generous dedicated vRAM is needed for anything to do with 3D environments (battle screens)
    For the campaign map, it is calculations that is being done in the background and that requires A LOT of CPU power
    Naturally enough RAM is also required to store the data that is to be processed.


Known things that will cause you to CTD or Lag heavily!
Autor: Kinsume in 1257 forum.
Link: http://forums.taleworlds.com/index.php/topic,127609.0.html

(click to show/hide)




-----------------------------
1. Solution.

Well, generally your crash and Runtime erros isnt bugs, it can be problem of performance or low memory. Brytenwalda 1.34 need best PC than 1.332 or native.

A solution that is fix 85% of the problems is here:

http://forums.taleworlds.com/index.php/topic,131274.0.html
-----------------------------

2. Solution

Other solution is that you look your configuration, if you have problem same you need change something to:

Enable Cheats = Off
Load Textures on demand = ON
Texture detail = 60%
Antialissing = Off
Shadow Quality = Low

Enable Edit mode = Off
Force Single Threading = ON (Mount&Blade supports multi-core processors. You can use this option if for some reason your multi-core processor is not handled correctly, or if your single-core processor is incorrectly recognised as a multi-core. If you have a multi-core processor you should always leave this option off unless you have problems, as turning it on will reduce performance.)

-You max the corpses at 40
-This could to be a potential problem with a video card with limited video memory.  You can reducing the texture size in the Warband configuration options.  Please reduce the texture size until your crashing stops.

More:
-You try to change the render_buffer_size parameter: rgl_config.txt

The default value is something like 15, but people reported good results in the past setting it to 100 or more (will depend on your GPU RAM size).

-There is another parameter there: disable_frequency_variation

-If you turn off 'load textures on demand', it doesn't load the textures into RAM for use when a scene is built and actors are placed.  Instead, it's putting all of the textures into VRAM.  This causes a crash upon game load if the end-user doesn't have enough room, throwing a fairly mysterious-sounding error message, instead of gracefully switching off the option and loading normally.


More information here:

http://strategywiki.org/wiki/Mount%26Blade/Configuration


However, if you have this problem and you fix it, post your solution plz, others player can need it.

 ------------------------

3. Solution


Quote
I am crashing on the first page. The very first page when you are loading the game. When I am loading I get a RGL error. Solutions?

Autor: Derraa


- Go to Documents
- Open Mount&Blade Warband folder
- Open rgl_config
- Change the value in render_buffer_size to 256 ( after playing Brytenwalda if you play another mod change it to the previous value; i.e: mine was 2048)
- Enter game, new game.
- Play and have fun.
---------------------------------

4. Solution


Autor: Evil_BG

Problem:
Quote
When I play for 20 minutes it gives me that release time or somthing CLOSED my game and I can't play...

Solution:
Quote
Im with Dual CPU so I enabled the single threading ... Otherwise I buffed my settings to the max and now I play with no problem, I also did another thing.
I went to My Documents and opened the warband folder then opened rgl_config and I pressed CTRL and F and typed in render_buffer_size then I changed it to 256... I don't remember what it was before but I have no problems now. The game is so nice when its on maximum settings.

-------------------------

5. Solution

If you cannt enter to taverns or towns, it is a Warband 1.143 bug with some configurations, you need open your module.ini (in Brytenwalda mod), and change disable_moveable_flag_optimization = 0 to disable_moveable_flag_optimization = 1

----------------------

6. Solution

Autor: Treebeard

Graphic Performance Problem:

Best current fix (for some people): So far the best temporary fix is to comment away all buffer_size lines.
The game_variables.txt file can be found in your module's name (e.g. Native) and is located in the Module folder where you installed Warband.
Example:

C:\Program Files (x86)\Mount&Blade Warband\Modules\Native

Before you modify game_variables.txt, make a copy of it so you have a backup, in case you make a mistake and you want to go back to the original.
To deactivate the lines put a # in front of them:

Code: [Select]
#new_buffer_size_dx7_regular_ffp_static  = 262144
#new_buffer_size_dx7_regular_ffp_dynamic = 262144

#new_buffer_size_regular_ffp_static =  32768
#new_buffer_size_regular_ffp_dynamic     =  32768
#new_buffer_size_regular_static          = 131072
#new_buffer_size_regular_dynamic         =  65536
#new_buffer_size_skinning_static         = 131072
#new_buffer_size_skinning_dynamic        =  65536
#new_buffer_size_normal_map_static       = 131072
#new_buffer_size_normal_map_dynamic      =  65536
#new_buffer_size_normal_map_skinning_static  = 131072
#new_buffer_size_normal_map_skinning_dynamic =  65536

The reason for commenting them away is that if they are not there, then the game engine uses its own hard coded default values, and those values seem to work better.


---------------------------------------------------------------------------------

--------------------------------


7. Solution

Autor: Harper2010


Quote
Anyhow for the life of me I could not get this mod to even start up in the game, giving me runtime errors on the loading bar screen once it reached the "loading setting data" part at the end. Well after trying about everything else I realized that when I downloaded it (saving it to downloads not clicking on run) that because I used one of the "alternative" download sites I had gotten a warning about that website not being trusted...I clicked on "run any way"...it installed fine but wouldn't run. Well apparently when it ran the installer it did not run with admin rights (windows 7)(nor did it even give me the option to). Even though the mod seemed to be all there when I inspected it, it apparently caused this error.

Solution= Erased the new version, went to my downloads folder and reinstalled with admin rights and now the mod loads up fine. So to anyone who has had this problem before and couldn't understand why....this might be your ticket to kick some pict butt.
If you installed using alternate website(forget which one of the two) and you got an error message about it not being trusted...just exit that out and goto download folder and  install with admin rights.

And before anyone blasts me....yes I always run everything with admin rights with win7 but the way this turned out I did not have the option too and for some dumb reason it didnt occur to me at first.
« Last Edit: February 21, 2012, 08:34:02 PM by Idibil »

Gulchatay

  • Guest
Re: If you have RUNTIME ERRORs Look here
« Reply #1 on: July 19, 2011, 04:08:05 PM »
A solution that is fix 85% of the problems is here:
http://forums.taleworlds.com/index.php/topic,131274.0.html
well intel core2 duo e6300, 3GB ram and radeon hd 3850 should be enough, i have had couple of times runtime error, using clean install(none of the alternative mods installed) of Brytenwalda, load textures on demand checked, hdr on, all settings on high. the hint to modify the ini bootfile from that thread do help. no runtime errors anymore, yay. give it a try, might help you guys.
« Last Edit: July 19, 2011, 04:11:00 PM by Gulchatay »

Hengwulf

  • Sergeant Knight
  • *
  • *Play nice children
    • View Profile
  • Faction: Neutral
  • MP nick: Hengwulf Erlinga
Re: If you have RUNTIME ERRORs Look here
« Reply #2 on: July 19, 2011, 06:44:23 PM »
For all you sceptics. This really works. It seems daunting, changing your logs but it is easy and it work fine for me.

I am not computer expert but this is bassicaly what I understand from it.

If you have 32 bit system, which most of us have, you have a RAM maximum (2 to the 32th is about 4 gig). I have a 32 bit system but I never have 4 RAM ( which I have) because other stuff like motherboard / Graphic card, also take up RAM memory. Your pc simply caps the amound of RAM for 1 process. With this you turn that up.

So as far as I follow: When you get a CTD for saving(f.e) normally your pc says "to much memory required I quit". Now we give the pc some extra (unused) memory to do just that singular action. (like saving/loading)

The thread link explains it way better.

BUT: it is not hard, it does work (for most) and we can enjoy this mod way better!

Just a thought from a , scared to **** up system guy, to say it CAN work
« Last Edit: July 19, 2011, 07:04:50 PM by Hengwulf »

Stitch74

  • Sergeant at Arms
  • *
    • View Profile
  • Faction: Rhodok
  • WB
Re: If you have RUNTIME ERRORs Look here
« Reply #3 on: July 19, 2011, 08:06:13 PM »
It worked for me too.   I was also worried about changing my computer settings, but everything worked out fine.  It turns out the my computer had its VM(Virtual memory) lower than it was supposed to.  So now I can play Bryrenwalda with no crashes. :D

Idibil

  • Moderator
  • *
    • View Profile
    • Nova Regula
  • Faction: Nord
  • MP nick: CeltíberoIdibil
Re: If you have Crash and RUNTIME ERRORs Look here
« Reply #4 on: July 25, 2011, 03:51:16 PM »
Update with Evil_BG solution.

gotrek

  • Recruit
  • *
    • View Profile
  • Faction: Nord
  • WB
Re: If you have Crash and RUNTIME ERRORs Look here
« Reply #5 on: July 26, 2011, 12:34:43 AM »
I used to play Brytenwalda1.33 fine and still do as the roman submod.
But since installing the newer version of MB Brytenwalda I get crashes whenever I enter a battle, big or small. I ge a lagging and then a CTD with a run time error. Why do I get it only on this version and not on 1.33? I tried playing on low settings instead of mediu and someof the fixes you give in these topics but it changed nothing.

I use a Intel core duo 3.16Ghz
2046 Mb rAM
Nvidia Geforce 9600GT 512 Mb

Please help.  :?

Idibil

  • Moderator
  • *
    • View Profile
    • Nova Regula
  • Faction: Nord
  • MP nick: CeltíberoIdibil
Re: If you have Crash and RUNTIME ERRORs Look here
« Reply #6 on: July 26, 2011, 08:26:38 AM »
I imagine that you have try previus solutions. If you can post your rgl_log.txt (warband folder) when you get crash, it can help.-

noks99

  • Recruit
  • *
    • View Profile
  • Faction: Vaegir
Re: If you have Crash and RUNTIME ERRORs Look here
« Reply #7 on: July 30, 2011, 03:28:02 AM »
hello everytime i click visit my camp or try to walk around in a city i get a c++ runetime crash

deathsmotto

  • Recruit
  • *
  • All war is deception - Sun Tzu
    • View Profile
  • Faction: Nord
  • MP nick: DeathsMotto
  • WB
Re: If you have Crash and RUNTIME ERRORs Look here
« Reply #8 on: July 31, 2011, 10:20:00 AM »
(click to show/hide)

Thats my rgl_log file, i seriously hope someone can help me... i posted another thread but it seems that one is sliding back..

Also, i have crashed from many errors as i fiddled with settings suggested throughout brytenwalda forum.. C++, postFX (?), RGL, low memory (i think i fixed that one), etc

edit: i completely reinstalled again and got a c++ error... i seem to only crash whenever the game has to load characters, (eg battle or talk to npc).. otherwise it seems ok.

(click to show/hide)

second attempt...
« Last Edit: July 31, 2011, 03:53:54 PM by deathsmotto »

deathsmotto

  • Recruit
  • *
  • All war is deception - Sun Tzu
    • View Profile
  • Faction: Nord
  • MP nick: DeathsMotto
  • WB
Re: If you have Crash and RUNTIME ERRORs Look here
« Reply #9 on: July 31, 2011, 04:20:23 PM »
Nvm got it working :D

I finally did the Command prompt thing (As Administrator this time) and it works... So far

Adders

  • Recruit
  • *
    • View Profile
  • Faction: Khergit
Mod is broken
« Reply #10 on: August 05, 2011, 12:45:16 PM »
Well, I've read the posts, tried all the advice, and Brytenwalda still crashes every minute or 2. Different messages with the crashes, sometimes no message, sometimes crash means I have to log off. Absolutely unplayable. It crashes if I pause, crashes if I click on a menu, crashes if I leave a location. The problem with this is that I'm a history buff who REALLY wants to play this mod! Would be easier to just go play a different game, one that WORKS!

My setup is:
Phenom II X6 1090T
3.25GB usable RAM
Win 7 32 bit
Tried both GeForce GTX560 and ATI HD5850 overclocked

Played vanilla Warband for 200 hours no problems. System can play things like Witcher 2 on highest setting. Nothing wrong with my computer.

Things I tried doing to fix the crashes:

2 different graphics cards
Reverted ATI catalyst to 10.5
made sure latest mod version and latest Warband version
Followed all installation instructions, graphics setting instructions etc. etc.
Increased virtual memory
Using latest DirectX
Tried in DirectX 7 and DirectX9
Tried on absolute LOWEST graphics setting in game
Using game settings recommended on this forum
Unplugged the network cable
Re-installed

And apart from making the graphics look like gaming back in the 80's, NONE of those things made any difference. I can't even go to the next town without it crashing.

I've never spent so much time trying to get a game to work. Loads of top-notch games work great on my computer. If I can't get any working advice about making this mod work, I'm...... ugh.

So, I've read the posts, tried the 'fixes', and this mod is still broken.

Most recent log file is here

(click to show/hide)

Idibil

  • Moderator
  • *
    • View Profile
    • Nova Regula
  • Faction: Nord
  • MP nick: CeltíberoIdibil
Re: If you have Crash and RUNTIME ERRORs Look here
« Reply #11 on: August 05, 2011, 01:43:30 PM »
Rest of people play it, I dont think that mod is broken  :lol:

However, in this log you have this problem: HERR_BUFFER_LOCK_FAILED!

It could be a sound problem.

You can see solutions to this problem here:
http://forums.taleworlds.com/index.php/topic,166405.msg4034684.html#msg4034684

http://forums.taleworlds.com/index.php/topic,147577.msg3554046.html#msg3554046

You can try too
http://forums.taleworlds.com/index.php/topic,131274.0.html


You can look too
http://forums.taleworlds.com/index.php/topic,113029.msg2728668.html#msg2728668


however, if you post your rgl_config.txt (in your documents \ warband folder), it can help us to meet problem.
 

Adders

  • Recruit
  • *
    • View Profile
  • Faction: Khergit
Re: If you have Crash and RUNTIME ERRORs Look here
« Reply #12 on: August 05, 2011, 02:33:59 PM »
OK Idibil, I'll try those posts. I understand it works for others, but you could imagine my supreme frustration at trying so many things to no avail.

rgl file as follows

(click to show/hide)

Thanks for trying to help

Adders

  • Recruit
  • *
    • View Profile
  • Faction: Khergit
Re: If you have Crash and RUNTIME ERRORs Look here
« Reply #13 on: August 05, 2011, 02:35:31 PM »
Oh, I should just ad:

That file is from when I just finished playing vanilla on high settings. Enjoying kicking Nord arse as the king. I tried ultra-low settings on Brytenwalda.

Adders

  • Recruit
  • *
    • View Profile
  • Faction: Khergit
Re: If you have Crash and RUNTIME ERRORs Look here
« Reply #14 on: August 05, 2011, 03:03:19 PM »
OK, to update you guys - I tried Brytenwalda again, doing all the things I've read and been told

Did in in low res, 16 bit graphics
Disabled sound and music (in case it was a sound problem)
Forced single threading
Lowest graphics settings
DirectX7
Put # in front of places on cfg file I read about following link from Idibil

And it still crashed after a minute or 2.

Ugh

rgl_config is here
(click to show/hide)

rgl_log is here
(click to show/hide)

Might have something to do with
 WARNING: UNABLE TO MAP GAME PRESENTATION CODE:  prsnt_game_start
 WARNING: UNABLE TO MAP GAME PRESENTATION CODE:  prsnt_game_escape

I'm still trying, despite hours of frustration, because of a belief that this mod will be the best! Am I wrong? Am I trying in vain?

There's got to be some other issues. I'm running Win7 Ultimate 32 bit. Is that the problem?